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LVelcome to the world of Microsoft Excel, the most popular and power-
ful spreadsheet program in the world. You may ask: “What is a
spreadsheet program?” A spreadsheet program is a computer program that fea-
tures a huge grid designed to display data in rows and columns. You can use
it to perform mathematical, logical, and other types of operations on the
data you enter. You can sort the data, enhance it, and manipulate it in a
plethora of ways — including creating powerful charts and graphs from it.
Whether you need a list of names and addresses or a document to calculate
next year’s sales projections based on prior year’s performance, Excel is the
application you want to use.

About This Book

This book provides the tools you need to successfully tackle the potentially
overwhelming challenge of figuring out how to use Microsoft Excel. In this
book, you discover how to create spreadsheets; however, what you do with
them is totally up to you. Your imagination is the only limit!

Why You Need This Book

Time is of the essence, and you probably don’t have the time to read a lot.
You just need to complete a task effectively and efficiently. This book is full
of concise, easy-to-understand steps designed to get you quickly up and run-
ning with Excel. I take you directly to the steps for a desired task without all
the jibber-jabber that’s often included in other books.

Even if you've used Excel in the past, Excel 2010 brings many new features
and major changes to existing features. This book helps ease the transition
from earlier Excel versions.

| “*troduction

Conventions used
in this book

w= When you need to type something, | put it in
bold typeface.

w= For Ribbon commands, | use the => symbol to
separate menu opfions. For example, “Choose
Inserte>Picture in the lllustrations group” says,
“Click the Insert tab and then from the
llustrations group, click the Picture button.”

= [n some figures, you see circled items. This is
done to help you locate items mentioned or
referred to in the text.

This icon points out fips and helpful sug-
gestions related to the current task.
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How This Book Is Organized

This book is divided into 24 chapters broken into 6 convenient
parts:

Part I: Putting Excel to Work

In Chapter 1, you uncover the basics of working with Excel
files, such as opening, closing, and saving files. In Chapter 2,
you work with entering the different types of data into Excel
worksheets, and in Chapters 3 and 4, you create various types
of formulas and functions to perform worksheet calculations.
Chapter 5 shows you how to protect your work with Excel’s
security features.

Part II: Sprucing Up Your Spreadsheets

Chapters 6 and 7 show you how to dress up the data you
enter into a worksheet using data alignment, formatting
values, changing fonts or colors, and adding cell borders.
In Chapter 8, you work with graphics, such as arrows and
Clip Art. In Chapter 9, you use workbooks consisting of
multiple worksheets, hyperlinks, and cross-references.

Part 111: Viewing Data in Different Ways

This part shows how you can modify the way Excel displays cer-
tain workbook options on your screen. Chapter 10 illustrates
changing the worksheet views. In Chapter 11, you sort your data
to make it easier to locate particular pieces of information.
Chapter 12 enables you to create charts to display your data in a
superb graphic manner. In Chapter 13, you work with the differ-
ent output methods, including printing and e-mailing your
worksheets. The last chapter in this part, Chapter 14, shows you
several timesaving tools included with Excel.

Part 1U: Analyzing Data with Excel

Use these chapters to effectively analyze all the data you input
into a worksheet. In Chapters 15, 16, and 17, you work with
Excel outlines, filters, and PivotTables, respectively. Chapter 18
shows you how you can create macros to save data entry and
formatting time.

Part U: Utilizing Excel with Other People and
Applications

Chapters 19-22 are all about sharing: sharing Excel with others
by using Excel’s collaboration features or sharing Excel with

Microsoft Office applications such as Word, PowerPoint, and
Access.

Part Vl: Practical Applications for Excel

Go to these chapters to save yourself time with a Commission
Calculator worksheet (Chapter 23), or a medical-expense track-
ing worksheet (Chapter 24).

Back Cover: Using Excel Shortcut Keys

This helpful list shows you many shortcut keys that make
access to Excel functions faster and easier.

Get Ready To . . .

To get started creating formulas, sorting data, adding a chart, or
building macros, just flip through this book, pick a task, and
dive in. The tasks in this book help you quickly master Excel.



Part |
Putting Excel to Work

T

@

he 5th Wave By Rich Tennant
A ,

%“\ AN %
v IS
e
s

Y

)
IS







Working with
Excel Files

E(cel is like a giant accountant ledger sheet composed of a grid made up
of columns and rows. At each row and column intersection is a cell. A

single worksheet contains 16,374 columns across the top (stretching from

column A to column XFD) and 1,048,576 rows down the side. That’s over

17 billion cells in a single worksheet. A cell address is the description of the

intersection of a column and a row, such as D23 (in this example, D is the
column name and 23 is the row).

The Excel interface provides you with the right tools at the right time. In
most Windows programs, you see menus and toolbars to select your options
from. Instead of the traditional look, Excel provides icon- and button-laden
tabs on the Ribbon containing most Excel features.

Throughout the course of this book, you discover methods to use Excel as a
spreadsheet, of course; but you also discover how to use it as a database, a
calculator, a planner, and even a graphic illustrator. I start with the basics
and work into the more advanced Excel actions.

In this chapter, you discover how to
m= Open and close the Excel program.
w= Work in the new Backstage View.
w=  Select commands with your keyboard.
w= Change information on your status bar.
m= Create, open, and save Excel workbooks.
m= Convert earlier files to Excel 2010.
m= Delete and rename workbook files.

w= Use workbook properties to better manage your files.

”'%apter

Get ready to. . .

w= Open and Explore Excel.....................ccoueneees 6
w= Explore Backstage View..................coooveeeeee 7
= Close Excel 1
= Select Commands with the Keyboard............ 8
w= Change Status Bar Indicators.............ooon.... 8
= (reate a New Excel File..................oooovvveeeees 9
w= Save a Workbook 9
w= Save a Workbook in a Ditferent Format .......10
= Open an Existing Excel File........................ 10
w= Convert a Prior Version File to Excel 2010.......11
w= Delete a File 1
w= Rename a File 12
= Specify Workbook Properties..................... 12



Chapter 1: Working with Excel Files

Open and Explore Excel

£ d H Booit - Mirnalt Excel =& @
\ Tt Pagilmod  Fumadn Dty Brdiew Vs s o
LA oy u A Iart -
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1. Choose Start=>All Programs=>Microsoft Offices>Microsoft R e W W S
Excel 2010. The Microsoft Excel program begins with a new, | — \ ”\ \ \" A .
blank workbook displayed ready for you to enter data. Figure i\ \ W - \ {
1-1 illustrates some of the common workbook components. ; \.‘.. “},, \ | II]I e '||
- = Accuss Ribbon |
2. Click any tabs, or task-oriented portions, of the Ribbon. The ! \ ﬁ.q |'|
first tab, which is displayed in a color different from the i Colurmn headings
other tabs, is called File. Clicking File displays the Excel 5 Tt
Backstage View, which you find more about in the next sec- pe———"rnae
tion. The remainder of the tabs is broken down into subsec- 5
tions, or groups. For instance, the Home tab includes the z
Clipboard, Font, Alignment, Number, Styles, Cells, and Workchoot tabe Stotus bar View buttons
Editing groups. Point your mouse over any button, and a : f; I
description of the tab’s features appear. P/ i \¥
) ) . :b:ﬂ: # | Gheef] et St J v JL .__, g
3. Click the Insert tab. The Ribbon changes to reflect options per- , -
taining to Tables, Illustrations, Charts, Links, and Text groups. Figure 1-1
Additional tabs appear when they're useful for the current task. Format Cells
tumber | Alignment || Fart f| Border | Fil | Protection |
Eont: Fornk style: Size:
albri egular
Cai Cambria HEadinis ; Ial - él ;

4. On the Home tab, click the down arrow next to the Format & gy e FEI—
as Table button. A gallery of table styles appears. (Click the 7 lgeran , o 3
arrow again to close the gallery.) Underine: Colr:

None [=] | —88 ] (] tiormal font

5. On the Home tab, click the dialog box launcher on the bottom- Effects preview
right of the Font group to open a related dialog box (see Figure i | asbbcon
1-2). In this example, the Format Cells dialog box opens. [ subsere

(I|(k Ihe (un(el bu“on to (Iose a dmlog box W“hou' muking uny thungeS. This is a TrueType font, The same font will be used on both your printer and your screen,
. .
6. Pause your mouse over any of the three icons above File. By
default, the Quick Access toolbar functions include Save,

Figure 1-2
Undo, and Redo.




Close Excel

Explore Backstage View

1.

Click File. Excel Backstage View opens with three columns.
The left column represents actions you can select.

Choose Print from the left column. The middle column
changes to show tasks relative to printing (see Figure 1-3).
See Chapter 13 for more information about printing.

Choose Recent in the left column. A list of workbooks you
worked on recently displays. You can click any workbook to
open it. See the steps in the section, “Open an Existing Excel
File,” later in this chapter.

Choose Info in the left column. The middle column represents
a second level of tasks related to your current workbook, and
the right column displays the workbook properties. See the
section, “Specify Workbook Properties,” later in this chapter.

Click File again. Backstage View closes, and you return to
your current workbook.

Close Excel

1.

Click File, and from Backstage View that appears, choose Exit,
as shown in Figure 1-4.

; Alternatively, dick the Close button (X) in the upper-right corner.

2. Click Save or Don't Save if prompted to save your workbook.

(See the section, “Save a Workbook,” later in this chapter.)

remains open.

s (Optional) Choose File=>Close. The current workbook closes, but the Excel program

Figure 1-3

Figure 1-4
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4. Click anywhere in the Excel workbook to close the
Customize Status Bar menu.

Select Commands with the Keyboard

1. Click any cell on the worksheet.
2. Press the Alt key on the keyboard. Shortcut letters appear on nea "I . fecld - Migrosoft Sl
the Ribbon, and numbers appear on the Quick Access toolbar _
(see Figure 1-5). e ’
B 7 O] v | W8 %
Numbers control commands on the Quick Access toolbar. _ il ) alannas b
Al -
2 B © o] E F G H |
1 L]
2
3. Press a letter on your keyboard to select a tab on the Ribbon; "
for example, press the P key to display the Page Layout tab. 5
Shortcut letters then appear for each command on that tab. Figure 1-5
4. DPress a letter on your keyboard to select a command. Excel :
displays options for the command you selected. Customize status ot
v | Cell Mode Ready
5. Press a letter or use the arrow keys and then press Enter on Sianatures ort

the keyboard to select an option. Excel performs the com-
mand you selected, applying the option you chose.

Press the Esc key to step the KeyTips back one step.

v
v | Information Management Policy
v | Permissions

Caps lock

Hum Lock
V| scroll Lock
v | Fixed Decimal

Dvertype Mode

Qff
Qff
Qff
on

Off
Qff

v | End Mode
Macro Recording Mot Recording
v | Selection Made
Change Status Bar Indicators D) penmy
syerage
v | Count
1. Right-click anywhere along the status bar at the bottom of il Caung
the window. Excel opens the Customize Status Bar menu. Minimum
Maximum
2. Active features have a check mark next to them and inactive Y] s
features do not. To activate an inactive feature, click it. This v Upload status
automatically adds a check mark. In Figure 1-6, the Caps ‘f S "
Lock feature is off. 7| zoom sicer
3. To deactivate any active feature, click it to remove the check Figure 1-6

mark.




Save a Workbook

Create a New Excel File

1. Choose File>New. Backstage View shows templates you can
choose from in the middle column (see Figure 1-7).

2. Select the Blank Workbook option and then click the Create
button. Excel creates a blank workbook based on the default
template.

s See Chapter 10 for more information about Excel templates.

Save a Workbook

1. Choose Filer>Save or click the Save button on the Quick
Access toolbar. The Save As dialog box appears, as shown in
Figure 1-8.

s The Save As dialog box only appears the first time you save a file.

2. By default, Excel saves your files in the Librariess"Documents
folder. If you want to save your file in a different folder,
select that folder from the folder pane.

Press Ctrl+N to create a new workhook without opening the New Workbook
dialog hox.

3. In the File Name text box, type a descriptive name for the
file. Filenames can't contain an asterisk (*), a slash (/), a
backslash (\), or a question mark (?) character.

4. Click the Save button. Excel saves the workbook in the loca-
tion with the name you specified in Step 3.

Figure 1-7

Figure 1-8

]

Blank workbook






Delete a File

Convert a Prior Uersion
File to Excel 2010

1.

Open a workbook created in an earlier version of Excel; the
title bar indicates that Excel opened the document in
Compatibility Mode.

Click File and from Backstage View, choose Convert. Excel
displays a message indicating you're about to convert the cur-
rent workbook (see Figure 1-11).

Click OK and then another conversion message appears.

Click Yes and then Excel saves the file in the new format.
Excel replaces the older version of the workbook, using the
same name you used for the older version of the document.
If the older version was an Excel 97-2003 or earlier docu-
ment, Excel 2010 changes the extension to . xIsx.

Compatibility Mode disappears from the Excel fitle bar.

Delete a File

Open Excel but do not open the file you want to delete. Click
File and choose Open or Save As. Either the Open or Save As
dialog box appears.

If necessary, in the folder pane, navigate to the folder con-
taining the file you want to delete.

Select the unwanted file and choose Organizer>Delete (see
Figure 1-12). A confirmation message appears.

Click the Yes button, and Excel deletes the file.
Click the Cancel button to close the Open or Save As dialog box.

Microsoft Excel

[T] Do nat ask me again about comverting warkboaks

This action converts the workbook ko the current file format, which allows vou ko use all of the new Features of Excel, and it reduces the file size. The
origingl warkbook will be deleted and cannot be restored after this conversion.

(7=

Remave properties

Figure 1-11
[ Open =5
(=
OU ‘j » Libraries » Documents » - | 3 || Search Documents )
Organize v New folder =~ 0 @
¥ cut =
L]
b G Documents_ library Arrange by:  Folder ~
= “opy Includes: 2 locations
Paste B
Name Date modified m
Undo |?‘
Redo Figures 1A1/20101:10 P |
=) ABC Balance Sheet §/22/2009 12:00 AM
Slfdlell ] alistate balances 1/14/2008 3:41 PM
[0 Layout ] analysis samples 11/2/2007 3:51 PM
Folder and search options &) August Ratings §/22/2009 1206 AM
* od & August &/15/2009 5:15 PM
elete
B Balance sheets 07 1/10/2010 3:15 PM
Rename

E_']Ba\ance sheets

5/14/2009 10:07 PM

B hiktac won. batale vAEPRAR 1398 DA
Properties < n
Close | All Excel Files -
Figure 1-12

11
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Rename a File

1.

Open Excel but don’t open the file you want to rename. Choose
Filec>Open or Save As. The Open or Save As dialog box appears.

If necessary, in the folder pane, navigate to the folder con-
taining the file you want to rename.

Select the file you want to rename and choose
OrganizewRename. The original filename becomes high-
lighted. (See Figure 1-13.)

Type the new filename. Filenames can’t contain an asterisk
(*), slash (/), backslash (\), or question mark (?) character.

Press Enter when you're finished typing.

Click the Cancel button to close the Open or Save As dialog box.

Specify Workbook Properties

1.

From an open workbook, click File and from the Info panel
on the right, choose Properties. A list of options appears.

Choose Show Document Panel. The workbook reappears,
and the Document Information panel appears.

Enter identifying information such as the author’s name, sub-
ject, or a list of keywords. See Figure 1-14.

Excel automatically adds statistical information, such as the workbook's original cre-
ation date, the last time the workbook was printed or modified, and the workbook
size.

Click the Close (X) button to close the Document
Information panel.

File paens July

Save a5 ype: | Extel Workhook

Crer Thumbms

= Hide Folders

I-:.igure 1-13

&) income Statements

oot =

et

Figure 1-14






14

Chapter 2: Entering Spreadsheet Data

Change the Active Cell

1. Open an Excel workbook. The Formula bar displays the
active cell location. Columns display the letters from A to
XFD, and rows display numbers from 1 to 1,048,576. A cell
address is the intersection of a column and a row, such as
D23 (in which D is the column and 23 is the row).

2. Move the focus to an adjacent cell with one the following
techniques:

Down: Press the Enter key or the down-arrow key.
Up: Press the up-arrow key.

Right: Press the right-arrow key.

Left: Press the left-arrow key.

3. To move to a cell farther away, use one of these techniques:

Click any cell to move the active cell location to that
cell. You can use the scroll bars to see more of the work-
sheet. In Figure 2-1, the cell focus is in cell E9. Notice the
border surrounding cell E9 and the name box that indi-
cates the current cell.

Choose Homer>Find & Select>Go To in the Editing
group. The Go To dialog box displays, as shown in Figure
2-2. In the Reference box, enter the address of the cell you
want to make active and then click OK.

S Press the F5 key to display the Go To dialog box.

Press Ctrl+Home. Excel jumps to cell Al.

Press Ctrl+End. Excel jumps to the lower-right cell of the
worksheet.

Press Ctrl+PageDown or Ctrl+PageUp. Excel moves to the
next or preceding worksheet, respectively, in the workbook.

Figure 2-1

Go To
@a ko:

$A$1

Reference:
G213

[ special... |

Ok

| [ cancel

Figure 2-2




Select Multiple Cells

Select Multiple Cells

1. Click the first cell in the group you want to select.

2. Depending on the cells you want to select, perform one of
the following actions:

To select sequential cells, select a cell, hold down the
Shift key, and select the last cell you want included. All
cells in the selected area are highlighted, with the excep-
tion of the first cell. (Don't worry, it’s selected, too; it’s just
not highlighted.) Figure 2-3 shows a sequential area
selected from cells B4:F15. Notice the black border sur-
rounding the selected area.

Click any cell to clear the selection. Alternatively, click and drag the mouse over a
group of cells to select a sequential area.

To select non-sequential cells, select a cell, hold down
the Ctrl key, and click each additional cell you want to
select. Figure 2-4 shows the non-sequential cells A4, C7,
and E4:E9, as well as all of row 2, selected.

To select a single entire column, click a column heading.

To select multiple columns, drag across multiple column
headings.

To select a single entire row, click the row number.

To select multiple rows, drag across multiple row numbers.

When making non-sequential cell selections, you can include enfire rows and entire
columns along with individual cells or groups of cells.

To select the entire worksheet, click the small gray box
with a triangle located to the left of column A and above
row 1. Alternatively, you can select all cells in a worksheet
by pressing Ctrl+A.

S R TR N S - SR SR

[
NP o |

13

Figure 2-4
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Chapter 2: Entering Spreadsheet Data

Enter Cell Data

1. Type the label or value in the desired cell.

2. DPress Enter. The data is entered into the current cell, and
Excel makes the next cell down active (see Figure 2-5). How
Excel aligns the data depends on what it is:

e Label: Excel aligns the data to the left side of the cell. If
the descriptive information is too wide to fit, Excel extends
that data past the cell width if the cell to the right is blank.
If that cell isn’t blank, Excel displays only enough text to
fit the display width; however you can widen the column
to display additional text.

S To enter a value as a label, type an apostrophe before the value.

e Whole value: If the data is a whole value, such as 34 or
5763, Excel aligns the data to the right side of the cell.

e Value with a decimal: If the data is a decimal value, Excel
aligns the data to the right side of the cell, including the
decimal point, with the exception of a trailing 0. For exam-
ple, in Figure 2-6, if you enter 246.75, 246.75 displays;
however, if you enter 246.70, 246.7 displays. (See Chapter
6 to change the display appearance, column width, and
alignment of your data.)

S If a value displays as number signs, or scientific notation (such as 4.3E+09) as shown

in Figure 2-6 in cell D8, the value is foo long fo fit into the cell. You need to widen the
column width.

e Date: If you enter a date, such 1/11, Jan 11, or 11 Jan, Excel
automatically returns 11-Jan in the cell, but the Formula bar
displays 1/11/2010. Figure 2-4 also illustrates an example of
a date entry. See Chapter 6 to change the date format.
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Edit or Delete Cell Data

Undo Data Entry

1. Enter text into a spreadsheet.

2. To undo any actions or correct any mistakes you make when
entering data, perform one of the following:

e (Click the Undo button on the Quick Access toolbar.
e Press Ctrl+Z.

3. Keep repeating your favorite undo method until you're back
where you want to be.

4. To undo several steps at once, click the arrow on the Undo
button and select the step from which you want to begin the
Undo action (see Figure 2-7).

To repeat your last action, click the Redo button on the Quick Access toolbar or press
Ctrl+Y. You can't repeat some actions, however.

Edit or Delete Cell Data

1. To delete the entire contents of a cell, use one of the follow-
ing methods:

e Choose Homer>Clear in the Editing group; then select
what you want to clear.

e Press the Delete key.

If you dear the wrong cell, use the Undo command (see the preceding section).

2. To edit cell contents, use one of these methods:

e Delete the contents and retype new cell information.

e Press the F2 key and edit the cell contents from
the Formula bar.

e Double-click the cell contents and edit them
from the cell. (See Figure 2-8.)

s | Bold
L | reping rsam in s

Faste | Typing Tom' in A5
Clipboa( Typing ‘Mary' in &4
Typing ‘David' in &3

Farmat Cells

1

2 Typing "460.358" in B6
Zl[ Typing ‘280" in BS

Typing 325.15"in B4

4 Typing "356.6" in B3

5 | yping wirin e

6

7

8

9

g Typing ‘Date’ in C2
Typing ‘Average’ in B2

Zaam

Zoom

Typing '12345 67890% in 0§
Typing ‘Scientific notation sample’ in &8

Typing ‘Completed’ in B2

Bookl - Micros

Farmulas Data Review Wi

= Custom

o | § - %

Alignment G Numbe

1.23E+04

10 | | Zoom
11 Undo 14 Actions
12

Figure 2-7

Figure 2-8
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Copy and Paste Data

1. Select the data you want to copy.

2. Choose Home=>Copy in the Clipboard group. A marquee (which
looks like marching ants) surrounds the cells (see Figure 2-9).

Click the cell to which you want to paste the copied data.

4. Choose Homer>Paste. The selected cells are pasted into the
new location.

5. Paste the cells into another location or press the Esc key to
cancel the marquee.

Alternatively, press Cirl+C to copy the selected cells, Cirl+X to cut the selected cells, or
(trl+V to paste the selected cells.

Move Data

1. Select the data you want to move.

2. Choose Home=Cut in the Clipboard group. A marquee
(which looks like marching ants) surrounds the cells.

Click the first cell that you want to move the selected cells to.

4. Choose Homer>Paste in the Clipboard group. The selected
cells are pasted into the new location. The cells originally in
B2:B6 are now located in cells C9:C13 (see Figure 2-10).
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Transpose Data

Draq and Drop Data ca - f-l Ayerage Score
A B C D E F
1
1. Select the data you want to move. . Test Date
2. Position the mouse pointer around any portion of the selec- 3 |David b 11-Jan
tion area edge, but not in the lower-right corner. The mouse g ?‘“arv
pointer shows four arrowheads. . s:::
3. Drag the borderline to the area you want the cells moved to. 7
A border shows the new area. See Figure 2-11 in which cells €
C9:C13 are being moved to cell B2:B6. 190 A"e;asg:z ore
4. Release the mouse button. The data moves to the new 11 325.15
location. 12 290
13 460.358
Drag and drop works best if you're moving a small amount of cells to an area that 14
isn't far from its original spot. s
Figure 2-11
E P o View P o
'\. ’\J st Ny Twlme @ . hé B ; }f A
Transpose Data ST ST e R R A
3k '.!_ L = B | Dand 4
1. Select the cells you want to transpose and then choose ko I ' N e————Y
Homeﬁ>COPY' ::.-:?«I:T--m ér'f.-'JﬁmEAmm smlir.«r..s T“l?al.‘:n [David My Tom  sam |
) (e ] Mary 2515 }1
The Transpose feature doesn’t work if you choose Cut instead of Copy. s om 1 s p
7 b S
s S A
10 \‘ //
11 \'\,_\_ //f
. . 2 e
2. Click the cell where you want the transposed cells to begin. 7 iind
14
3. On the Home tab, click the down arrow on the Paste button Figure 2-12

to display a menu of options.

4. Choose Transpose. As shown in Figure 2-12, Excel copies the
selected cells into the new area, transposing rows into col-
umns or columns into rows.

5. Press Esc to cancel the marquee.
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Extend a Series with AutoFill

1. Type the first cell of data, such as a day or a month like
Wednesday or September. AutoFill works with days of the
week, months of the year, or yearly quarters such as Qtr 2.
You can enter the entire word or you can enter the abbrevi-
ated form (such as Wed or Sep).

Press Enter.

3. Position the mouse pointer on the fill handle — the small black
box at the lower-right corner of the data cell. Your mouse
pointer turns into a small black cross. (See Figure 2-13.)

To AutoFill a series of numbers, enter two values in two adjacent cells, such as 1 and 2
or 5 and 10. Select both cells, and then use the AutoFill box to highlight cells. Excel
continues the series as 3, 4, 5, or 5, 10, 15, and so forth.

4. Drag the small black box across the cells you want to fill. You
can drag the fill handle across cells up, down, left, or right.

5. Release the mouse. Excel fills in the selected cells with a con-
tinuation of your data. Figure 2-14 shows how Excel fills in
the cells with the rest of the weekdays. This figure also shows
the different formats for the days of the week, months, and
some numbers.

If you use AutoFill on a single value or a text word, Excel duplicates it. For example, if
you use AutoFill on a cell with the word Apple, all filled cells contain Apple.

Chapter 11 includes instructions for creating your own customized list. AutoFill can
enter lists you often use, such as sales rep names or product types.
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Remove Rows and Columns
1. Select the row numbers or column letters you want to remove.
Excel highlights the entire rows or columns. (See Figure 2-17.)

2. Choose Homer>Delete in the Cells group. Excel removes any
data in the rows or columns and moves existing data up or
left. This fills the void from the deleted rows or columns.

(Optional) Right-click the selected row numbers or column letters and choose Delete
from the shortcut menu.

Delete Cells

1. Select the cells you want to remove.
2. Choose Home and in the Cells group, click the arrow on the
Delete button. A menu of options appears.

Alternatively, right-dick over the selected cells and choose Delete from the shortcut
menu.

3. Choose Delete Cells. The Delete dialog box appears, as
shown in Figure 2-18.

4. Select a deletion option:

e Shift Cells Left: Select this if you want data in the cells in
the same row moved to the left.

e Shift Cells Up: Select this if you want data in the lower
cells in the same column moved up.

e Entire Row: Select this if you want remove a row and
move lower data up.

e Entire Column: Select this if you want to remove a
column and move data to the left.

Figure 2-17

Figure 2-18
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Use Named Ranges

N R C II I fore ;e Pagelwmout | Fomulas | Date  Review
ame a anqe 0 e s f X sutosum v @ Logical - [ Lookun & Reference = =1 5 Trace Preceden|
; ft [ Recently Used = & Text~ [ Math & Trig ~ ” Reha it ot =% Trace Depende|
. unction (@ Financial = & Date & Time - ) More Functions = snager B Create from Selection | 7, Remove Arrow
1. After selecting the cells you want to name, choose e e R
Formulas=>Define Name in the Defined Names group. The E - £ m
New Name dialog box appears. (See Figure 2-19.) S R e 0 E F & i
1
2. In the Name text box, type up to a 255-character name for 12 | East ___ West  North  South
the range. Range names aren't case-sensitive; however, range | 3 Bob 202 4 New Name ==
names must follow these conventions: |4 Mary .
| 5 John 443 77 Score: | Workhook [=]
e The first character must be a letter, an underscore, or a lel:san 5y 7 comert: z
7 | Ellie 673 74
backslash. 8 | oy el s
¢ No spaces are allowed. o il B (E S weererer
anny
— -OK -Car\cel
e You can't use a name that's the same as a cell address. For 1
example, you can’t name a range AB32. ﬁ
3. Click OK. Figure 2-19
(Optional) Enter a range name info the Name box located at I‘he left end of the ‘ L TR
Formula bar. You can jump quickly to a named range by clicking the down arrow in ¥ o ks m=E e |5 o -
the Name box and selecting the range name. o *j O R i a——— E;‘,;”ﬁ?l o
Clipboard @ Font 7 Alignment ® Murber 7 Style.
. o . . ofe South - S| d63
You can include range names in formulas, such as =F6*PayRate in which a specific cell = - c 5 : - c -
is named PayRate. %“
West West North South
iBOb 202 431 492 468
| 4 |Mary 408 300 728 730
u N d R i]ohn 443 756 625 678
se ame anqes | & |Susan 487 in 577 649
7 |Ellie 673 760 689 577
1. Click the down arrow in the Name box to the left of the | 8 Harry 284 507 34 B
Formula bar. A list of named ranges appears. (See Figure 2-20.) %;:’:nv 222 ;22 zzi ;22
2. Select the range name you want to access. Excel highlights the 12
named cells. B
14
(Optional) Choose Homec>Find & Select=>Go To. Double-click the range name you 15

want to access. Figure 2-20
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Manage Range Names

1. Choose Formulass>Name Manager in the Defined Names
group. The Name Manager dialog box appears, as shown in
Figure 2-21.

Excel automatically adds tables to the Name Manager. See Chapter 7 for more on
working with tables.

2. Select one of the following options:

e Click the New button, which displays the New Name dia-
log box where you can enter a range name and enter the
cell locations it refers to.

Instead of typing the range cell locations, click the Collapse button, on the right side of
the Refers To hox, which moves aside the New Name dialog box. You can then use
your mouse fo select the desired cells. Press Enter or click the Expand button fo return
to the New Name dialog hox.

¢ (Click an existing range name and then click the Edit but-
ton, which displays the Edit Name dialog box, as shown in
Figure 2-22. Use this dialog box to change the range name
or the range cell location reference.

e (Click an existing range name and then click the Delete
button. A confirmation message appears making sure you
want to delete the range name.

If you have a lot of range names, you can click the Filter button and elect to display
only the items meefing selected criteria.

3. Click the Close button to close the Name Manager dialog box.

Name Manager

) Lo

New... Delete

Mame
Rl ast
= Morth
=l South
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5i$B§10
Sheet31$D$3:50610
Sheet3I$E§3 §EF10
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Comment:

Refers tar
#||v | | =shestagesais10

]

A

Figure 2-21
Edit Name % s
Name! East|
Scope: ‘Warkbook,
Comnment: A
Refersto! | _cheetsigRga:gasio B3
-
Figure 2-22




Validate Data Entry

(/a [" date D ata En try On the Error Alert tab of the Data Validation dialog box, you can cus-

tomize the error message Excel displays if an invalid enry is enfered.

1. Select the cell(s) you want Excel to validate and then choose
Datar>Data Validation in the Data Tools group. The Data
Validation dialog box displays. B

2. In the Settings tab, click the Allow drop-down list and choose
the type of validation, such as

e Values, such as Whole Number or Decimal, in which you - B O £ A
specify the upper and lower limits of allowable data val-
ues. (See Figure 2-23.)

Hours Worked Seltegs | Input Message. | Emmor Mt

Monday 'z.:s.-..- artrrin

Tuesday Decmal [] i tarere phari
Wednesday Dt i

Thursday eainse L

Friday i

Saturday .-'_.'.....v.

Il ]

e Lists, such as a list you define, a range of cells in the exist-
ing worksheet, or a named range.

CRETRRET R RS

@
|

When creating a list, if you want the available choices to appear when the cell is =

selected, make sure to select the In-Cell drop-down check box. 1
12
13

Figure 2-23

e Ml o || cance

e Dates or Times in which you specify ranges or limitations,
such as greater than or less than, or even a specific date.

e Text Length in which the number of characters in the data
must be within the limits that you specify.

3. (Optional) Display the Data drop-down list and select criteria
such as Between, Greater Than, and so on.

4. Select criteria, such as maximum and minimum values, or
specify a data location. Enter values or cell addresses. Precede
a value with an equal sign (=) to specify a range name.

5. (Optional) On the Input Message tab, enter a comment to

display whenever someone clicks the validated cell.
Figure 2-24
6. On the Error Alert tab, choose from the Style drop-down list .

whether Excel warns you or completely stops you from enter-
ing an invalid entry. (See Figure 2-24.)

7. Click OK.
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a a - fr
Enter Data in Validated Cells \ — T T T
1
1. Click a cell that has a validation requirement; then type data T Hours Worked ,
into the cell. 4 Tuesda: 6. |Invalidentry! =
2. Press Enter. One of two things happens: ?:ﬂ:‘z:av EN— — 8 B
- - 7 Friday Pleasier\ter - Retry | -Cantel -ﬂelp
e If the data meets the validation rules, Excel accepts the 8 scturday e st st e
entry and moves to the next cell down. 9
10
e If the data does not meet the validation rules, Excel displays 1
an error message similar to the one you see in Figure 2-25. 12
13
3. Depending on the setting you selected on the Error Alert tab Figure 2-25
in the Data Validation dialog box (see the preceding section),
choose an option: -
e Stop: Click Retry or Cancel. E R s bl P" o i *
e Warning: Click Yes, No, or Cancel. e G et e e o
¢ Information: Click OK or Cancel. . - L
.4 Iuosdn: 6.5
5 | Wednesday
Locate Cells with Data Validation i
10
1. To have Excel highlight all cells that have data validation, 5
select one of the following methods, as shown in Figure 2-26: Figure 2-26

e Choose Home=Find & SelectrvData Validation in the
Editing group. (See Figure 2-26.)

e Choose Home=Find & Select=>Go to Special in the Editing
group. Select the Data Validation option, choose All, and
then click OK.

2. Click any cell to deselect the highlighted cells.

To remove data validation, choose Data=>Data Validation in the Data Tools group.
From the Data Validation dialog box, dick the Clear All button and then click OK.
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Building Formulas

Fis chapter is all about the math. With Excel, you can create formulas to
perform calculations. The calculations can be simple, such as adding
2+3, or they can be extremely complex, such as those used to calculate
depreciation. This chapter deals with the simpler ones.

Alas, sometimes you get errors after creating calculations. Occasionally, the
error results from a simple typing mistake, and you can see the problem and
easily fix it. Other times, the errors aren’t easy to locate, so Excel provides
tools to assist you in evaluating formula errors.

The primary tasks in this chapter include
m= Creating simple and compound formulas by typing them into a cell.
w= Adding or averaging a row or column of values.
w= Summarizing an array.

w= Creating cell ranges separated by colons for a sequential cell selection
or by commas to list specific cell locations.

w= FEvaluating formula errors and locating a cell’s precedents and
dependents.

”'%apter

Get ready to. . .

w= (reate Simple Formulas with Operators...... 28

w= (reate Compound Formules...................... 29
= Add Numbers with AutoSum ...................... 30
= Find an Average Value ......................... 30
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= Copy Values with Paste Special
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Create Simple Formulas with Operators

1.

28

Enter values in two different cells; remember, however, that
formulas don’t need to reference cell addresses. They can con-
tain actual numbers.

In the cell where you want to perform the calculation for the
two values, type an equal sign (=). All Excel formulas begin
with an equal sign.

Click or type the first cell address, or type the first value you
want to include in the formula. In the example in Figure 3-1,
I'm adding two cell references (B2 and C2).

Excel displays a color border that surrounds the cell reference you enter.

Type an operator. Operators can include
e The plus sign (+)

e The minus sign (-)

e The asterisk (*) to multiply

e The slash (/) to divide

e The percentage symbol (%)

e The exponentiation symbol (#)

Click or type the second cell address or the second value you
want to include in the formula.

Press Enter and then Excel displays the results of the calcula-
tion in the selected cell. (See Figure 3-2.)

The formula bar af the top displays the actual formula.

Formulas can have multiple references. For example, =B5+B6+B7-+B8 is a legitimate
formula. Formulas with multiple operators are compound formulas.

E Home Insert Page Laynut Formulas Data Review “ieans
Jie = |11 A A e =
Pafteéﬁ.vnzz = - A =E== FiF o $
C\lpbuard/ = Font Alignment Mumbe|
SUM ~ (" R & fe|=B2
A B C D E F
1 TEST1 TEST 2
2 oy [ e 29702
3 February 297 351
4 March 223 188
5 April 251 369
6 May 277 285
7 |June 324 358
8 |uly 314 127
9 August 216 180
10
11
12
13
14
15
Figure 3-1
7_Fl:_ Hiome Insert Page Layout Farmulas Data Rewi e g
* Calibri 11 o A A = Mumber
Pastehﬁvnru- - &AL = $ - % o
\;‘ = i
Clipboard 1= Font £l Murmnbe
Dz - Je | =B2+C2
A B C D E F
TEST1 TEST 2
:Ilanuary 46 237 653
February 297 351 1
4 March 223 188
5 April 251 369
6 May 277 285
7 June 324 358
8 luly 314 127
9 August 216 180
10
11
12
13
14
15

Figure 3-2



Create Compound Formulas

Create Compound Formulas

1. Type values in three or more different cells; then select the
cell where you want the formula.

2. Type the equal sign (=) and then type or click the first cell
reference.

3. Type the first operator and then type or click the second cell
reference.

4. Type the second operator and then type or click the third cell
reference.

; Compound formulas aren't limited to three references, and you can use cell references

multiple fimes in a compound formula.

5. Press Enter. Excel displays the results of the calculation in the
selected cell. The actual formula appears in the formula bar.
(See Figure 3-3.)

If you paid attention in your high school algebra dlass, you might remember the Rule
of Priorities, or the Order of Precedence. In a compound formula, Excel calculates
multiplication and division before it calculates addifion and subtraction. This means
that you must include parentheses for any portion of a formula you want calculated
first. As an example, in Figure 3-4, you see that the formula 3+5*2 gives a result of
13, but (3+5)*2 gives a result of 16.

You can include range names in formulas, such as =D23*CommissionRate, in which a
specific cell is named CommissionRate. (See Chapter 2 about using range names.)

Compound formulas can have multiple combinations in parentheses and can contain
any combination of operators and references. A formula might read
((B5+C5)/2)*SalesTax. This formula adds cells BS and (5, divides that result by 2,
and then multiplies that result times the value in the SalesTax cell.

Figure 3-3
A2 - fe | =(345)*2
A B C D
1 13 3+5%2
2 16| (3+5)*2
i :
Figure 3-4
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Define an Absolute Reference

32

1.

To prevent a formula from changing a cell reference while
you copy it to a different location, lock in an absolute cell
reference using one of these methods:

e Lock in a cell location: Type a dollar sign in front of both
the column reference and the row reference (as in $G$1).
If the original formula in cell E5 is =D5*$G$1 and you
copy the formula to cell E6, the copied formula reads
=D6*$G$1 instead of D6*G2, which is how it would
read if it wasn't absolute. (See Figure 3-9.)

e Lock in only the row or column location: Type a dollar
sign in front of the column reference ($G1) or in front of
the row reference (G$1).

Copy the formula, as needed, to other locations. Notice that
the absolute cell reference in the original formula remains
unchanged in the copied formulas.

Copy Values with Paste Special

1.

Select a cell (or group of cells) containing a formula and then
choose Homer>Copy in the Clipboard group. A marquee
appears around the selected cell.

Select the cell where you want the result to appear; then click
the down arrow on the Paste button on the Home tab.

Choose Paste Special. The Paste Special dialog box, as shown
in Figure 3-10, appears.

Select the Values option.

Click OK and press Esc to cancel the marquee. Excel pastes
the result of the formula, but not the actual formula. If the
original formula changes, this value doesn’t change.

Paste

() Farmats
) Comments
) Yalidation

Operation

() All using Source theme

) All except borders

() Column widths

() Formulas and nurmber Formats
© Values and number Farmats

&l merging conditional formats

@ Mone ) Multiply

) Add ) Divide

@) Subtract

[] Skip blanks [F] Transpose.
Figure 3-10

SUM - K v fo =DE*SGS51
(Functiors] B C D E F G
1 Tax Rate 6.50%
2
3
4 Item QTY COST SUBTOTAL  TAX TOTAL
5 |Red Widget 15 2.15 32.35 2.10
| 6 |Bluewidget 30 211 ]  63.30 |=DE*$GE1 |
7 |Green Widget 9 211 18.99 1.23
8 |Yellow Widget 42 2.25 94.50 6.14
9
10
11
12
13
14
15
Figure 3-9
Paste Special 2=




Summarize an Array

Summarize an Array

1. Set up the array data you want to total.

An array is a group of cells. An array formula is a single formula that produces resulis
in multiple cells.

2. Select the cells in which you want the array formula.

Be sure fo select the exact number of cells. If you select too few cells, Excel doesn't
display all your array values. If you select too many cells, Excel displays #N/A in the
cells for which no array values exist.

3. Type the formula, or use the mouse to select cells, beginning
with the equal sign, indicating the array ranges. For example,
in Figure 3-11, I want to calculate the volume divided by the
range, so the formula is C5:C40/D5:D40. Separate each array
range with a colon.

You can also use Excel functions in array calculations. (See Chapter 4 for more infor-
mation on Excel functions.)

4. Press Ctrl+Shift+Enter. Excel enters the formula in curly
brackets, as shown in Figure 3-12. All the formula cells show
the same formula.

If you press Enter instead of Ctrl+Shift+Enter, Excel enters the array formula in only
the first selected cell.

You can’t add or remove rows or columns from the array. To remove the array formu-

las, you must highlight all the cells containing the formula and then press Delete.
Excel doesn’t permit you fo delete only one or some of the array formulas.

Using an array calculation ensures you make the same calculation for all cells. When
you change an array value, Excel updates all the cells in the formula.

SUN - K « J| =C5:C40/D5:040
(eI g C D E F &
1 Project X
2 January Testing Results
3
4 Volume Range Result
5 Test1 116 11.98 :C5:C40/D5:D40|
6 Test 2 297 3.84
7 Test 3 223 5.66
8 Test 4 251 9.15
9 Test5 277 6.44
10 Test6 324 8.22
11 Test 7 314 3.83
12 Test 8 216 13.03
13 Test9 300 8.83
14 Test 10 255 13.75
15 Test11 208 5.34
Figure 3-11
Figure 3-12
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Troubleshoot Formula Errors

e #N/A: This error occurs when Excel needs a value in a for-
mula that isn’t available.

e #NULL!: This error occurs when a formula attempts to use

the intersection of two ranges that don't intersect. For exam-
ple, if you type =C5 C6 instead of =C5+C6 (using a space in
the formula instead of a plus sign), Excel returns the #NULL!
answer. Replace the space in the formula with the correct
character, in this example, a plus sign. (See Figure 3-15.)

#NUM!: When you enter a formula and use an illogical argu-
ment, such as the square root of a negative number. For
example, if you enter =SQRT(81), Excel returns a value of 9,
but if you enter =SQRT(-81), Excel returns a value of #NUM.

#REF!: This error occurs whenever cell references become
invalid. For example, if you enter a value in cell A1 and
then in cell C2, you create a formula that references cell
A1l. That works fine, but if you attempt to copy the for-
mula in cell C2 to the higher cell C1, you get the #REF!
error because no cell is higher than cell Al. Figure 3-16
shows an example.

Perform one of the following steps, depending on the error
type:

Click in the cell and edit the formula as needed. Click the
Resume button when you're finished.

Click the Ignore Error button to jump to the next potential
problem.

Click an option, if available, to allow the Error Checking
dialog box to assist you with repairing the problem.

To help you determine the nature or origin of the problem, some error messages have
a Show Calculation Steps button to display the logic behind the formula.

Click Next to review the next problem area. When the error-
check process is complete, Excel displays a message box. Click
OK to close the message box.
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Display Formulas in the Cell 2 e
1. Choose Formulasw>Show Formulas in the Formula Auditing — pa— - - ‘ . =
group. Excel displays the actual formulas in the cells rather 1 L1 w2 1o o NOETD___permenG
. 2 | lanuary 416 237 =B2+C2 a47 - Wi-bL
than the reSUltS. See Flgure 3-17. 3 February “297 351 “pasca “399 TRaCEs
4 March 73 188 Bd+Ca 3 sBd=Ca-[a
.. . 5 April 251 369 “B5+C5 600 =B5+L5-E5
This is a great troubleshooting tool! 6 My m 75 -Bect 27 -B64C6 16
T June 324 358 BT+CT A08 sBT+CT-ET
a  luby 314 127 ~BE (8 426 ~B3+(8-E8
9 August 216 180 B9+C9 334 “BI+CI-EY
10 “SUM[E209) “SUM[C2:C9) “5UM[D2:03) “SUMIEZ:ES) =SUM[F2:FS]
11 Average -AWERAGE(B2:B)  ~AVERAGE(CZ.CI) -AVERAGE(DZDI) -AVERAGE(E2E9) =AVERAGE(F2:F9)
. 12
2. Choose Formulas®>Show Formulas again to turn off the cell 13
. . 14
formula display and redisplay the results. s
Figure 3-17
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2. Choose Formulas=>Trace Precedents or Trace Dependents in -~ o T
the Formula Auditing group. Excel displays one or more blue 7 e 2AC[HE e s o
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arrows pointing out either precedents or, as shown in Figure D mgust N6 | w0 2 3 6
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Dependent cells are are referred to by a formula in another cell. Precedent cells con- 1
tain formulas referencing other cells. -~
Figure 3-18

3. Choose Formulasw>Remove Arrows in the Formula Auditing
group. The blue arrow(s) disappear.



Using Excel Functions

E(cel includes almost 400 built-in calculations — or functions — in 12
categories. Functions contain arguments, which appear in parentheses
following the function’s name. The arguments are the details you provide to
Excel to indicate which numbers to calculate in the function. Some functions
require several arguments to function correctly, but don’t worry, Excel contains
a Function Wizard to walk you through the entire process.

Excel separates functions into categories, including Financial, Date & Time,
Math & Trig, Statistical, Lookup & Reference, Database, Text, Logical,
Information, Engineering, Cube, and Compatibility categories. For example,
the SUM function is in the Math & Trig category, whereas AVERAGE, COUNT,
MAX, and MIN are Statistical functions. Functions that calculate a payment
value are considered Financial functions. In this chapter, you discover how to

w= Create a function with the Function Wizard.
m= Manually type a function and its arguments.

m= Analyze data with Excel’s timesaving functions.

”'%apter

Get ready to. . .

w= Build a Formula with the Function Wizard........ 38
w= Manually Type an IF Fundtion....................
w= (reate Text Functions .....................

w= Change the Cell Text Case...............coovrree
w= Use Functions to Calculate Time

w= Convert a Text Date fo a Date Value.......... 41
w= Count the Number of Cells

(ontaining Data 42
w= Round Values with Math Functions............. 42
= Locate Data with Lookup Functions............. 43
w= |Jse the MODE Function ..............coooeec..c. 44
= Remove Unwanted Spaces

with the TRIM Function..........ccooeeveneeenc 44
= Estimate the Future Value

of an Investment 45

= Calculate a Loan Payment ......................... 46
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Build a Formula with o

Type a brief description of what you want to do and then dick

a a
the Function Wizard o
O select a category: | Financial [~]
. Select a function;

1. Select the cell where you want to enter a function. CORFTIFD =
ODOLPRICE

2. Choose Formulas=Insert Function in the Function Library ﬁ

group. The Insert Function dialog box appears. P i
. PMT(rate,nper,pv,fy.type)

3. Select a function category from the Or Select a Category drop- L o b et ey s

interest rate,

down list. (See Figure 4-1.)

4. Select a function name from the Select a Function list. A brief

description of the function and its arguments appears under —
the list of function names. Figure 4-1
5. Click OK. The Function Arguments dialog box displays. The i .
contents of this dialog box depend on the function you've Finetion frgtments a—
selected. Figure 4-2 shows the PMT function that calculates a pate [o3 0
loan payment based on constant payments and interest. Mer [0 o
Pv |DZ o

Fv

For more details on using the PMT function, see the section, “Calculate a Loan ) -
Payment,” later in this chapter. i =

Calculates the payment For a loan based on constant payments and & constant interest rate,

Py s the present value: the total amount that 5 series of future payments is
workh now,

6. Type the first argument amount or cell reference, or click the

cell in the worksheet. If you click the cell, Excel places a mar- Fammf o=
quee (which looks like marching ants) around the selected cell. Help cn this Functcn
7. Press Tab to move to the next argument and then type or Figure 4-2

select the second argument.
Repeat Step 7 for each necessary argument.

9. Click OK. Excel calculates and displays the result in the
selected cell and displays the formula in the formula bar.

Arguments in hold type are required. Those in normal type are opfional.
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Create Text Functions

1.

Select a cell where you want to show the function result; then
choose Formulas=>Text in the Function Library group and
choose one of the following:

LEFT: Displays a specified number of characters from the
beginning of a text string.

RIGHT: Calculates a specified number of characters from
the end of a text string.

MID: Extracts a specified number of characters from a text
string starting at a position you identify.

LEN: Determines the number of characters in a text cell.

Select the cell containing the text you want to evaluate.

Enter any remaining prompts in the Function Arguments dialog
box and click OK. (Figure 4-5 shows the resulting examples.)

Change the Cell Text Case

1.

From the cell where you want the function result, choose
Formulas=>Text and then choose one of the following:

UPPER: Displays the referenced cell in all uppercase
letters.

LOWER: Displays the referenced cell in all lowercase
letters.

PROPER: Displays the referenced cell with the first letter
of each word capitalized.

Select the cell you want to change and then click OK. (See
Figure 4-6 for resulting examples.)

File Home  Insert  Page Layout

Insert
Function [ Financial =

f I mutasum -
[iZ Recently Used = (A Text~

i Logical - [ Lookup & Reference -
[ Math 2 Trig -
[ Date & Time ~ (7 More Functions =

Function Library

Formulas Data Review Wiewy

Mame

@ ~3 Define Name ~

£ Use in Farmula

Manager B Create from Selection

Defined Mames

£ Trace Precede
=i Trace Depend

. Remove Arro

C3

- fe | =MID(53,4,9)

A B C D E F

1 ATouch of Class ATou LEFT 5

2 Robinson's Directory ctory RIGHT 5
ZlSunshine Day Care |shine Day! MID 4, 9

4 Everybody Knows You 19 LEN

5

6

7

8

9
Figure 4-5

Samuel R. Smith

CRET R R R IV

UPPER
SAMUEL R SMITH

LOWER PROPER

Figure 4-6
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Count the Number of Cells
Containing Data

1. From the cell where you want the function result, choose
Formulasm>More Functionsw>Statistical=>COUNTA in the
Function Library group.

If you want to count numeric values, use the COUNT function instead of the COUNTA
function. If you want to count blank cells only, use the COUNTBLANK function.

2. Select the data range you want to count and click OK. Excel
counts the number of entries. See Figure 4-9, which displays
that there are 372 entries in cells A3:A374.

Round Values with Math Functions

1. From the cell where you want the function result, choose
Formulas=>Math & Trig in the Function Library group, and
then choose one of the following:

e ROUND: Rounds a value to a number of digits you specify.

e ROUNDUP: Rounds a value up to a number of digits you
specify.
e ROUNDDOWN: Rounds a value down to a number of
digits you specify.
2. From the Number text box of the Function Arguments dialog
box, select or enter the cell you want to evaluate.

3. In the Num_digits text box, enter the number of decimal
places you want the value rounded to. Enter zero if you want
a whole number; if you want the number rounded to the left
of the decimal point, enter the value as a negative number.

4. Click OK. The results appear in your worksheet. (See
Figure 4-10.)

3] - K| =COUNTALAZATTA)

A B C

Y=
I..Inl.:c\

5] E
1 SONGS OF THE 1960'S - 1980'S
2 Song Title Artist Year TOTAL SONGS
3 | AHorse With No Name America 1975
4 ASatisfied Mird Bobly Hebb 1984
5 ASweel Womnan Like You Joe Tex 1984
6 ABL lackson & 1976
T Afternoon Dalight Srarlight Voeal Band 1985
B AL Tre Anchy Williams 1385
9 Ain't Mo Mountain High Enough Diana Ross 1983
Figure 4-9

NODCWN[AT, 3]

] - fe | =R

A B C 8]

1 ORIGINAL ROUND ROUND UP ROUND DOWN

2 137641544987 13764.154 13768.155
3

4

5

6

Figure 4-10




Locate Data with Lookup Functions

Locate Data with Lookup Functions

1.

Prepare your worksheet in a column list format. For example,
maybe you have a list of song titles and artists and you want
to look up the artist for a particular title. The song title would
go in the first column, the artist in the second, and perhaps
the year it was recorded as the third column. You can have as
many columns in the array as you want.

Sort the data by the column you want to match; then click
the cell where you want the function result.

Choose Formulas=>Lookup & Reference>VLOOKUP in the
Function Library group. The Function Arguments dialog box
appears.

To locate a value in a column, use the VLOOKUP function. To locate a value in a row,
use the HLOOKUP function.

From the Lookup_value box, select the cell containing the
value you want to search. (In this example, the cell is E3.)

From the Table_array box, select the range containing all the
values. Don't include the heading rows.

Create a range name for the data and use that name in the VLOOKUP function. (See
Chapter 2.)

From the Col_index_num box, enter the column containing
the value you want to find. The leftmost column is 1. (In this
example, you want to find the artist, so you need to search by
column 2. If you want to find the year, you'd search by col-
umn 3.) See Figure 4-11.

Click OK. Excel displays the formula result in the selected
cell, and the actual formula appears in the formula bar. See
Figure 4-12.

Function Arguments
WLOOKLUP
Lookup_value
Table_array
Col_index_num

Range_lookup

E3
A3IC3T4
4

FEs
"Bmerican Pie"
4, Horse With Mo Mame","America”, 197

2

"Don MeLean"

Looks for a walue in the leftmast column of a table, and then returns a valug in the same row from a column you
specify. By default, the table must be sorted in an ascending order.

Col_index_num is the column number in table_array Fram which the matching value
should be returned. The First column of values in the table is column 1,

Formula resul =

Help on this function

Figure 4-11

[ = CE

B il e i
SONG TITLE ! e .lKnFl

Figure 4-12
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Use the MODE Function

The MODE function displays the most frequently occurring value in a specified range.

1. Select the cell where you want the function result; then
choose Formulas>More Functions=>Compatibility=>MODE in
the Function Library group. The Function Arguments dialog
box appears.

2. Select the worksheet range that you want to evaluate and
then click OK. Excel displays the results. (In Figure 4-13, the
result is 12, which is the most often used value in the data.)

If you prefer, you can manually type the function. In the cell where you want the
function result, type =MODE(A1:A32) replacing A7:432 with the area that you
want to evaluate.

Remove Unwanted Spaces
with the TRIM Function

The TRIM function is often very useful when you work with data imported from other
programs.

1. Select the cell where you want the function result and then
choose Formulas=>Text>TRIM in the Function Library group.
The Function Arguments dialog box appears.

2. Select the cell containing the text you want to trim the spaces.

Click OK. Excel displays the result of the formula in the cell
you selected in Step 1. (In Figure 4-14, you can see the data
before the TRIM function and after it.)

TRIM replaces any two (or more) spaces with a single space. If the text words contain
a single space, TRIM doesn't delete that space.

File Home  Insert  Pagelayout | Formnulas | Dats  Review  Wiew
ﬁ X sutosum + (@ Logical - 3 tookup & Reference ~ é O Define Name - TaTrace Frecectents 15
[ Recently Used ~ (A Text~ [ Math 2 Trig = £2 Use in Formula = = Trace Dependents ¥ Er|
Insert X . n— X Mame -
Fumdtion [@7 Finandal = [ Date & Time = ) More Functions - Manager S Create from Selection | 7 Remove srrows = (@) B
Function Library Defined Names Formula 4
D3 - fe | =MODE(R2:B18)
A B © D E F G
1 6TH GRADE CLASS ROSTER
2 NAME AGE AS OF 10/1/09 MODE
3 |Bob 11 12
4
4 Tom 12
5 Mary 10
6 Susan 11
7 Julia 12
8 |Brayden 12
9 Noah 12
10 Nathan 13
11 Grace 11
12 Danny 12
13 Alex 12
14 Sarah 12
15 Keadon 11
16 Alyssa 11
17 Cassie 11
18 Dawson 12
Figure 4-13
T fone  mset  Pagelwout | Formuis | Data  Review  View o
T autosun -+ @ logica -y Lookup & Reference - @ Define Name B Trace Precedents B show Formulas - 7l
ﬁ [ Recently Used - A Test - i Math £:Tiig - § FPUseinFomulas | ETrace Dependents % Error Checking = Cj £
Fhton 8 Finana - B Date & Time - ([@More Funcions - | wianager B Create fom Selection | U7, Remove ayrows (@) evaluate Formul  wradow | ape]
Function Library Defined Names Formuia Auditing cal
B4 - Fe | =TRIM(24)
) B c D E
1 BEFORETRIM AFTER TRIM
2 |ALLIANCE PLASTICS ALLIANCE PLASTICS
3 PO BOX 8395 PO BOX 5395
ERIE PA [ERiE P

BOMAR INDUSTRIES
4349 5 ARLINGTON AVE
INDIANAPOLIS IN

4

5

6 [BOMAR INDUSTRIES

7 4349 5 ARLINGTON AVE

8 INDIANAPOLIS N
10 |HAGGARD & STOCKING

1 £429 VICTORY DRIVE

1z INDIANAPOLIS N

HAGGARD & STOCKING
£429 VICTORY DRIVE
INDIANAPOLIS IN

14| LONESTAR PLASTICS
15 3986 MARKET STREET
16 GARLAND ™

LONESTAR PLASTICS
3986 MARKET STREET
GARLAND TX

18 |PAPERCONE CORPORTION
13 4399 FERN VALLEY ROAD
Pl LOUISVILLE Ky

PAPERCOME CORPORTION
4399 FERN VALLEY ROAD
LOUISYILLE KY

Figure 4-14
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Calculate a Loan Payment

Use the PMT function to calculate the amount you can expect fo pay each period for a
loan, such as a house or a car.

Create a worksheet containing the principal amounts, the
interest rates, and the number of payment periods.

Express all amounts in the same time frame, such as monthly or annually.

Select the cell in which you want to display the payment
amount and then choose Formulas=>Financial=>PMT. The
Function Arguments dialog box appears.

In the Rate box, select the cell containing the interest rate. If
you entered the value in years and are looking for a monthly
payment, enter /12 after the cell address.

In the Nper box, select the cell containing the number of pay-
ment periods. If you entered the value in years and are look-
ing for a monthly payment, enter *12 after the cell address.
(See Figure 4-17.)

In the Pv box, enter the amount of the loan.

Click OK. Excel calculates the payment amount. In Figure 4-18,
you see that with a $200,000 loan over 30 years at 5.5 percent
interest, you can expect to make monthly payments of
$1,135.58.

Ji

B N ML)
A B C 3]

30 Loan term inyears
5.5% Annual Interest Ratg
$ 200,000 Leon amount

12*12,84) | Monthly payment

R e R

9
10
1 [T TR

12

13

Figure 4-17

fe | =PMT(B3/12,B2%12,84)

A B C D

30 Loanterm invyears
5.5% Annual Interest Rate
$ 200,000 Loanamount

1
2
3
4
:I |($1,135.58)_| Monthly payment

6
7
8
9

[

Figure 4-18




Protecting Excel Data

W)rksheets often contain numerical information that’s confidential,
such as financial or payroll data. In today’s world of electronic
snooping, it's up to you to protect your work against prying eyes.
Fortunately, Excel provides a large number of security tools, such as using
password protection, hiding sensitive worksheet areas, or locking data
against unwanted changes.

This chapter is about the security concerns surrounding Excel workbooks. 1
show you many distinctive protection methods, including how to

»= Hide all or selected areas of a workbook.

m=  Specify that users can view a file but not modify it.
m= Restrict the access to designated worksheet ranges.
w= Mark a file as final to protect it from changes.

w=  Assign passwords to open or modify a workbook.

m= Remove private data from a workbook before sending it to others.

”'%apter

Get ready to. . .

w= Quickly Hide an Open Workbook...............
= Make a File Read-Only......................
w= Open a File as Read-Only ...............cooeen....
= Mark a Workbook as Findl .......................
= Hide Rows and Columns ...........................

w= Unlock Cells

w= Protect Worksheets

w= Restrict User Data Entry.........oooooerrvvrenneee
w= Enter Data in a Restricted Area..................
= [nspect for Private Information..................

w= Hide Cell Formulas

w= Assign a File Password.........................ceeo.
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Ouickly Hide an Open Workbook

1. Choose Viewr>Hide in the Window group. Excel hides the
current workbook, leaving the Excel program open and visi-
ble. If you have another workbook open, you see that work-
book, but not the hidden workbook.

Press the Windows key+M to quickly minimize all open items and to display the Figure 5-1
Windows desktop.

2. Choose Viewr>Unhide in the Window group. Excel displays
the Unhide dialog box listing all hidden workbooks, as
shown in Figure 5-1.

S If no workhooks are hidden, the Unhide button is unavailable.

3. Select the workbook you want to unhide and then click OK.

Make a File Read-Only

1. Choose Filer>Save As. The Save As dialog box opens.

Figure 5-2

2. (Optional) Select a file location from the Save-In drop-down
list and enter a filename.

Click the Tools button. A drop-down list appears.

4. Choose General Options. The General Options dialog box, as
shown in Figure 5-2, appears.

Click the Read-Only Recommended check box.
6. Click OK and then click the Save button.

48



Mark a Workbook as Final

* icrosoft Excel ==
Open a File as Read-Only I
l‘@'\ 'Current Inwentary, xlsx' should be apened as read-only unless you need to sawe changes ta it. Open as read-onky?
1. Choose File>Open. The Open dialog box appears. e ] Lw ) [
2. Locate and select the previously saved as a read-only file you Figure 5-3
want and then click the Open button. A message box
appears, as shown in Figure 5-3.
Click the Yes button and then the file opens.
To save any changes to the file, choose Filem>Save As and
then specify a different filename.
Mark a Workbook as Final
1. Click File and from the Info category, under the Permissions
section, click the Protect Workbook button and choose Mark Figure 5.4

as Final. A message appears.
The Mark as Final feature is designed to prevent accidental changes and isn't
permanent.

2. Click OK. Another message appears.

3. Click OK again; then click File to return to the worksheet.
The file appears as Read-Only and in Protected view, which
displays a warning bar across the top, as shown in Figure 5-4.
Most of the Ribbon features are unavailable.

4. If you intend to edit the file, click the Edit Anyway button.
The file is no longer Read-Only, and you can make changes
as desired.

5. 1If you want to remark the file as final, you must repeat
Steps 1-3.
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Hide Rows and Columns e e ey
1. Select the column or row headings you want to hide. Press B — T

the Ctrl key while selecting multiple rows or columns.

2. Choose Homer>Format>Hide & Unhide in the Cells group.
A menu of options appears.

G H 1 i =
GL SALES GL INVENTORY GL COGS TYPE

You can't hide selected cells; only entire columns or rows.

e ]
3. Choose Hide Rows or Hide Columns. In Figure 5-5, notice PRI PPN R e et
that columns C, D, E, and F are hidden and seem to have et
disappeared. : N 5 2 . B
. 2 Employee Name  Monday Tuesday  Wednesday  Thursday Friday Total ” " jount
4. To unhide rows or columns, select the rows or columns both 3 [BobR s Sl oecives
. 4 Mary$s e
before and after the hidden rows or columns. = 1 s
& |DonadD 5
5. Choose HomewFormat>Hide & Unhide and then choose Pt 2
Unhide Rows or Unhide Columns. 9 fane D S iy
10 TOTALS ]
11 ¥
You can also hide an entire worksheet. (See Chapter 9 for more information.) 2
=
16
Figure 5-6

Unlock Cells

Select the cells you want users to be able to modify.

2. Choose Homer>Lock Cell in the Format group. (See Figure 5-6.)
Because, by default, Excel locks all cells while in a protected
worksheet, choosing this option turns off the Lock Cell option.
The locked and unlocked function doesn't actually take effect
until you protect and save the worksheet. See the following
section.



Protect Worksheets

Protect Worksheets

Choose Reviewr>Protect Sheet in the Changes group. The
Protect Sheet dialog box appears, as shown in Figure 5-7.

A good reason to protect a worksheet is fo prevent accidental changes to formulas.

Make sure the Protect Worksheet and Contents of Locked
Cells check box is selected.

(Optional) In the Password to Unprotect Sheet text box, type
a password. For privacy reasons, only a series of dots appears.
Passwords are case-sensitive.

From the Allow All Users of the Worksheet To box, select any
options a user is allowed to change without unprotecting the
worksheet.

Deselecting the Select Locked Cells check box prevents unauthorized users from even
clicking a locked cell. All cells are considered locked unless you unlock them, as I dis-
cuss in the preceding section.

Click OK.

If you generated a password, a Confirm Password dialog box

appears. Retype the password and then click OK again.

Notice the Protect Sheet option now displays as Unprotect Sheet.

In the protected worksheet, attempt to change the value in a
locked cell. Excel displays an error message, as shown in
Figure 5-8.

To unprotect the worksheet, choose Review—>Unprotect Sheet
in the Changes group.

Enter the password, if prompted.

Excel also provides a Protect Workbook button, which protects not only
the current worksheet but also all worksheets in the workbook.

Figure 5-7
s [ 3 | I

oo | % e :

- 4

A B L 1] E F G H I =
1
2 Employee Mame  Monday  Tuesdsy Wednesday Thursday Friday Tetal Rate Ameunt
3 BobR 1335 69.59 B6.11 5 20895 5 2090
4 Marys 5164 49.06 4661 5 173 12% § 17468
5 loeld 5112 86,56 8224 5 25542 1m% § 2859
& Donald 0 ierime Excal T ) 9% 5§ A5
7 Daniel § e 2 13% §  38.01
S Andy Ch Db ot smmimicnt s oo et S e L s aem
9 laneD Charees i), ens e b proms 7% 8 878
10 TOTALS 5
1
12
13
Figure 5-8
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Restrict User Data Entry

1. In an unprotected worksheet, choose Reviewr>Allow Users to
Edit Ranges in the Changes group. The Allow Users to Edit
Ranges dialog box appeatrs.

2. Click the New button. The New Range dialog box, as shown
in Figure 5-9, appears.

3. In the Title text box, type a short descriptive name, such as
Qty Shipped or Price, for the data entry area.

4. In the Refers to Cells box, enter the range you want to allow
users to edit. Begin the range with an equal (=) sign.

Alternatively, click the Collapse button, select the range in the worksheet, and then
press Enter o return to the dialog box.

5. (Optional) Enter a password that the user must type to gain
access to the cell range in the Range Password box. Without a
password, any user can enter data into the range.

6. Click OK. The Confirm Password dialog box appears.

7. Retype the password and then click OK. The Allow Users to
Edit Ranges dialog box appears with the newly created range.

(See Figure 5-10.)

Select a range name and then dlick the Modify button to change the specifications, or
click the Delete button to remove the input range access.

8. Choose one of the following:

e Click the Protect Sheet button to launch the Protect Sheet
dialog box. (See the “Protect Worksheets” section, earlier

in this chapter.)
e Click the Apply button and add another cell range.

¢ Click OK to accept the changes and close the dialog box,

52 but not protect the worksheet.

Excel doesn't enable the restrict data entry feature unfil you protect

the worksheet.

ASSETS

4 Current Assets

13 Fasts and Supply bveenory
14 Iemantory - Codl
15 Propuid Eapenses

16 Propud Treurancs

17 Tasal Cusrent Assrts

1% Property and Equipment

Figure 5-9
Allow Users to Edit Ranges 7 =a
Ranges unlacked by a password when sheet is pratected:
Title Refers to cells Hew...
(CurrentAssets
Modiy...
Delete

Specify who may edit the range without a password:

[ Paste permissions information into a new workbook

[Protect sheet... | [ ok | [ cancel

Apply

Figure 5-10



Inspect for Private Information

Enter Data in a Restricted Area

On a protected worksheet, in any cell with restricted access,
begin typing data. The Unlock Range dialog box, as shown in
Figure 5-11, appears.

Type the password. Passwords are case-sensitive.
Click OK. Excel allows access to the specific range.

Continue entering cell data as desired.

If a user attempts to enter data in an unauthorized cell, Excel displays a message box.

Inspect for Private Information

L.
2.

Save the workbook.

Click File and from the Info category, in the Prepare for Sharing
section, click the Check for Issues button. A menu appears.

Click Inspect Document. The Document Inspector dialog box
appears.

You can't inspect a document on a workbook with protected worksheets.

Deselect any option you don't want to check and then click
Inspect. Excel inspects the document for the selected information.

When the inspection is complete, the Document Inspector
reappears with information, as shown in Figure 5-12.

Click the Remove All button next to any option you want
removed. Excel removes the selected data. After removing the
data, the Remove All button next to the option disappears.

Repeat Step 6 for any additional items you want to remove.

Click the Close button and save your file.

You can't undo some changes done with the Document Inspector.

B3 - Fe| -1691,97

A

ASSETS

Current Assets

Fiest Financial Account
Fifth Third Arcount
Netional Bank Sweep Acct
National Bank Checking Acc
Business Investment Acct
10 Cash

11 Accounts Receivable

12 Accounts ReceivableOther
13 Parts and Supply Inventory
14 Inventory - Coal

15 Prepaid Expenses

16 Prepaid Insurance

17 Total Curremt Asseis

18

19 Property and Equipment

BNEEIENE

20 Settlement Purchase

1877887
32251
50922333 [,ﬁ 4 cell you are trying to change s password
16915 protected,
2000 Enter the password to change this cel
11,7200 |
L977,474.52
792,059 45
181,000.00
98,281.20
135,232.53
374494271

Unlock Range

3,963,000.00

Figure 5-11

Document Inspector

Rewview the inspection results,

@ Comments and Annotations
No iterns were found,

¥ Document Properties and Personal Information
The Fallowing document information was Found:
* Document propetties
* futhor
* Printer properties (e.g. printer path, secure print passcode, stc.)

& Custom XML Data
No custom XML data was found,

7 Headers and Footers
The Fallowing items were Found:
* Headers
* Footers

?  Hidden Rows and Columns
Number of hidden columns Found: 4
Some hidden columns within PivotTables or table headers cannot be removed.
These types of columns are unhidden when you dick Remove All,

@ Hidden Worksheets
No hidden worksheets Found,

Remove Al

Remove All

Remove All

m

/By Mote: Some changes cannot be undone,

Figure 5-12
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Hide Cell Formulas

1.

Select the cells containing formulas or information you want
to hide.

Choose Homew>Format>oFormat Cells in the Cells group.
The Format Cells dialog box appears.

Click the Protection tab, select the Hidden option, and
click OK.

Protect the worksheet. (See the “Protect Worksheets” section,
earlier in this chapter.) In Figure 5-13, although you see the
results of the formula in cell G2, the formula bar doesn't dis-
play the actual formula.

Assign a File Password

Choose Filer>Save As. The Save As dialog box opens.

Click the down arrow on the Tools button and choose
General Options. The General Options dialog box appears.

Type a password in the Password to Open text box if you
want users to enter a password before they can open and
view the workbook. (See Figure 5-14.)

(Optional) Type a password in the Password to Modify text
box. Users must have the workbook open before they're
prompted for the password to modify.

Click OK.

Retype the password to open; then click OK. Retype the pass-
word to modify; then click OK.

Click the Save button and then click the Yes button, if you're
prompted to overwrite the file.

Figure 5-13

File paema: My Infie

= Hide Folders

Figure 5-14

Save a5 type: | Extel Workbook
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Formatting Cells

w hoever said, “Looks aren’t everything,” wasn't staring at an unformat-
ted Excel spreadsheet. Columns often aren’t wide enough, fonts are
too small to read, dates display in an unusual manner, and when columns
of data are stacked next to each other, sometimes the information overlaps.

Fortunately, Excel includes a plethora of features to make your data more
presentable and easier to read. In fact, Excel has so many appearance-
altering features, I had to break them up into two chapters! In this chapter,
you master the following Excel formatting features:

== Change the font type, size, and style of text, values, or dates.

== Change the alignment of data in a cell from the standard left-aligned
for text and right-aligned for values or dates.

»= Turn values into currency or percentages.
w=  Create titles with the Merge and Center button.

w= Change column width and row height.

I“*napter

Get ready to. . .

w= Format Values

= Adjust Column Width

w= Change Row Height

= Align Data Horizontally and Vertically........

w= (reate a Title by Merging Cells ..................

w= Change Font Color
w= Select Font Attributes

w= Apply Cell Background Colors

= Wrap Text in a Cell

w= Rotate Text

58
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60

62
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64
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Chapter 6: Formatting Cells

Format Values

1. Select the cells you want to format. You can select a few cells,
entire rows, entire columns, or the entire worksheet. (See
Chapter 2 for information on selecting multiple cells.)

2. Choose Homer>Number Format in the Number group. A list
of options appears. (Figure 6-1 shows values formatted in
various Excel styles. Notice the different dollar sign place-
ment in the Accounting and Currency types.)

The Number group on the Ribbon also displays three icons you can use fo quickly for-
mat as Accounting, Percent, or Comma styles. The Accounting option has a drop-down
list from which you can select different international currency symbols. The Comma
option adds two decimal places and a comma between the thousands; it doesn’t
include a dollar sign. The Percent option adds a percent sign and no decimal places.

3. To remove digits to the right of the decimal point, choose
Homer>Decrease Decimal in the Number group. To add deci-
mal digits, click the Increase Decimal button. Each click adds
or removes a number to the far right of the decimal point
and rounds the value in the cell. (See Figure 6-2.)

If you see a cell with values displaying ###4###, you need to widen the column width.
(See the following section.)

Another method to select number formatting is clicking the Number dialog box
launcher, which displays the Format Cells dialog box. Number format selections
are on the Number tab.

Excel numbers can display up to 30 decimal places.

Figure 6-1
n Fan Puge For Data  Srdes L
& ‘ A A ] B - &
‘j BrUg- Z- S A EERRE H 5%
alg - &
A B C 8] E H
1
2 1,235
3 1,234.6
4 1,234.57
L 1,234,568
6 1,234.5679
i 1,234.56789
8
]
10
ik
Figure 6-2



Adjust Column Width

Adjust Column Width

1. To adjust the width of column headings, select the ones to be
widened. If you want to adjust a single column, click any cell
in that column.

If your worksheet contains many numbers, you can widen the columns to make the
worksheet less cluttered. Columns that especially need widening are those containing
cells with truncated text enries or numbers that Excel shows as ###44#.

2. Choose a method to adjust column width:

e To manually change the width of columns, position the
mouse pointer on the right boundary of the column head-
ing until it turns into a double-ended arrow. Drag until
the column is the width that you want. As you move the
pointer, a balloon message displays the new width. In
Figure 6-3, I'm expanding column A.

Excel displays cell width in characters and pixels instead of inches. The minimum
column width is 0 characters, and the maximum is 255 characters.

e To set column width to a specific setting, choose
Homer>Format>Column Width in the Cells group.
The Column Width dialog box, as shown in Figure 6-4,
appears. Type the exact width you want; then click OK.

e To automatically change the column width so it fits the
widest entry, double-click the boundary on the right side
of the column heading or select the column and choose
Homer>Format>AutoFit Column Width in the Cells
group. Excel sets the width slightly larger than the longest
entry in the column.

The default column width is 8.43 based on the default 11-point Calibri font. If you
change the default font type or size, Excel may also change the standard column
width. You can manually set a default column width by choosing Home=>Format=>
Default Width in the Cells group.

Figure 6-3

Column Width [ % |E%]

Column width: | 5,43

[ OK ][ Cancel ]

Figure 6-4
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Change Row Height :

1 Applicant Name

Height: 28.50 (38 pixels,

1. Highlight the row headings whose height you want to adjust.

If you want to adjust a single row, click any cell in that row.

2. Choose a method to adjust row height: 2
e To manually change the row height, position the mouse L
pointer on the bottom boundary of the row heading until 9
it turns into a double-ended arrow. Drag until the row Figure 6-5

is the height that you want. As you move the pointer, a
balloon message displays the new height. In Figure 6-5,
I'm increasing the height of rows 2-7.

Excel displays row height in characters and pixels instead of in inches.
Figure 6-6

e To set row height to a specific setting, choose Homer>
Format=>Row Height in the Cells group. The Row Height
dialog box, as shown in Figure 6-6, appears. Type the exact
height you want; then click OK.

e To automatically change the height of the row so it fits
the tallest entry in the row, double-click the boundary on
the bottom of the row heading or choose Home=>Format=>
AutoFit Row Height in the Cells group. Excel examines the
row’s contents and sets the height slightly larger than the
tallest entry.

S The default row height is 15 based on the default 11-point Calibri font. If you change

the default font type or size, Excel may also change the standard row height. You
can't manually set a default row height.
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Align Data Horizontally and Vertically

Align Data Horizontally
and Vertically

1. Select the cells you want to align.

2. Choose Home and in the Alignment group, select one of
these alignment buttons:

e Align Left: Horizontally aligns the data along the left edge
of the cell.

e Center: Centers the data horizontally in the middle of the
cell. If you modify the column width, the data remains
centered to the new column width. Cells B4-F4 are
center-aligned in Figure 6-7.

e Align Right: Horizontally aligns the data along the right
edge of the cell.

Values formatted as Accounting can display only as right-aligned. You can change
alignment on all other formatting styles.

e Top Align: Aligns the data vertically along the top edge of
the cell.

e Middle Align: Centers the data vertically in the cell.

e Bottom Align: This is the default option and aligns the
data along the bottom edge of the cell. Notice the heading
in Figure 6-8. Cell A1 shows the default bottom vertical
alignment whereas cell A2 shows the top alignment.

(Optional) You can view additional alignment options and align both the horizontal
and vertical alignment at the same time with the Format Cells dialog box. From the
Home tab, click the Alignment group dialog box launcher. If necessary, dlick the
Alignment tab and then set any desired alignment options; then lick OK.

* s ‘ ) DI S=nser|

N N - Y b ij 3?;& -4 3 Delet)
g s 0 | W8 st G gy
Clipboard s Il Mumber Il Styles Cells.

B4 - £ | TESTL

A I B I c [ D E F [ &

1 2010 Testing Results
2 January-June
3
4 TEST 1 TEST 2 TOTAL PROJECTED DIFFERENCEl
5 January 416 237 653 447 206
6 February 297 351 648 399 249
7 March 223 188 411 313 98
8 April 251 369 620 600 20
Figure 6-7
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1 2010 Testing Results

January - June

TEST1 TEST2 TOTAL PROJECTED DIFFERENCE

February
March
April

Figure 6-8
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Cre ate a Tl‘t,e b y M er q l‘n q Ce ”S If you choose a light font color, add background shading fo make the

font color show.

1. Select the cell containing the data you want to merge and the
cells you want to include in the merge. The data cell must be

in the left cell of the selection and the other cells can’t con- e e e T
tain data. (See Figure 6-9.) Ao A mlal B
Blru- - ®-A- F&AiFR Es - % o+ Wl
2. Choose Homer>Merge and Center in the Alignment group. e - - a
All the selected cells merge into one larger cell, and the data = = =Bl

A B C D E F G

is centered horizontally.

1 |2010 Testing Results

If you select cells vertically and dick the Merge and Center button, Excel merges the January - June
cells and vertically bottom aligns the data.

4 TEST1 TEST 2 TOTAL PROJECTED DIFFEREMNCE
5 lanuary ali 237 653 aar 206
: 1,: H 6 Februa 97 351 G48 399 249
After clicking the Merge and Center button, you can chqnge the alignment. Select the Ty = - - e &
merged cell and click the Merge and Center button again to unmerge the cells. 8 Aprll 251 369 620 600 20
Figure 6-9
Change Font Color
1. Select the cells you want to format.
2. Choose Home and in the Font group, click the Font Color
drop-down arrow to select a color, as shown in Figure 6-10.
Excel’s Live Preview feature shows you the selected cells in
the new font colors.
Choose More Colors to display the Colors dialog box from which you can select addi-
fional colors as well as create your own custom color. Figure 6-10

Another method to select font color is through the Font dialog box launcher, which dis-
plays the Format Cells dialog box. Font color selection is on the Font tab.
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Wrap Text in a Cell

1. Select the cells you want to format.

2. Choose Homer>Wrap Text in the Alignment group. As in
Figure 6-13, if the selected cells contain more text than will
fit the width of the cell, Excel displays it on multiple lines.
Notice that Excel automatically increases the row height to
accommodate the additional text lines.

Selecting the Shrink to Fit option on the Alignment tab of the Format Cells dialog box
(instead of choosing the Wrap Text option) allows Excel to automafically change the
font size in the selected cell. This forces the data fo fit within the cell's current width.

Rotate Text

1. Select the cells you want to format.

2. Choose Homew>Orientation in the Alignment group. A list of
options appears:

e Angle Counterclockwise: Angles the text in the cell from
left bottom to right top.

e Angle Clockwise: Angles the text in the cell from left top
to right bottom.

e Vertical Text: Centers the text and places one letter on top
of the other, from top to bottom.

e Rotate Text Up: Places the text on the lower-right side of
the cell and runs it vertically up the cell.

e Rotate Text Down: Places the text on the lower-left side of
the cell and runs it vertically down the cell.

From the Alignment tab of the Format Cells dialog box, you can select a specific
degree of rotation.
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3. Choose an option. The selected cells take the rota-
tion you choose. In Figure 6-14, you see the cells
angled counterclockwise.

Figure 6-13
File | Home Insert Page layout Formulas Data . Review Wiew
2 i- Calibri S A AT 5 General - ij}‘ %E'ﬂ‘ ,’—;‘d‘ i:ID";
g Blruc @A M ERRRAE Rl e
Clipboard Font & Mumber £l Styles Cel
B4 - Je | TESTL
A B C D E F G
1 2010 Testing Results
Janaarg - Jung

2
3

. o &

Report date: C\‘" 6\
August 16, <y Vv g & ‘:8“
& & St & N

4 |2010 < < < ] 9
5 January 416 237 653 447 206
6 February 297 351 648 399 249
7 March 223 188 411 313 98
8 April 251 369 620 600 20
Figure 6-14



Applying Additional
Formatting Options

Chapter 6, I discuss many of the Excel features designed to change the

n

I cell data appearance. In this chapter, you discover a few more of the excit-
ing Excel formatting features created especially to make your worksheet
more interesting and easier to read, such as

=

=

Iy

-y

3

=

1)

Save time with the mini toolbar and the context-sensitive menu.
Liven up the worksheet with effective use of borders and lines.

Format cells containing dates and discover ways to use dates in
calculations.

Reduce redundancy with the Format Painter.

Effectively use predefined styles and themes that carry a single design
through all Office products.

Specify conditional formatting to designate cell appearance if the cell
value conditions are met.

Add data visualizations to help you more easily determine the top or
bottom values.

”'%apter

Get ready to. . .
w= Use the Mini Toolbar
w= Change the Default Font..................ooooceo..

w= Place Borders around Cells .......................
w=> Work with Date Formats............oovveeeeeenene.
w= se Dates in a Calculation ......eeeeeeeeeee...

w= Format Telephone, Zip Code, and
Social Security Numbers...........oooeeee......

w= Copy Formatting

w= [ndent Data in Cells
e Use Cell Styles

w= Format Cells as a Table..........ovooeeeeeeennee..

w= Specify Conditional Formatting ..................

w= Add Data Visualizations ...........ooeeeeveeenne...
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Chapter 7: Applying Additional Formatting Options

Use the Mini Toolbar s

1. Right-click a cell or a group of cells. As shown in Figure 7-1,
the mini toolbar and a shortcut menu appear.
1
The mini toolbar contains many of the formatting commands available on the Home =
tab, making it unnecessary for you fo actually click the Home tab. 3
5 January 416 7‘3 - :1:17 ?D.b
& Februm 297 [} e R 399 249
. . 7 March 75 [ i~ 313 98
2. Choose the formatting attribute you want to apply. The cells o 2 s 2
. . . . 9 vy E 4
take the selected attributes, and the mini toolbar remains 10 1une a7 108 7
el s 11 TOTAL 1788 2514 1062
open for you to make additional selections. 12 AveRace 208 "9 177
13
3. Click any cell to close the mini toolbar.
Change the Default Font TR ' oo
L i 2 ~
Figure 7-1
1. Click File and then click Options. The Excel Options dialog
box appears. Excel Options Eae
General :h eneral options for working i el
2. If General isn't already selected, click it; then click the Use F— EG cenerstopions forworking win s
This Font drop-down list. (See Figure 7-2.) ootna e oo
save Show Mini Toolbar on selection &
. nable Live Previews
3. Select the font type face you want to use in all new e comrmens ]
WOI'kbOOkS. im:md - SereeriTip style: | Show feature deseriptions in SereenTips |+ ]
L e s .
. o . . Use this font: Body Font
The Excel 2010 default font is Calibri 11 point. st o i o 1]
Trust Certer Default siew for new sheets: |0 oF o |=
b gency FB =
Include this many sheets: Aharoni -
Personalize your copy of Mico: :Lg; ar ; ::
Angsana New
Usermame: [Windows User |y oo ioe
4. (Optional) Open the Font Size drop-down list and choose e ssting
the font size you want to use in all new workbooks.
Arial Marrow
. . izl Rounded MT Bold
5. Click OK twice and then exit and restart Excel. it Umcode s
Batang
BatangChe
See Chapter 14 for more information on setfing Excel options. g
e s e
o
oo o E
Sheet3 /%0 Bodoni MT Condensed - w1 a0

06 Figure 7-2



Work with Date Formats

Place Borders around Cells o

= Calibri 11 v AT AT
= gy s

Faste B|7 U g ]
- - &

Insert Page Layout Formulas Data Rewiew Wieww ;

== fo

Si General -

»
]

= $ - % v | %% FCD”d‘
arma

1. To add a border, select the appropriate cells.

Clipboard Fl Mumber Fl

Bottom Border

2. Choose Home and in the Font group, click the arrow next to
the Borders button. A variety of border options, as shown in
Figure 7-3, appears.

Top Border
D E
o LeftBorder

| Right Border

i Mo Border g RQSUHS

All Borders
Outzide Borders - Jung

Thick Box Border

The Borders ScreenTip may display Bottom Border, Top Border, or whatever border
was last used.

Bottom Double Bitder

Thick Bottom Barder TOTAL PROJECTED D
Top and Bottom Border 653 447

3. Select the border you want. Excel applies the border to the January

selected cells February E Top and Thick Bottom Barder 648 399
’ March £ Top and Double Bottam Border 411 313
. April Draw Borders 620 600
For more border styles, colors, and options, choose More Borders to open the Format P A oraw Barder
Cells dialog box. May . CrowBorger o 362 347
10 |June @ | Ersse Border 682 408
11 |[TOTAL i Line Colar r 3576 2514
12 | AVERAGE tine style g 596 419
« 13 [ More Borders...
Work with Date Formats 14
i : Figure 7-3
1. Enter a date into a cell. Depending on what you type, Excel
probably displays the date in a different format than you e -
typed. Figure 7-4 shows some date examples. N L -l  E
Py BRIU- D @A EEEEEHE
Dates are actually numeric values, and you can use them in Excel calculations. (See e v -
. . A B £~
the following section.) B Yourre Eic el Sophivs =
2 102/14 14-Feb
3 D2/14/10 2/14/2010
4 02/14/2010 2/14/2010 |
2. From the Home tab, click the Number dialog box launcher, s :'::r:‘“m ateb
which displays the Format Cells dialog box. 7 February 14,2010 14.Feb 10

3. Click the Date category. The right side of the screen displays a L ———  —TT

variety of different date formats, also shown in Figure 7-4. g oo Dot Sunday, February 14, 2010 |
4. Select a format for the selected cells and then click OK. i
16 =
(Optional) Select Short Date or Long Date from the Number Format drop-down list in 17

the Number group on the Home tab. Figure 7-4
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Use Dates in a Calculation

1. Enter a date into a cell. You can format the date any way you
want.

2. Enter another date into another cell.

To have the cell dynamically display the current date, enter =Today(). To enter
today’s date as a stafic value, press Cirl+; (semicolon) and press Ener. To enter the
current time as a static value, press Cirl+: (colon) and press Enfer.

3. To find the difference between the two dates, create a
formula that subtracts one date from another. For example,
in Figure 7-5, I put the first date in cell B3 and the other date
in cell B5; in cell C5, I entered the formula =B5-$B$3 to find
the difference between the dates.

Occasionally, Excel may display the formula result as a date instead of a value. If
Excel does, choose Home and in the Number group from the Number Format list,
choose Number.

To calculate the number of days between a specific date and the present time, enter
the specific date in a cell, such as A1, and then in another cell, enter the formula
=NOW()-AL

Format Telephone, Zip Code, and
Social Security Numbers

1. Select the cells you want to format.

2. Choose Home and then click the Number dialog box
launcher. The Format Cells dialog box appears.

3. Click Special in the Category list. A list of special formatting
options appears, as shown in Figure 7-6.

4. Choose the option you want and then click OK.
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E Home Thsert Page Layout Formulas Data Pewiew Wiew
& Tahoma
Paste T - | T
7 B I U & )
Clipboard 1 Font Alignment Number
© h e .,.... ;
A B C
1 Planting Record
2
3 |PLANT DATE 4f11£2010
GERMINATION DAYS TO
TYPE DATE GERMINATE
Sunflower 4/22/2010] |
Calendula 4/18/2010
7 Poppy 4/17/2010 6
8 |Cornflower 4/23/2010 12
9 Marigold 4222010 11
10 Zinnia 4/20£2010 9
11 Nasturtium 4/19/2010 8
Figure 7-5
- 0-v
g BIUC DB A EERER O $-% 0 Yoot
A B c TR
X Formatti
. You enter this {i:g'l-:ils t:igs
2 Zip Code 462011234 46201-1234

3171234567 (317) 1234567

201234567 901-23-4567

3 Telephone
4 |Social Security

Figure 7-6




Indent Data in Cells

i
Eifomut | 3

Copy Formatting

s Bl TG I P [ E &m0 o a

1. Click a cell containing formatting you want to copy.

2. Choose Home=>Format Painter in the Clipboard group. The | j
mouse pointer is a white plus sign along with a paint brush, ; T TP W T TS

as shown in Figure 7-7. b - 2 n om m
3. Click or drag across the cells you want to format. Excel imme- ¢ m o w e wl e B @ s
diately applies formats such as font, size, colors, borders, and WY E— T IR lioice  wmw me ey
alignment.
8 Figure 7-7
Double-click the Format Painter tool to lock it in so you can paint additional cells with- B o | ot oot Formns Dot Fevew view
out having fo reselect the tool. Click the Format Painter tool again fo unlock it. e .
§ Calibri T 11 v A A
Fbd :j [Blr - - &-A-
Clipboard & Font
To quickly copy the width of one column to another column, select the heading of the Ad - £ | January
first column, click the Format Painter tool, and then dick the heading of the column
where you want to apply the column width.
1 2010 Testing Results
Janaarg - Jung
1 ‘ :
ndent Data m CB”S 3 | TESTMONTH  TEST1 TEST 2 TOTAL PR
. 4 January 416 284 700
1. Select the cells you want to indent. |5 | February 297 351 548
2. Choose Homer>Increase Indent in the Alignment group. Each | 6| March 223 188 1
. 7 | April 251 369 620
Increase Indent button click adds a small amount of space 51 M 577 285 62
between the cell border and the data itself. (See Figure 7-8.) o Jun: 34 355 o
How Excel indents depends on how you format the cell: 1o ToTAL 1,788 1,635 3623
e |f the data is left aligned, Excel indents from the left. 11 AVERAGE 298 306 604
12
e |f the data is right aligned, Excel indents from the right. Figure 7-8

o If the data is centered, with the first click, Excel indents
from the right; but subsequent clicks cause Excel to move
the data from the left to the right.

(lick the Decrease Indent button fo remove indentation.
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Use Cell Styles

1. Select the cells you want to format.

2. Choose Home=>Cell Styles in the Styles group. In Figure 7-9,
you see that Excel displays a gallery of predefined styles.

Excel styles include Normal (the default style for regular cell text), Heading 1-
Heading 4 (suitable for worksheet headings), and several accent styles.

3. Select the style you want to use.

Format Cells as a Table

1. Select the data you want to format as a table.

Typically, tables are used to manage related data by organizing it under column
headers into multiple rows of similar data.

2. Choose Homer>Format as Table in the Styles group. A gallery
of Excel themed formats appears. (See Figure 7-10.)

Themes are predefined style sets that appear across the entire Office suite, providing
consistency in your work appearance.

3. Select the table style and theme you want to use. The Format
as Table dialog box appears.

4. Confirm that the selected cells contain the data you want to
format.

5. 1If the top row of your selection contains the headers, make
sure the My Table Has Headers option is selected.

6. Click OK. Excel formats the table and applies filter arrows to
each header. (See Chapter 16 for information about filter-
ing.) The Table Tools Design tab appears.
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Specify Conditional Formatting

Specify Conditional Formatting

1.

Select the cells to which you want to apply conditional
formatting.

Reasons for using condifional formatting might include locating dates that meet a cer-
tain condifion (such as falling on a Saturday or Sunday), specifying highest or lowest
values in a range, or indicating values that fall under or over a specified amount.

Choose Homer>Conditional Formatting=>Highlight Cells
Rules in the Styles group. A list of options appears.

Select the criteria you want to use. Criteria options include
Greater Than, Less Than, Between, Equal To, Text That Contains,
A Date Occurring, and Duplicate Values. A dialog box opens
where you can specify the value. In Figure 7-11, in order to see
which items went over budget, use the Less Than criteria.

Enter the values you want to reference in the text box. The
number of boxes depends on the criteria you selected in Step
3. You can type a value here, such as 500 or 0, or you can ref-
erence a cell address, such as F13.

Click the drop-down arrow next to the format options so that
you can specify the format options to employ if the condi-
tion you specified is TRUE. Live Preview shows you what
your data will look like.

Click the Custom Format option where you can create your own format, selecting from
font styles and color, numeric and other formats, borders, patterns, or background
color.

Click OK. In Figure 7-12, you see formatting options applied
to cells that meet the specified criteria of being less than 0
(meaning, in this example, items over budget).

Repeat Steps 2-6 to apply any additional conditions.

To clear conditional formats, go to the Home tab and in the Styles group, choose
Conditional Formatting=>Clear Rules=>Clear Rules from Selected Cells.

Figure 7-11

1 Actual Budget Variance
2 Costof Sales
3 FICA 42,913.26 30,018.97 (12,894.29)
4 | Medicare 10,036.39 5,602.47 (4,433.92)
5 FUTA 2,413.92 2,269.33 (144.59)
6 sul 16,896.74 15,310.65 {1,586.09)
7 Accrued Payroll Expense {7,765.97) - 7,765.97
g Direct Labor Wages 515,125.31 436,552.89 (78,572.42)
9 Labor - Overtime 82,690.49 47,624.00 (35,066.49)
10 Workers Comp 16,191.24 12,394.93 (3,796.31)

El Subcontractors 60,139.00 (60,139.00).
12 Job Materials 333,022.74 230,182.44 (102,840.30)
13 Job Equipment Rentals 14,252 55 34,289.25 20,036.70
14 Special Job Costs - 317.50 317.50
15 Bonus for Job Evaluations 480.00 793.74 313.74
16 VehiclefJob Expense 34,331.11 29,700.00 (4,631.11)
17 Total Cost of Sales 1,120,726.78 845,056.17 (275,670.61)
18
19

Figure 7-12
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Add Data Visualizations

1. Select the cells to which you want to apply formatting.
Choose Homer>Conditional Formatting.
3. Select from the following options, as shown in Figure 7-13:

e Data Bars: A gradient-style bar helps you see the value of a
cell relative to other cells. The length of the data bar repre-
sents the value in the cell, so a longer bar represents a
higher value and a shorter bar represents a lower value.
The data bars have six color options designed to match
Excel themes.

e Color Scales: Designed to visually help you understand
your data, color scales compare a range of cells by using
two colors representing higher or lower values or three col-
ors representing higher, middle, or lower values. The color
scale bars come in six color themes, including red, yellow,
and green. You can also create your own scheme by choos-
ing More Rules under the Color Scales options.

e Icon Sets: Icon sets help you classify data into three, four,
or five categories with each icon representing a range of
values such as higher, middle, and lower. As shown in
Figure 7-14, icon sets include arrows, traffic lights, clocks,
and even smiley faces.

The icon size you see depends on the cell font size. You may need to adjust the
column width to accommodate the icon.

To clear data visualization formatting, select the formatted cells and then choose
Homer> Conditional Formatting=>Clear Rules=>Clear Rules from Selected Cells in the
Styles group.
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Designing with
Graphics

Sometimes, even after adding font and style attributes to cell data, you
still want to call extra attention to specific areas. Maybe you want to add
an arrow to point to a problem area. What? You can’t draw a straight line?
That's okay because with Excel, you don’t have to be a gifted artist to draw.

Whether you want to draw circles, squares, lines, or arrows, Excel provides
tools to assist you, making the drawing process fun and easy.

In this chapter, you discover how to

w= Draw arrows, shapes, and annotation boxes, plus add depth to your
art using shading and dimension.

== Insert Clip Art, which is a collection of ready-made, computerized
graphic illustrations.

»= Insert a photograph or your company logo, making your viewers
sit up and take notice of your worksheet.

w=  Ise WordArt, stylized text objects, which add pizzazz to your
worksheet.

»= Manipulate and manage all the earlier mentioned graphic objects —
by moving, resizing, cropping, rotating, recoloring, and using many
other options.

”'%apter

Get ready to. . .

e [llustrate with Arrows ................ceeeveeeeeeee 74
w= Draw with Shapes 75
w= [nsert Saved Images 75
w=» Add Aristic Effects and Use Picture Styles......76
w= Select a Transparent Color ..............coovvee. 77
w= Change a Picture 77
w=> Annotate with Text BoXes....................cooen 78
w=> Add Clip Art and Create WordArt.......... 79-80
w= Manipulate Graphics 81
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Add Artistic Effects

1. Select the image you want modified.

2. Choose Picture Tools Format>Artistic Effects in the Adjust
group. A gallery of photo special effects appears. As you
hover your mouse pointer over any effect, a preview of it on
your image appears. In Figure 8-5, I put two identical pictures
side by side so you can see the original on the right as well as
the one with the special effect, which in this example, is

Glow Edges.
3. Choose the effect you want. Figure 8-5
Don't like what you've done to an image? Choose Picture Tools Formatc>Reset FEES inad i Bt S | - o7
Picture. All cropping, resizing, color adjustment, special effect, or any other changes NS T F | b |
to the image disappear! S rRDEo@EE 2 !
I A ; = ; = {j = E F [ )
Use Picture Styles ; Sl J S ‘
s x:;qu H=D9 4900 49 w-‘i
. 6 2nd Qtr B : _H8.00 55 L
1. Select the picture you want to manage. Handles appear 7 3rdQu 1795900 28517000 843700 54 -
. 5 4th Qtr 235679.00  462,394.00 9734400 795
around the selected picture. s TOTALS 74523700 129198000 35750800 2,394
Choose Picture Tools Format and find the Picture Styles group. u e =
Click the More button, located directly under the Picture Fi.gure 8.6

Styles scroll buttons, to see the complete gallery of options,
as shown in Figure 8-6. As you hover your mouse pointer
over an option, you see your picture with a preview of the

style.

4. Select one of the preformatted shapes or three-dimensional
effects.

Pick additional picture enhancements by choosing Picture Tools Format, locating the
Picture Styles group, and then choosing Picture Shape, Picture Border, or Picture
Effects.
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Change a Picture

Select a Transparent Color

1. Select the image you want modified and then choose Picture
Tools Format=>Color in the Adjust group. A gallery of color
adjustments appears.

2. Choose Set Transparent Color. The mouse pointer turns into
a pointer with an arrow on the end of it.

3. On the image, click the image color you want transparent. In
Figure 8-7, you see the original image on the right and the
one with the transparency on the left. On the left image, I
clicked the white background, so anything white in the image
became transparent. You can now see data and cell gridlines
through the image background.

You can also select color changes. For example, you may want to change both the
tone and the saturation levels. Choose Picture Tools Format=>Color and then make a
selection. For additional color options, from the Color Adjusiment gallery, choose More
Variations.

Change a Picture

1. Select the image you want to replace.

2. Choose Picture Tools Format=>Change Picture in the Adjust
group. The Insert Picture dialog box appears, as shown in
Figure 8-8.

3. Locate the picture you want and click the Insert button. Excel
replaces the existing photo with the new image, retaining the
picture style you've selected already.

The new image does nof pick up the artistic effects, transparency, cropping, or
coloring modifications from the previous image.

guit + Mcrosott Excel e

2 Pt bt

CELET L

A B C D E F G LS
1 I Love My Tools, Inc.
2 Sales-by-Quarter
3
4 Drills Saws Grinders T
5 1stQur 145,632.00 24600 (8634900 4
& 2nd Qir 184,378 o 8941800 5§ =
7 3rdQtr 179,549, = W ea39700 5 ﬂu E ‘i
4 4thQur 23567900 462,394.0G_amy 9734400 7 b
a TOTALS 745237.00 1,291,950, 750800 2.3 |~ ]
10
11
12
13
Figure 8-7
Figure 8-8
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Annotate with Text Boxes

1.

Choose Insert=>Text Box in the Text group. The mouse
pointer looks like an upside-down cross.

Click and drag diagonally on the worksheet to draw the box
the approximate size you want. You can resize or move it
later if necessary. You see a text box like the one shown in
Figure 8-9. A blinking cursor appears inside the text box.

Type the desired text and then click outside the text box to
deselect it.

Depending on the text box size and location, the text box may cover worksheet cells.
See the “Manipulate Graphics” section, later in this chapter, o see how to move the
text box out of the way.

Right-click the text box and choose Format Shape. The Format
Shape dialog box (as shown in Figure 8-10) opens. In this
dialog box, choose from any of these formatting options or
the other options in the dialog box:

e To add a background fill to the text box, click Fill and
select an option from the right side of the dialog box.

¢ To change the border color that surrounds the text box,
click Line Color and choose a line color option.

e To change the style of line surrounding the text box, click
Line Style and choose any desired options.

e To add a shadow around the text box, click Shadow and
then choose an option from the Presets drop-down list.

e Make the text box three-dimensional with choices in the
3-D Format and 3-D Rotation tabs.

From the Text Box tab, select Resize Shape to fit text. As you
add or remove text from the text box, the box expands or
contracts to fit around the text.

Click the Close button when you finish making your
selections.

2nd Qtr
3rd Qtr
4th Qtr
3  TOTALS

1
2
5
4
5 1stQtr
3
7
8

B G o E ;
I Love My Tools, Inc.
Sales by Quarter

Drills Saws Grinders TOTALS |
14563200  259,246.00 86,3900  491,227.00
184,377.00 285,170.00 89,418.00 558,965.00
179,549.00  285170.00 84,397.00  549,116.00
235679.00 462,394.00 97,344.00 T95,417.00
74523700 120198000 35750800 2,394,725.00 |

Great increase in
sales!

@ 1]
D 3

ic.

Grinders TOTALS |
86,349.00 491,227.00 |
89,418.00 558,965.00 |
8439700  549,116.00 |
97,344.00 795,417.00 |

| Greatincrease in i
. sales! |

357,508.00  2,394,725.00 |

Figure 8-10




Add Clip Art

Add Clip Art

1.

Choose Insert=>ClipArt in the Illustrations group. The Clip
Art task pane appears, as shown in Figure 8-11.

In the Search For box, type a brief description of the image
type you want, such as food, buildings, animals, or people.

If you want to include Office.com in your search, select the
Include Office.com Content check box.

Choose the type of image you want from the Results Should
Be drop-down list. Excel can locate Clip Art, photographs,
movies, or sound files.

Click the Go button. Excel displays a number of images rep-
resenting the art you specified.

Select the desired image. Excel places the image onto your
worksheet, as shown in Figure 8-12.

Click the Close (X) button to close the Clip Art task pane.

Clip Art -
Search for:

kools|
Resuls should be:

All media file types IZ|

[ tnclude ©Ffice. com content

Y

0}) Find mare at Office.com

e Hints for finding images

Figure 8-11
A B C D E F G
1 I Love My Tools, Inc.
2 Sales by Quarter
3
4 Drills Saws Grinders TOTALS
5  1stQtr 145,632.00 259,246.00 86,349.00 491,227.00
| 6 | 2ndQtr 18437700  285170.00 89,418.00  558,965.00
7 3rd Qtr 179,542.00  285,170.00 84,397.00  549,116.00
8 | 4th Qtr 235679.00  462,394.00 97,344.00  795,417.00
9  TOTALS 745237.00  1,291,980.00 357,508.00  2,394,725.00
10
11
12
13
14
15
16
Figure 8-12

79






Manipulate Graphics

Manipulate Graphics

1. Select the object you want to modify. Selection handles
appear around the object.

2. Perform any of the following actions:
e Delete: Press the Delete key on the keyboard.

e Move: Position the mouse pointer over the object, but not
on the handles. Click and drag the object to the desired
location.

s (Optional) Nudge a selected object by using the up, down, left, or right arrow keys.

e Resize: To resize an object, position the mouse pointer
over one of the white selection circles and drag the circle
until the object reaches the desired size. Use the top or
bottom middle handle to resize the object height. Use the
middle left or right handle to resize the object width. Use
a corner handle to resize both the height and width. See
Figure 8-15.

; If you want to consirain the sizing when resizing an object, hold down the Shift key.

e Rotate Shape: Position the mouse pointer over the green
rotation handle until the pointer turns into a circle. Then,
drag the green rotation handle until the object rotates to the
desired angle. See Figure 8-16. This doesn’t apply to arrows.

e Rotate Arrow: Drag the white selection handles in the
direction you want to rotate.

To constrain rotation to 15-degree angles, press and hold the Shift key while rotating
the obiect.

E, Inc.
ter 7
0
P
P
o | - o 1
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+ = 1] -
' H&B = il\
i
Figure 8-15
Figure 8-16
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Crop an Image

1. Select the image you want to modify and then choose Picture
Tools Format=>Crop in the Size group.

2. Position the pointer over one of the crop handles. Crop han-
dles appear at each corner, in the middle of each side, top,
and bottom, as shown in Figure 8-17.

3. Click and drag a crop handle inward to crop an area of the
image. In the image on the right, I'm cropping the back-
ground away from the bird.

4. Release the mouse button. Figure 8-17

Continue cropping other edges of the image, as needed, and

then click the Crop button again to turn off the Crop tool.

Excel crops the image.

Flip an Object

1. Select the object you want to flip.

2. Choose Picture Tools Formatr>Rotate in the Arrange group. A
menu of choices appears. While you hover your mouse pointer
over a menu option, Excel previews the effect on the picture.
In Figure 8-18, in the image on the left, the bird faces left, and
after flipping the image on the right, the bird faces right.

Efgure 8-18

3. Select from the following options:
Rotate Right 90°

Rotate Left 90°

Flip Vertical

Flip Horizontal

S Choose More Rotation Options to display the Format Picture dialog box where you can

set many options precisely including size, rotation, and cropping.
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Align Multiple Graphics

Align Multiple Graphics

1.

Select the first object, and then hold down the Ctrl key and
select one or more subsequent objects.

For assistance in selecting multiple objects, select one object and then choose Drawing

Tools Formatc>Selection Pane.

Choose Drawing Tools Formatr>Align in the Arrange group.
A list of options appears. (See Figure 8-19.) Here are some of

the options:

e Align Left: Aligns two or more objects so their left edges
are the same as the leftmost selected object.

e Align Right: Aligns two or more objects so their right
edges are the same as the rightmost selected object.

e Align Top: Aligns two or more objects so their top edges
are the same as the highest selected object.

e Align Bottom: Aligns two or more objects so their bottom

edges are the same as the lowest selected object.

¢ Distribute Horizontally: Aligns the objects left and right
so they're an equal distance horizontally from each other.

You must have at least three selected objects to use this
feature.

e Distribute Vertically: Aligns the objects up and down so
they're an equal distance vertically from each other. You

must have at least three selected objects to use this feature.

Choose a menu option. Figure 8-20 shows three arrows

aligned along the bottom edges and with the space between

them horizontally evenly distributed.

Figure 8-20
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them later. To ungroup the object, choose Drawing Tools Formatc>
Group=>Ungroup in the Arrange group.

Co ntro I Ob l‘e ct orde r S You can ungroup a group of objects at any time and then regroup

1. Select the object you want to move and then choose Drawing
Tools Format=>Bring Forward in the Arrange group. A menu

of options appears. g
S (Optional) Choose Send Backward to move a selected object behind another one. 2411

2. Choose Bring Forward or Bring to Front. The selected object
moves on top of the other object(s). See Figure 8-21 where, on
the left, you see the original arrangement of the smallest arrow :
hidden by the larger one. On the right, you see that by moving i

[k

the larger arrow backward, the smaller arrow becomes visible. it

16

Figure 8-21

Group Objects
1. Selectt biect ARG T 0=
. Select two or more objects. PENNES & ) (] A | A T 0
A - (=) (%) oo | B A\ A ik
Alternafively, choose Homer>Find and Selecic>Select Objects in the Edifing group. — -
Next, use the mouse to draw an imaginary box around the objects you want fo select. O T T B e ——
Click the Select Objects option again to turn off the feature. 2

2. Choose Drawing Tools Format=>Group=Group in the Arrange
group. The selected objects become one object with a single

®

boundary box around it. With grouped objects, any changes 2
you make affect the entire object. In Figure 8-22, you see =
three separate objects on the left, and on the right, you see 1
the rectangle, circle, and triangle grouped as one. -
Figure 8-22

When you group obiects, you combine them; therefore, any changes you make affect
the entire object. Changes include move, resize, flip, rotate, crop, and any style,
shadow, or color changes. You can also create groups within groups to help you build
complex drawings.



Managing Workbooks

Iwant to begin by clearing up a couple terms. A worksheet, sometimes
called a spreadsheet, is a collection of cells that can have more than 1 mil-
lion rows down and over 16,000 columns across. Each cell of each sheet can
contain over 32,000 characters.

Secondly, a workbook is a collection of worksheets. By default, each time you
create a new Excel workbook, it contains three worksheets. Each workbook,
however, can have an almost unlimited number of worksheets, limited only
by your computer memory. The resulting possible number of cells in a sin-
gle workbook is too huge to even dream about, but the fact remains you
could create a single huge workbook of all your work in Excel. Realistically,
however, you'll probably have a number of different workbooks each with a
number of worksheets.

Excel makes working with multiple worksheets easy. You can maneuver
between the sheets by clicking a sheet tab. Excel even provides navigation
buttons for situations when you have a lot of tabs. This chapter is primarily
about working with multiple sheets. You discover how to insert, delete,
move, and copy worksheets, rename the tabs that reference them, and create
formulas that reference other worksheets or workbooks. Finally, you dis-
cover how to create hyperlinks to jump to Web sites, other cells, or work-
books and how to create an instant e-mail.
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Get ready to. . .
w= |nsert Additional Worksheefs .....................

= Delete Worksheets

w= Rename Worksheets

= Copy Worksheets

w= Move or Copy Worksheets fo a
Different Workbook

w= Hide and Unhide Worksheets.....................
w= Change Worksheet Tab Colors.d..................
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Worksheets
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w= [nsert a Hyperlink
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Chapter 9: Managing Workbooks

Move or Copy Worksheets
to a Different Workbook

1. Open the workbook to which you will move the worksheet
and then open the workbook that contains the worksheets
you want to move.

2. Click anywhere on the worksheet you want to move. If you
don't see the sheet you want, click the tab navigation buttons
until you see it, and click the sheet tab.

If you want to move or copy multiple worksheets, hold down the Cirl key and dlick
additional tabs. If you want to move or copy all the existing worksheets to another
workbook, right-click a sheet tab and choose Select All Sheets.

3. Choose Homer>Format>Move or Copy Sheet. The Move or
Copy dialog box opens.

Alternatively, right-click a selected tab and choose Move or Copy.

4. Click the To Book drop-down list, as shown in Figure 9-5,
and select the workbook to which you want to move or copy
the sheets.

5. 1If you want to duplicate the sheets to the other workbook,
select the Create a Copy check box.

6. In the Before Sheet list box, select where in the order of the
existing worksheets you want the sheet placed.

7. Click OK. Excel moves or copies the worksheets to the other
workbook. In Figure 9-6, the Customer List sheet was moved
from the Customer Table workbook to the Names and
Address workbook.

88

If you chose to copy a sheet to another workbook in which a sheet has
the same name, Excel keeps the same name but adds a sequential
number fo the end.

You can't copy or move a worksheet created in an Excel 2010 or 2007
workbook fo one created in an earlier version of Excel.

Move or Copy Cr=s

Move selected sheets
To baok:
Mames and Addresses. xlsx

Create a copy

Figure 9-5
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Generate References to
Other Worksheets

1. Select the cell into which you want to enter a reference.
2. Perform one of the following actions:

e To display a value located in another cell on the same
worksheet, type the equal sign and then the cell address.
For example, type =B45 and press Enter. If the value in
B45 changes, the cell with the reference to B45 also
changes.

e To display a value located in a cell on a different work-
sheet but in the same workbook, type the equal sign.
Next, click the worksheet tab containing the cell you want
to reference and then click the actual cell you want to ref-
erence. Press Enter. Excel displays the equal sign, the work-
sheet name, an exclamation point, and the cell reference.
(See Figure 9-9.)

e To include a cell located on a different worksheet, but
in the same workbook, in a formula, begin to type the
formula. In the place where you want to position the dis-
tant cell reference, click the worksheet containing the cell
and then click the actual cell. Follow this with the remain-
der of the formula. Figure 9-10 illustrates an example of a
formula using a reference to a different worksheet.

Formulas referencing other worksheets or other workhooks can also be compound for-
mulas or used in a function.
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Cross-Reference Other Workbooks

i =[vearly Sales by Product.x/sx]Green'| 56513

Cross-Reference Other Workbooks -

A
1 WIDGET COLOR January February March

1. Open the workbook to which you will refer. For simplicity | 2 |Green | 193,402.09 |
sake, I call this Workbook2. 3 Blue I

2. Click the desired cell in the workbook where you want to : Yellow

create a reference. Call this Workbook1. -

7
8

Figure 9-11

3. In Workbookl, begin the formula or reference with an equal
sign.

4. If using a function or formula, enter any portion that you
want to precede the cross-reference.

Click the cell that you want to reference from Workbook2.

6. Finish the remainder of the formula or press Enter. Excel dis-
plays the equal sign, an apostrophe, and then the Workbook2
filename in brackets followed by the worksheet name, a clos-
ing apostrophe, an exclamation point, and the absolute cell
reference. For example, ='[Monthly Sales by Product.xlsx]
January’!$E$4 refers to the value in cell E4 of the sheet
January in the Excel file named Monthly Sales by Product.
See Figure 9-11 for an example of a cross-reference.

Excel uses absolute references (with dollar signs) when referring to other workbooks.

Figure 9-12

When you open a workbook containing a cross-reference,
Excel displays a message, such as the one shown in Figure 9-12,
prompting you with a security alert so it can determine
whether to update the cross-referenced cell. Click the Enable
Content button if you want Excel to check the originating
workbook for changes to the referenced cell. You may see
another confirmation message.
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Changing Worksheet
Views | “*Iapter

Someone once wrote about the importance of seeing and being seen.
Although I'm sure that quote referred to people, it also can apply to
your Excel worksheets. You need to see them in many contexts. That's what
this chapter is about — seeing your workbook from different perspectives by
using the following techniques:

Get ready to. . .

"= Viewing alternatives such as zooming in or out, displaying page

breaks, or seeing the worksheet without the Ribbon and other screen »= Zoom In or Qut 96

elements. w= Use the Zoom Controls .........c.ccccccooocrvrreee 96

g Splitting j[he screen to see multiple sections of a worksheet at the same we> Change Worksheet Views...................... 97
time or viewing multiple worksheets together.

w= Freeze Worksheet Titles.................oevevvere 98

w= Freezing portions of a worksheet so you can see category or row
headings. web Split the Excel Screen.........ooooccoocvvvevereee 99

w= Comparing two spreadsheets onscreen. = Arrange Windows 99
w= Creating templates that can bring consistency, such as the company 5

standards or personal preferences, to your workbooks, = Compare Spreadsheefs ........................... 100

w=» Monitoring specific cells for changes. = Save as a Template 100

w= Open a Template 101

Go ahead, take a look!
w= (reate a Workbook from an
Existing File 101

w= Monitor Cells in the Watch Window.......... 102




Chapter 10: Changing Worksheet Views

3. Click and drag the Zoom slider bar to the right.
Zoom In o¥ out Excel increases magnification.
1. Choose Views>Zoom in the Zoom group. The Zoom dialog 4. Click and drag the Zoom slider bar to the left. Excel
box appears. decreases magnification.

(Optional) Click the magnification box next to the Zoom controls. The magnification
box and the Zoom controls are located on the status bar. Zoom 7=

Magnification
) 200%
) 100%
) 75%
) 5%

2. Select a magnification percentage from the Zoom dialog box,
as shown in Figure 10-1. A higher zoom setting makes the
text appear larger, so you see less on the screen; a lower set-
ting shows more onscreen, but the data appears smaller.
Zooming doesn't affect the printed data size. Click OK.

Select the Custom opfion and enter your own setting from 10% fo 400%.

Figure 10-1
Marion MY 39937
(Optional) To zoom in on a particular worksheet areq, select the area and choose ng ';JI g;égg
Viewc>Zoom to Selection. Maysville Y% 88968
MNew Paris MY 85998

Paducah NY 87396
0 lhcfﬁc\d

illacs

Use the Zoom Controls

1. Click the Zoom In button on the Zoom control on the right
side of the status bar. Excel increases the magnification per-
centage by 10 percent for each click of the Zoom In button.
(See Figure 10-2.)

Figure 10-2

The Zoom percentage displays on the status bar.

2. Click the Zoom Out button on the Zoom control. Excel
decreases the magnification percentage by 10 percent for each
click of the Zoom Out button.

96



Change Worksheet Views

Change Worksheet Uiews

1.

Choose Viewr>Page Layout in the Worksheet Views group. As
shown in Figure 10-3, the Page Layout view displays your
worksheets on individual pages that correspond to printed
pages. A ruler appears on the top and on the left side of the
worksheet. (See Chapter 13 for more on headers and footers.)

Use the Zoom controls to increase or decrease magnification.

Choose Viewr>Normal in the Worksheet Views group. Excel
returns to the default Normal view, which shows one contin-
uous page of columns and rows.

Choose Viewr>Page Break Preview in the Worksheet Views
group. A Welcome to Page Break Preview dialog box appears.

If you don’t want to see this dialog box when you enter Page Break Preview, click Do
Not Show This Dialog again.

Click OK. The Excel view changes to Page Break Preview,
where Excel indicates page breaks with dotted lines. (See
Figure 10-4.) You can click and drag these lines to modify
where the pages break. (See Chapter 13 for more on using
page breaks.)

Choose View>Full Screen in the Worksheet Views group. You
see only the worksheet itself with its row and column head-
ings, worksheet tabs, and the title bar. The Ribbon, Quick
Access toolbar, and the status bar are hidden.

Press the Esc key. Excel returns to Normal view.

On the status bar, next to the Zoom controls, you find three icons you can use to
quickly switch among the Normal, Page Layout, and Page Break Preview views.
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Chapter 10: Changing Worksheet Views

Freeze Worksheet Titles B o LRI

1. Choose what you want to freeze:

GL SALES GL INVENTORY |GL COGS

e Columns: Select the column to the right of the columns
you want to freeze. For example, click cell B1 to freeze
only column A.

e Rows: Select the row below the rows you want to freeze.
For example, click cell A4 to freeze rows 1, 2, and 3.

e Columns and rows: Click the cell below the rows and to
the right of the columns you want to freeze. For example,
click cell B2 to freeze both column A and row 1, as shown
in Figure 10-5.

Freezing panes affects only the current worksheet. If you want fo freeze other work-
sheets, you must select them individually and freeze them.

i F
AT I
ny AN il aaes =

Figure 10-5

2. Choose Viewr>Freeze Panest>Freeze Panes in the Window
group. A thin black line appears to separate the sections. As
shown in Figure 10-6, as you scroll down and to the right, i o) By | Tom 0% o
row 1 and column A remain visible even though you see 5 m

H ] [
|BL INVENTORY GL COGS
40200 1;
iz

rows 77-95 in the bottom section and columns D-I on the
right.

Normally when you press Cirl+Home, Excel takes you fo cell A1. However, when
Freeze Panes is active, pressing Ctrl+Home takes you to the cell just below and to the
right of the column headings. However, you can still use your arrow keys or click your
mouse to access any cell.

3. Choose Viewr>Freeze Panese>Unfreeze Panes to remove the
freeze setting from row and column headings.

ones

Figure 10-6



Arrange Windows

Split the Excel Screen

1.

4.

Click anywhere in a row and column where you want to split
your screen. This is usually somewhere around the middle of
the screen.

Choose Viewe>Split in the Window group. Excel splits the

window into two or four panes each separated from other
panes by bars. Each pane has its own set of scroll bars (see
Figure 10-7).

Drag the horizontal split bar up or down or the vertical split
bar left or right to resize the window sections.

(Optional) Double-click any part of the bars that divide the panes to remove that par-
ticular split.

Choose View=>Split again to remove the split.

Arrange Windows

1.

With two or more workbooks open, choose Viewr>Arrange
All in the Window group. The Arrange Windows dialog box,
as shown in Figure 10-8, appears.

Make a selection:

e Tiled arranges the open workbook windows so they don't
overlap each other.

e Horizontal places the open workbook windows horizon-
tally on top of each other.

e Vertical lays the open workbook windows side by side.

e Cascade arranges the windows so that they overlap each
other, keeping the title bar visible.

Click OK.

e
mady

Figure 10-7

Figure 10-8
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Compare Spreadsheets

1.
2.

Open two workbooks.

Choose Viewm>View Side by Side in the Window group. The
two workbooks are split horizontally on the screen, as shown
in Figure 10-9.

If you have more than two workhooks open, you see a dialog box enabling you to
choose which workbook you want to compare.

Scroll down or across a worksheet. Notice the other work-
sheet scrolls simultaneously.

Choose Viewr>Synchronous Scrolling in the Window group
to turn off the option to scroll the worksheets independently.

Choose Viewr>Reset Window Position in the Window group,
to reset the workbook windows to the positions they were in
when you first started comparing workbooks.

Choose Viewr>View Side by Side in the Window group to
return the windows to Normal view.

Save as a Template

1.

Create an Excel workbook. Templates can store formatting,
worksheet layouts, data, formulas, and much more.

Click File and choose Save As. The Save As dialog box
appears.

Type a name for the template in the File Name text box.

Choose Excel Template from the Save as Type drop-down list.
Excel automatically saves the template in the default template
location (see Figure 10-10).

Click the Save button and close the workbook.
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Figure 10-9
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Figure 10-10



Create a Workbook from an Existing File

Open a Template

1. Click File and choose New. The Available Templates Backstage
View appears.

s The Ctrl+N shortcut doesn’t work here. That shortcut automatically creates a new stan-

dard, blank workbook, not one from a specially saved template.

plates, most of which are free.

s Click any category in the Office.com Templates area to view a great collection of tem-

2. Click My Templates. The New dialog box displaying your cus-
tomized templates appears. See Figure 10-11.

3. Select the template you want to use and then click OK.

Create a Workbook from an Existing File
1. Click File and choose New. The Available Templates
Backstage view appears.

2. Click the New from Existing button. The New from Existing
Workbook dialog box, as shown in Figure 10-12, appears.

Locate and click the workbook you want to open.

Click the Create New button. Excel opens a copy of the work-
book. The filename in the title bar shows the same name as
the original with a number after it.

prompfing you for a filename.

s When you choose to save the workbook, the Save As dialog box automatically opens,

Figure 10-11

Figure 10-12
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Chapter 10: Changing Worksheet Views

Monitor Cells in the Watch Window e

Baok. Sheet Narne Cell l Earmul

¥
Add Watch [ o=l
Select the cells that you would like to watch the value of:

= =

1. Choose FormulassoWatch Window in the Formula Auditing
group. The Watch Window opens.

Use a Watch Window to keep track of data in a particular cell or range of cells even
when the cells are no longer in view. Figure 10-13

2. Click Add Watch. The Add Watch dialog box, as shown in
Figure 10-13, appears.

3. Select the cell(s) you want to watch or manually type the cell
reference address.

4. Click the Add button. Excel adds the cells to the Watch
Window, including any values or formulas within the cells. If
you scroll away from the original cells, the Watch Window
always displays the cell contents. (See Figure 10-14.)

Figure 10-14

5. Repeat Steps 2-4 to add another watch area to the Watch
Window. You can add watches with cells on the same work-
sheet, a different worksheet, or a different open workbook.

To return to the original cell, double-click the cell name or address in the Watch
Window.

6. As necessary, perform the following actions:

e To remove a cell from the Watch Window, click the cell
name and then click the Delete Watch button. Excel imme-
diately removes the cell from the window.

e To move the Watch Window, click and drag the window’s
title bar anywhere onscreen.

e To resize the columns within the Watch Window, posi-
tion the mouse pointer between columns in the Watch
Window and drag to resize the left column.

o 7. When finished, click the Watch Window's Close (X) button.



Sorting Data

Sometimes worksheets become quite large, making locating particular
pieces of information time-consuming and difficult. If your data is in an
array, you may find the data easier to view if it’s sorted in a particular manner.

Perhaps you have multiple worksheets and want to locate every occurrence
of a specific value. Or, maybe you're just a neat freak and want everything to
be in a particular order. Excel contains features to help you arrange your
worksheets in an easy-to-manage sequence.

In this chapter, you discover how to

m= Sort your data in ascending or descending order with either the
Ribbon or the Sort dialog box.

w= Perform a secondary sort if the primary sort has multiple matches.
w= Sort data containing days of the week or month names.
w= Create a customized list of frequently used names or terms.

w= Locate cells containing data you specify, whether the data is part of a
formula or a resulting cell value.

w= Quickly replace data containing certain information with another
specified set of data.

»= Locate all cells with a particular style of formatting and easily replace
them with a different format.

I“*napter

Get ready to. . .

w= Use the Ribbon to Sort................coevvveeee 104
= Work with the Sort Command.................. 105
w= Sort by Multiple Criteria ..............coooee... 106
w= (reate a Customized List.......................... 107
w=Sort by Day, Month, or Custom List.......... 108
w= Remove Duplicate Records................o..... 108
w= Sort by Cell Format 109
w= Search for Data 110
w= Find All Data Occurrences........................ 111
w= Locate Cells Based on Forma .................. 1M

= Use the Replace Command ...................... 112






Work with the Sort Command

Work with the Sort Command T

‘-’gjﬂdd Lewel ][ )( Delete Level H 153 Copy Level ” ~ [ opkions... ] My data has headers
. . . Column Sort On Ordet
1. Select or click in the list of data you want to sort. e [T ] [vaes ] ez 5
Select only a single column of data if you want to sort that column independently of
the rest of the data.
2. Choose Data=>Sort in the Sort & Filter group. The Sort dialog
box opens. (See Figure 11-3. .
x opens. (See Fig ) Figure 11-3
3. If your data includes column headings, make sure the My
Data Has Headers check box is selected. If the data doesn't — Em)
include column headings, deselect this check box. Sy assion) (et [Easemrian | [~ [~ | [emien) e P
Column Sort On Order
Excel doesn’t indude header rows in the sort process. Sortby [Last Hame (=] [raues [z] ez =
Lot o
Zompany
Address
ik
;it:te
4. From the Sort By drop-down list, choose the column by
which you want to sort. (See Figure 11-4.)
If you don't have header rows, Excel displays Column A, Column B, and so forth. Figure 11-4

5. From the Sort On drop-down list, choose Values. (I discuss
the other options later in this chapter.)

6. From the Order drop-down list, choose how you want to sort
the data:

e Choose A to Z or Z to A to sort text values.

e Choose Smallest to Largest or Largest to Smallest to sort
numeric data.

e Choose Oldest to Newest or Newest to Oldest to sort by dates.

7. Click OK. Excel sorts data in the following order: numbers,
spaces, special characters, and finally, alphabetic characters.
Blanks are always placed last. 105
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Chapter 11: Sorting Data

Sort by Multiple Criteria

1. Select or click in the list of data you want to sort; then choose
Datar>Sort in the Sort & Filter group. The Sort dialog box opens.

2. If your data includes column headings, make sure the My
Data Has Headers check box is selected. If the data doesn't
include column headings, deselect this check box.

Although the most common sort is by rows (top to hottom), you can also sort by col-
umns (left to right). In the Sort dialog box, click the Options button and then in the
Orienfation section, choose Sort left to right. Finally, dlick OK.

3. Set up the primary sort criteria, as described in the preceding
section.

Excel sorts dates formatted with slashes, such as 11/22/68, as numeric data. Dates
with the day or month spelled must be sorted differently. See the section, “Sort by
Day, Month, or Custom List,” later in this chapter.

4. Click the Add Level button.

In the Then By section, select the secondary column you want
to sort by if two or more items are identical in the first Sort
By option.

6. Select how you want to sort the second data criteria. Repeat
as needed. See Figure 11-5.

To delete an entry, select the sort entry and choose Delete Level. You must keep at
least one sort entry in the list.

7. Click OK. Excel performs the sort. Figure 11-6 illustrates
data rows sorted first by State and then by City and then by
Company.

During an Excel sort, apostrophes (') and hyphens (~) are ignored, unless two text
strings are the same except for a hyphen. In that situation, the text with the apostro-
phe is sorted first in ascending order.

Sort FEs
“’;1 Add Level ] [ X Delete Level ] [ 53 Copy Level ]| B [ Options, .. ] Iy data has headers
Column Sorkon Order
Sortby [ state [=] |values [=] |atez (=]
Thenby | giby [=] |values [=] |atoz =]
Then by | Eampany [=] |vahues [=] |atoz =]
Figure 11-5
A B c D E F
1 |First Name Last Name [Company laddress City State  Zip
2 Sam Srnith Adeo Of Qhio 510 Wayne Ave Lino Lakes A 46!
3 Mark Boylens  Shorr Papar Products Inc. P.0.Box 6800 Valdosta DE 60.
4 Jim Kowis  Mayar Matarial Handling Prod P.0. Box 47366 Sarasota FL 28
5 Beverly  Wilson Stoffal Sals Corporation 1 Stoffel Drive Atanta a7
6 Ron Abboud  Abboud Chamicals 1000 W. Oak Street Atlanta GA 30
7 Robert Adams Dairy Charms, LLC 10139 W. Co. Rd. 750 South Atlanta GA 30
8 Louie Adamo Louia's Auto Rapair 1010 S. State Road 135 Atlanta GA 30
9 lodi Peaches  Thee Peachtree Lady 1015 NW 68th Street Atlanta GA 30
10 Brenda Beeman  Sleavaco Inc. 103 Lumpkin Campground Rd North  Duluth GA 30
11 |Jack Landon  Thrashar Madical Supply 1031 Harrison Street Duluth GA 30
12 |Lynn Foltz Apsilon Plastics Inc 3100 E Harcourt Street Indianapolis GA 90
13 |Greg Peters  CDOI 240 Boundary Road Indianapolis GA 16:
14 |Jim Mercier  Midpack/Division Of Midwast Canvas 4635 West Lake Street Lafayette GA 46!
15 Tom Daley Stata Farm Insuranca 7230 N, Shadeland Ave Newport GA 46
16 Stanley  Chen Alliad Box Co, 8092 Woodland Drive Nor cross GA 46
17 |Mike Davis Bloomfiald Nationwide Inc 8402 N Magnolia fve Nor cross GA 92
18 |Ben Friedman Wayarhaausar Inc 7591 Collections Center Drive Norcross GA 601
19 |Rick Pistons  SunPackaging P.0.Box 1937 Smyrna GA 46:
20 |Joe Powers  Flax-Pacinc P.0.Box 660212 Tacoma GA 46
21 |Jeff Speed  H.J. Spiar CoInc 5750 Castle Creek Pkwy. Modesto I 46;
22 |Greg Meyer  Bunzl Oil 5772 Collections Center Drive Muncie I 77
23 [Jim Miller  Southwastarn Packaging Corp, 6960 Ardmore New City I 46;
L Camcbibeaa il el DL m 4

Figure 11-6




Create a Customized List

Create a Customized List

1. Choose File>Options. The Excel Options dialog box appears.

2. Click the Advanced section and scroll down to the General
category. (See Figure 11-7.)

3. Click the Edit Custom Lists button. The Custom Lists dialog
box opens. Excel provides two ways to create a custom list:

A custom list can contain fext or text mixed with numbers. Use custom lists fo speed
up data entry for commonly used terms, such as sales people, regions, or products.

e To create a list from items you've entered already into
the worksheet, click the Collapse button next to the
Import button. The Custom Lists dialog box collapses.
Highlight the worksheet cells containing your list and then
press Enter. The Custom Lists dialog box reappears. Click
the Import button. The data you selected appears in both
the List Entries box and the Custom Lists box.

e To type your own list without entering it into the work-
sheet first, click New List from the Custom Lists section.
Type your list in the List Entries text box, as shown in
Figure 11-8, and then click the Add button.

4. Click OK twice.

You can now use the AutoFill feature with the custom list by typing one st entry and
using AutoFill to enter the other list entries. (See Chapter 2.)

To edit a custom list, from the Custom Lists dialog box, select the list that you want to
edit. Make any changes in the List Entries box and then dlick the Add button. To delete
a customized list, select the list and then dick the Delete button. You can't edit or
delete the Excel-provided fill series, such as months and days.

Excel Options

=

General
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Save

Language

p— |
Customize Ribbon
Quick 4ccess Toalbar
Add-Ins

Trust Center

Cluster type:

When cacuating i workbook: ] vaves a0 A00R [ ]

Update links to other documents
[T set precision as displayed

] Use 1904 date system

Save external link values

General

[F] Provide feedback with sound

Provide feedback with animation

[F] 1anore ather applications that use Dynamic Data Exchange [DDE)
A3k to update sutomatic links

[T Show add-in user interface errors

Scale content for A4 or 8.5 x 11" paper sizes

Show customer submitted Office.com content

A& startup, open all files in:

Enable multi-threaded processing

Disable undo for Iage PiuotTable refresh operations to reduce refresh time when the PivotTable S0
data source has more than this nLUMbE iR RO,

% | it Custom Lists., | & M

Create lists for use in s0rts and fill sequencel
Lotus compatibility

Micrasoft Excel menu key: |/

I

[T Transition navigation keys

Lotus compatibility Settings for: [ City [=]
[ Transition formula ewaluation L
Figure 11-7
Custom Lists 7 ==
Custom Lists
Custom lists: List enkries:
NEWW LIST - | |reD E
Sun, Mon, Tus, Wed, Thu, Fri, S ORANGE
Sunday, Monday, Tuesday, Wec YELLOW
Jan, Feb, Mar, Apr, May, Jun, 2 =REEN =
A BLUE
INDIGO
WIOLET

Import list From cells:

Figure 11-8
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Chapter 11: Sorting Data

Sort by Day, Month, or Custom List

Select or click in the list of data you want to sort.

Choose Data=>Sort in the Sort & Filter group. The Sort dialog
box opens.

If your data includes column headings, make sure the My
Data Has Headers check box is selected. If the data doesn't
include column headings, deselect this check box.

Select your first sort criteria field.

By default, Excel soris days and months alphabetically, not by date.

From the Order drop-down list, choose Custom List. The
Custom Lists dialog box appears.

Select the custom list (see Figure 11-9) you want to sort by
and then click OK. The Sort dialog box reappears.

Set up any secondary or additional sort criteria; then click OK
to perform the sort.

Remove Duplicate Records

Select or click in the list of data you want to work with.

Choose Data=>Remove Duplicates in the Data Tools group.
The Remove Duplicates dialog box appears. (See Figure 11-10.)

Select or deselect the columns you want Excel to examine;
then click OK. Excel looks for and removes duplicates. A mes-
sage tells you how many duplicates were removed (if any)
and how many unique values remain.

Click OK.

D E [ F T & H |
1 Address City State Zip Status __Last Order Month
1 Stoffel Drive Atanta GA 71930  Green  January
1000 W. Oak Street tlant: nna0 Al March

10139 W. Co. Rd. 750| Sert
1010 5. State Road 13

options.

1015 NW 68th Street
528 Moore Drive
285 Bumblebee Ct
103 Lumpkin Campgr
1031 Harrison Street
3100 E Harcourt Stre
240 Boundary Road
2929 BIuff Road
2835 Pellissier Place
11 West Carlisle Stree
10830 Andre Drive
247 S Indiana

1044 Harrison Street
1205 N, St. Road 75
1111 East 54th Street
2000 Mote Drive
4307 West Division

Llslelemlelelele =2 e [e e
>“‘"'\"“‘°‘“"“"“‘@‘U““‘“"“"“‘O'm‘w‘“‘m‘w‘b‘w"\"

Column

Sort on

Sortby [Last order orth[=] |vaes

Custom Lists

Custom Lists

cust

tom
NEW LIsT B
5un, Mon, Tue, Wed, Th, Fr, 5
Sunda: e
Jan, F: n, 30

RED, CRANGE, VELLOW, GREEN

Press Enter to separ ate lst entris.

ber

er

5= Unselect Al

Ta delats duplicate values, select one or more columns that contain duplicates.

My data has headers

1200 Independence Dr =
e R
Figure 11-9
Remove Duplicates =

Columns

[ Firsk Name
[T Last Name
Company
[T address
[ City

7] state

Figure 11-10




Sort by Cell Format

Sort by Cell Format o
‘-’gjﬂdd Lewel ][ )( Delete Level H 53 Copy Level ” . [ opkions... ] My data has headers
1. Select or click in the list of data you want to sort. L ] eeicar B —
Sorting by cell format is helpful when you have specified conditional formatting
conditions; it can sort all items meeting your conditions to the top or bottom of the
data fable.
2. Choose Data=>Sort in the Sort & Filter group. The Sort dialog
box opens. .
P Figure 11-11
3. If your data includes column headings, make sure the My
Data Has Headers check box is selected. If the data doesn’t E F 5 H
include column headings, deselect this check box. City State  Zip Status _|Last O
MMaodesta IL 46278 Indigo Januar
4. Select your first sort criteria field and then in the Sort On Muncie I 77054 \iolet  March
drop-down list, select one of the following: New ity L 46241 Red  Nove
Palatine IL 46206 COrange  March
e Cell Color: Choosing this option sorts the cells based on Pembroke I 46266 Yellow  May
the cell backeround formattin Flainfield IL 60693 Green Septe
8 & South Canaan IL 19804 Blue Mave
e Font Color: Choosing this option sorts the cells based on T:!;’::;EZT‘S P AL
the font color of the cell contents regardless of background Lorao oH 2283 Red iy
forrnattlng. Meenah OH 46278 Orange  Septe
. . . . . Santee OH 46226 Yellow  March
5. Click the Order drop-down list. Several options, including Whitestown OH 46140  Green  March
Automatic and each color you used in your selected field, Lebanon TN 22660 wiolet  Move
appear. MNashwville ™ 46075 Red lay
ashwille T 46237 Crange  July
6. Select the cell color or font color you want to sort by. See Lino Lakes €A 46250 Red  Januar
Figure 11-11 Valdosta DE 60598 Orange  Septe
: Sarasota FL 28329 Yellow hlay
7. Choose whether you want the formatted cells to appear at the Atanta GA  [/1930 |Green |Januar
top of the data range or at the bottom of the data range. Alants GA |50080 [Blue  |March
Figure 11-12

8. Add any additional sort criteria and then click OK. In
Figure 11-12, the data is sorted with the formatted cells
at the top.
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Chapter 11: Sorting Data

Search for Data

1. Choose Homer>Find & Select=>Find in the Editing group. The

entry you want.

Find and Replace dialog box appears.

Find and Replace

Find Replace

B8 =

Alternatively, press Ctrl+F to open the Find and Replace dialog box.

Within | Shest E [C] Match gase

Match entire cell contents
Search: | By Rows E al <

Find what! Indianapalis| IZ‘ Mo Format Set

5. Click the Close button when you've located the

2. In the Find What box, enter the value or word you want to Lockins [rormas 3]
locate.
I Find &l I [ Eind Mesk ] I Close I
3. Click the Options button and specify any desired options, as
shown in Figure 11-13: Figure 11-13
e Within: Search just the current worksheet or the entire g 5 G FT e T
ompany ddress i ate i atus ast
workbook. ; be;ud‘éham\ca\s :ooow Oak Street :;:nta :S‘A‘ égogo ;u‘e Ir:/\a‘rci
3 Adco Find and Replace = Lino Lakes CA 46250 Red Januarn
e Search: Select whether to search first across the rows or S o o el
[V e — ] [rome | (Cramed dnapals ] olet Nove
down the columns. o T T -
8 ANhEr | e, [sher 7] D Mtch s walparaiso MA 60616  Indigo  Move
e Look In: Select whether you want to search through the 15 i | e e bty 58 ooz e by
values or formula results, through the actual formulas, or L e Mareta UG v e
1 1 13 |Bloom Norcross GA 92071  Orange Nover
lf you Want to look ln the Comments' 14 Bozall Industrial Products 247 S Indiana Indianapelis IN 46031 Greergv July
15 Bunzl Qil 5772 Collections Center Drive Muncie L 77054 Violet March
. . . 16 Carnival Nails 1044 Harrison Street Indianapolis N 30312 Blue Septel
Choose Formulas in the Look In drop-down list when you're looking for a formula that e 240 Boundary osd ndarepls GA 45240 e Sepie
ofe 18 | Covalanca Adhasives P.0.Box 10450 Shelbyville IN 60055  Red July
references a SpE(IfI( (e" ClddreSS. 19 Crowall Corporation P.0.Box 3227 South Canaan It 19804  Blue  MNove
20 Custorn Cara Lawnscaping Inc. P.0.Box 63 St Louis MO 60644 Orange  March
21 D& SEntarprisas Inc 528 Moore Drive Boston MA 46032 Green Mover
22 Dairy Charms, LLC 10139 W. Co. Rd. 750 South Atlanta GA 30093 Indigo May
23 Daisy Chains to Go 1205 M. St. Road 75 Indianapolis IN 30093 Indigo MNover

e Match Case: Select this check box if you want your search
to be case-specific (for example, BOBCAT instead of
BobCat or Bobcat).

e Match Entire Cell Contents: Select this check box if you
want your search results to list only the items that exactly
match your search criteria.

Figure 11-14

4. Click the Find Next button. Excel jumps to the first occur-
rence of the match (see Figure 11-14). If this isnt the entry
you're looking for, click the Find Next button again. Excel
advises you if it doesn’t locate the data you are searching for.
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Locate Cells Based on Format

Find All Data Occurrences

1.

Choose HomeFind & Select=>Find in the Editing group. The
Find and Replace dialog box appears.

In the Find What box, enter the value or word you want to
locate.

Click the Options button and specify any desired options, as
I discuss in the preceding section.

Click the Find All button. The Find and Replace dialog box
expands showing a list of each cell entry that contains your
data (see Figure 11-15).

Click any entry. The specified cell is selected. When finished,
click the Close button.

Locate Cells Based on Format

1.

2.

Choose HomeFind & Select=>Find in the Editing group. The
Find and Replace dialog box appears.

Click the Format button. The Find Format dialog box appears.

cell and then confinue with the Find and Replace options.

To select formatting from an existing cell, from the Find and Replace dialog box, click
the arrow on the Format button and choose Choose Format from Cell. Click the desired

From the various tabs, select the formatting options you're
searching for. See Figure 11-16.

Click OK. The Find Format dialog box closes, and the Find
and Replace dialog box displays a sample of the format you
selected.

Click the Find Next button or the Find All button. Excel finds
the formatting occurrence.

Click the Close button to close the Find and Replace
dialog box.

To remove formatting search options, from the Find and Replace box,
click the arrow on the Format button and choose Clear Find Format.

Figure 11-15
Find Format
| umber [ lignment | Font [ Border | Fil [ protection
Background Calar: Pattern Color:
OomO .. EEEE Pattern Style:
ORODSO000000 E
ONEEEEONEO
ENENENONEEE
FEEEEEEEEN
EENEEEEEEEN
EEfFEEEEN
Sample
Figure 11-16
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Chapter 12: Creating Charts

Add Sparklines

1. Select the cell where you want the Sparkline. Typically, this is
next to the data.

2. Choose Insert and in the Sparklines group, choose a
Sparkline type: Line, Column, or Win/Loss. The Create
Sparklines dialog box appears.

3. In the Data Range box, enter (or drag across the cells with
your mouse) the cells containing the data you want to plot.
(See Figure 12-1.) Figure 12-1

4. Change, if necessary, in the Location Range box, the cell in
which you want the Sparkline.

h . Selint Cothes
5. Click OK. Excel creates a Sparkline chart in the selected cell. AN e

To delete a Sparkline, click the Sparkline cell and choose Sparkline Tools e T —— = —
Designl:bcleur in Ihe Group group' 1 Product January  February March April May lune .

2 |Green fe1a ah2i 678 Ah7s et 000§ —

3 |Blue 6311 1068 10397 7446 5869 8253] A

4 Yellow 8179 9160 #0227 L37E ans 9537 =
To save time when creating multiple Sparklines in a data array, such as in the Figure 6
12-1 example, use the AutoFill handle to copy the Sparkline settings. This creates a !
Sparkline group and changes you make to one Sparkline affect all the Sparklines in Figure 12-2

the group.

Add Sparkline Markers

1. Select the Sparkline cells on which you want to add markers.

2. Choose Sparkline Tools Design and in the Show/Hide group,
select the markers you want displayed. In Figure 12-2, the
High Point check box is selected so you see only high point
markers.

To change the Sparkline type, with the Sparkline cells selected, choose Sparkline Tools
Design and then choose a different type in the Type group.
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Edit Sparkline Data

Change Sparkline Styles - eI W
o i st B mume IASIAS A AW AW A TE s
1. Select the Sparkline cells on which you want to change the e VARV AN AR AR AV
Style. 1 Prnr:u:l Fanu l: 1y n-u.fmw Mu.::. Apri Y . R4 A J . s
If the Sparklines are in a group, and you only want o change one of the Sparklines, g | o ;‘E‘;‘: = ) il
choose Sparkline Tools Design=>Ungroup. 5 VAN VANV AN VANV AV
; W/ & i "\J’“ \{'\/‘
9
2. Choose Sparkline Topls Design and in the Style group, click Figure 12-3
the More button, which is located directly under the Style
scroll buttons. A gallery of Sparkline styles appear, as shown
in Figure 12-3. = e
3. Select the Sparkline style you want. All selected Sparklines
change to the selected style. P

Edit Sparkline Data

1. Select the Sparkline cells on which you want to change the
data.

Figure 12-4

2. Choose Sparkline Tools Design=>Edit Data in the Sparkline
group. A menu appears.

3. Choose Edit Group Location & Data if you're working with a
group of Sparklines. The Edit Sparklines dialog box appears,
as shown in Figure 12-4.

If you want to change only one of the Sparkline data locations choose Edit Single
Sparklines Data.

4. In the Data Range box, if necessary, enter the new data area
you want to include in the Sparklines.

5. 1In the Location Range box, if necessary, enter or select a new
Sparkline location.

6. Click OK.
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Chapter 12: Creating Charts

Create a Basic Chart

1.

116

Select the data (sequential or non-sequential) you want to
plot in the chart. See Figure 12-5 for an example of sequen-
tial data selected for a chart.

Press the F11 key. Excel immediately adds a new sheet —
Chartl — to your workbook with the data plotted into a
column chart. Each subsequent chart page is numbered
sequentially, such as Chart2, Chart3, and so forth. Figure
12-6 shows you the various elements that can make up a
chart:

Some newer keyboards use a different function for the F11 key. If your F11 key
doesn't produce a chart, use the Insert tab, as | explain in the following section.

Throughout this chapter, you discover how fo edit the look and style of a chart.

e Chart title: A descriptive name for the overall chart. By
default, titles aren’t added in a basic chart, but you can
add them later manually or by using a chart layout.

e Category (x) axis: Column or row headings from your

selected data, which Excel uses for category axis names. In

a column chart, the categories display along the bottom.

In other charts (such as a bar chart), the category axis dis-

plays along the left side.

e Category axis title: A descriptive name for the category
axis. By default, a category label isn't added in a basic

chart, but you can add one later manually or with a chart

layout.

e Data labels: Usually, numbers that identify the actual data
values, but they can also be category names or other asso-

ciated information.

A

B

C

D

E

1 January  February March TOTALS
2 |Mary 256 269 298 823
3 |Stephen 236 289 176 701
4 |John 2498 167 170 585
5 |Bob 255 153 245 653
6 |Susan 119 149 206 474
7 TOTALS 1,114 1,027 1,095 3,236
8

9

10

11

Figure 12-5

Figure 12-6




Create a Basic Chart

Value (y) axis: A scale representing the zero or the lowest
and highest numbers in the plotted data. The value axis is
usually located on the left side on a column chart or on

the bottom on a bar chart. 206

Legend

Value axis title: A descriptive name for the values. By
default, a value label isn't added in a basic chart, but you o January
can add one later manually or by using a chart layout. February

March
Legend: The box, usually located on the right, identifies e

the patterns or colors that are assigned to the chart data
series. In Figure 12-7, the legend shows the colors used to
represent January, February, and March.

. . . Figure 12-7
Tick marks: The small extensions of lines that appear out- g
side the gray area and represent divisions of the value or —= g B FI e F [
CategOI'y axis. ; Januaq256 Fehruazq69 March 51 =
o . . 3 236 289 176 || **°
Gridlines: These lines extend from the tick marks across 2 8 167 e
the chart area to allow you to easily view and evaluate s us M9 206 s
data. 2 %
. 10 -
Series: Excel uses the worksheet cell values to generate the u e em
series. Each element, or data point or data marker, repre- Figure 12-8

sents a single worksheet cell value. Related data markers
make up a data series and have the same pattern or color.
In Figure 12-8, you can see the comparison of the data val-
ues to the y axis and the series values.

Plot area: The background that represents the entire plot-
ted chart area.

To delete a chart sheet, right-click the Chart tab at the bottom of the window, and
choose Delete. When Excel asks for confirmation, dick Delete again.
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Insert a Chart

118

Select the data you want to plot in the chart.

Typically, if you're selecting values, such as monthly figures, you don’t want to include
totals in your chart.

Choose Insert and in the Charts group, click the arrow near
the chart style you want. Excel can create many different chart
types; each compares data in a different manner. (See Figure
12-9.) Some of the most commonly used chart types include
the following:

Click a chart type fo see a sample and an explanation of the chart.

Column: Column charts compare values to categories
using a series of vertical columns to illustrate the series.

Bar: Bar charts, like column charts, compare values to cate-
gories, but use a series of horizontal bars to illustrate the
series.

Line: Line charts are similar to bar charts but use dots to
represent the data points and lines to connect the data
points.

Pie: This chart compares parts to a whole. Usually a pie
chart has only one data series. Figure 12-10 illustrates data
appropriate for a pie chart.

Area: Area charts display the trend of each value, usually
over a specified period of time.

X-Y scatter: These charts include two value axes, one
showing a set of numerical data along the x axis and
the other showing numerical data along the y axis.

My Line ~ |l Area -

nﬂ @B Fie ~ |£Scatterv
Column o

- = Bar ~ lI‘.)OtherChartsv

Charts

Figure 12-9

Figure 12-10




Insert a Chart

e Surface: Shows trends in values in a continuous curve.

« Doughnut: Displays data similarly to a pie chart; it com-
pares parts to a whole, but contains multiple series.

e Stock: Stock charts are usually (but not exclusively) used
to illustrate the fluctuation of stock prices. In a stock chart,
the data order is very important and usually the row head-
ings are High, Low, and Close; or Open, High, Low, and
Close. See Figure 12-11 for an example of a stock chart
and related data.

< Radar: Displays changes in values relative to a center point
by comparing the cumulative values of multiple data
series.

e Bubble: These charts are similar to scatter charts, but com-
pare three sets of values by displaying a series of circles.

e Cylinder, cone, and pyramid: Excel uses these three
chart types to create a column or bar chart using three-
dimensional cylindrical, conical, or pyramid shapes.

Choose a chart subtype. Depending on the chart type, some
chart subtypes show the data series next to each other; others
show the data elements stacked on top of each other. Some
charts are two-dimensional, and others are three-dimensional.
As shown in Figure 12-12, Excel creates the chart on the
worksheet where your data resides.

You'll soon discover how you can change the chart location to its own sheet. But just in
case you don't like your changes, make sure to save your worksheet, which also saves
your chart, before modifying chart attributes.

The chart is a graphic object. You can resize or delete it as you would any graphic
object.

A B
1 High
2 January
3 February
4 |March

5 April

6

7

8

Low
98.4
106.0
1104
113.5

D E F G H | J
Close

]

97.8 1200
101.0 ‘

109.5 100.0
97.0 ‘
80.0

60.0

40.0

20.0

January February March April

High

Close

1 January  February March TOTALS

Mary 256 269 298 B23
Stephen 236 289 176 701
4 John 248 167 170 585
¢ Bob 255 153 245 653
¢ Susan 119
7 TOTALS 1,114 o
1
16 |
18 ! I i
13 50 100 150 w09 250 1 !
20
Figure 12-12
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Change the Chart Type

1. Click the chart to select it whether it appears on its own sheet
or on a data worksheet. A Chart Tools tab with three subtabs
appears.

S Selection handles appear around the chart.

2. Choose Chart Tools Design=>Change Chart Type in the Type
group. The Change Chart Type dialog box appears.

3. Select the different chart type and subtype you want. (See
Figure 12-13.)

4. Click OK. Excel modifies the existing chart.

Adjust the Chart Location

1. Click anywhere on the chart that you want to move.

S If you don't select the chart first, you won't get the Chart Tools tab.

2. On the Chart Tools Design tab, in the Location group, click
the Move Chart button. The Move Chart dialog box appears.
(See Figure 12-14.)

3. Select a location:

¢ New Sheet: Creates a new worksheet and places the chart
on the sheet.

e Object In: Moves the chart to an existing sheet in the
workbook. Click the drop-down arrow to select the work-
sheet to which you want to move the chart.

4. Click OK. Your chart is moved to the location you've specified.

To move the chart to a different location on the current worksheet,
position the mouse over the edge of the chart and drag it fo a new

ocation.

Figure 12-13

Figure 12-14
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Customize the Chart Legend

1. Click anywhere on the chart you want to modify and then
choose Chart Tools Layout=>Legend in the Labels group.

2. From the drop-down list that appears, choose a placement
for the legend or choose None to turn off the chart legend.
(See Figure 12-17.)

Choose Chart Tools Layoutr>Legend>More Legend Options.

4. The Format Legend dialog box appears, offering the same type
of formatting options as the Format Chart Title dialog box ref-
erenced in the previous section. Choose any desired options.

5. Click the Close button.

Add a Data Table

122

1. Click anywhere on the chart you want to modify.

©)

2. Choose Chart Tools Layout=>Data Table in the Labels group.
Options that appear include a choice not to show a data
table, show a data table but not show a chart legend, or to
show a data table and include the chart legend.

®

3. Choose the data table option you want. A data table, as
shown in Figure 12-18, displays at the bottom of the chart.

®

Data tables can be added to charts on a regular worksheet, but it isn’t a common
practice because the worksheet itself already displays the data.

Data tables display the chart values in a grid beneath the chart. They are very helpful
if o reader needs to see exact values along with a graphical display, such as when
using a 3-D chart.

For more control over the data table appearance, click Chart Tools Layout=>Data
Table=>More Data Table Options in the Labels group. Make any choices from the
Format Data Table dialog bhox and dick Close.

Figure 12-17
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Select a Chart Color Style

Show Data Labels

1. Click anywhere on the chart that you want to modify. —
2. Choose Chart Tools Layout>Data Labels. A menu of data
label placement options appears.
You can use data labels to help identify the data series values, which are sometimes
difficult to read on the y-axis scale.
3. Select a placement option. Figure 12-19 shows the data labels )
with a placement of Outside End.
4. Choose Chart Tools Layout>Data Labels=>More Data Label
Options. The Format Data Labels dialog box appears.
5. If you don't want the data label to be the series value, choose e e ——
a different option from the Label Options area (such as the Figure 12-19
series or category names).
6. }:bte}}se Number option, select a number style for the data ‘ b ok ‘ kd ‘ kd ‘ kd ‘ kd ‘ kd ‘ kd ‘ [ 1
7. Select any additional options and then click the Close ‘ b v ‘ I II' ‘ h II ‘ h II ‘ l II ‘ h II ‘ | II ‘ b
button. bk bk hd hd hd hd ki ki
B bl bl bl bl bl bl
Select a Chart Color Style b b b b bl bl b b
Click anywhere on the chart you want to modify. m- - - H m 5

2. Choose Chart Tools Design and in the Chart Styles group, Figure 12-20
click the More button, which displays the Chart Styles gallery
(see Figure 12-20).

3. Select a chart style. Scroll down . . . you find more at the
bottom.
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Change Axis Options

1.

Click anywhere on the chart that you want to modify.
Choose Chart Tools Layout=>Axis Titles in the Labels group.

Choose Primary Horizontal Axis Title or Primary Vertical Axis
Title from the drop-down list that appears.

Choose an axis title location. For the horizontal axis, your
choice is Title Below Axis (or None). For the vertical axis, you
can rotate the title, run it vertically along the axis, or run it
horizontally. I don’t recommend the horizontal option
because it takes up a great amount of chart space. In Figure
12-21, you see both vertical and horizontal axis titles.

Highlight the axis text and replace it with your desired text.

(Optional) Choose Chart Tools Layout and in the Labels
group, click Axis Titles and from either the Horizontal or
Vertical Axis Title, choose More Options to set the line style,
background color, and other appearance choices. Click the
Close button.

Choose Chart Tools Layout and find the Axes group. Two
options are available:

e Axes: Choose this option to change the way Excel displays
either the horizontal or vertical axis. You can choose not
to display an axis or you can change the value representa-
tion along the vertical axis. Click the axis you want to
change and choose the More options to change choices,
such as axis-number formatting. (See Figure 12-22.)

e Gridlines: Choose this option to change the way the grid-
lines display along the chart background. You can add,
change, or remove horizontal or vertical gridlines. Choose
the gridline you want modified and click More Options to
modify the gridline color.
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Enhance a 3-D Chart

Farmat Chart Area
Enhance a 3-D Chart _
Fil 3-D Rotation
Border Color
1. Click anywhere on the 3-D chart you want to modify. Bordar Sty presets: D
Rotation
2. Choose Chart Tools Layout=>3-D Rotation in the Background e || & [@ @
group. The Format Chart Area dialog box, as shown in I v = 5@ &
F}ilgure 12-23, appears. The options you see depend on the . = 8 e
chart type' Size erspective; | 1.1° 5
. Properties e 1 @ @
3. From the 3-D Rotation tab: . ext
exl Keep text flat
¢ Click the X left or right arrows or enter the degree of left/ Osfectpostion
right rotation (between 0 and 360) you want for the chart pere e 8
in the Rotation section. This rotates the x-axis or pie slices
left or l'ight. ] Right Angle Azes
. Autoscale
e Click the Y up or down arrows, or enter the degree of up/ Depth (o cfbase) 1005
down rotation. Height 4 of bese) 10012
e Click the Perspective up or down arrows to change the
. . . -_Iose
camera view, or the view from the top. (Optional) Type the :
elevation angle (between 0.1 and 120) in the Perspective Figure 12-23
text box.
4. From the 3-D Format tab choose a Bevel option to select a BEFORE AFTER
bevel style for the top or bottom of the chart border.
5. Click the Close button. The chart appears onscreen, rotated "r":""“ "r"’:‘"“
to the angles you selected. Figure 12-24 shows a 3-D pie chart g Fhivas
before and after changing the perspective and rotation.

Figure 12-24
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Chapter 12: Creating Charts

Place a Picture in a Data Series

1.

Right-click the series or data point you want to modify. A
shortcut menu appears.

Choose Format Data Series. The Format Data Series dialog
box appears.

Click the Fill option. Fill options appear on the right side.

Select Picture or Texture Fill and then click File. The Insert
Picture dialog box appears.

Locate and select the picture you want to use; then click
Insert. The Format Data Series dialog box reappears.

Click the Close button. Figure 12-25 illustrates a pie chart
with one series as a texture, one as a pattern, and one as a
picture.

Adjust Chart Data

Click anywhere on the chart that you want to modify.

Choose Chart Tools Design=>Select Data in the Data group.
The Select Data Source dialog box opens with the current
chart data selected in the worksheet (see Figure 12-26).

Click and drag in the worksheet to select the new data range.
The Select Data Source dialog box collapses so you can easily
see your data.

Release the mouse button. The Select Data Source box
reappears, and the new data range appears in the Chart
Data Range box.

Click OK. The Select Data Source dialog box closes.

Figure 12-25

Select Data Source

Chart datarange: |="Sheetl'i§a$l:$06

"' I':I Esu\tch Row/Calumn ==

Legend Entries {Series)

Horizontal (Category) Axis Labels

2 4 ][ = Edit ][)(R_amme]

iz

[ [ Edit ]

January
February
March

Mary
Stephen
Johin
Eob

Susan

Figure 12-26







Chapter 13: Printing Workbooks

Add a Manual Page Break CEEEy

1. Click a cell in the row where you want the new page to begin.

2. Choose Page Layout=>Breaks=>Insert Page Break in the Page
Setup group. Dotted page break lines appear, similar to the
ones shown in Figure 13-1.

To remove the manual page break, click a cell in the row just below the page break
and choose Page Layout=>Breaks=>Remove Page Break in the Page Setup group.

Set a Specific Area to Print

Figure 13-1
1. Highlight the area you want to print. 0

Unless you specify a specific print area when you print, Excel prints the enfire
worksheet.

2. Choose Page Layout=>Print Arear>Set Print Area in the Page
Setup group. See Figure 13-2. Dotted lines appear around the
print area. When you print the worksheet, only the area con-
tained within the dotted lines prints. See the section, “Print
Worksheets and Charts,” later in this chapter.

To reset Excel to print the entire worksheet, choose Page Layout=>Print Area=>Clear
Print Area.

Figure 13-2
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Make Worksheets Fit Better on a Page

Adjust the Paper Orientation and Size

1. Choose Page Layout~>Orientation in the Page Setup group
and then choose whether you want a Portrait or Landscape
orientation.

Portrait orientation prints the top of the document along the short edge of the paper,
and Landscape prints it along the long edge of the paper.

2. Choose Page Layout=Size in the Page Setup group. A drop-
down list of paper sizes appears.

3. Choose a paper size. The paper size choices you see depend
on the printer you use. The two most common U.S. choices
are Letter, which is 8.5 x 11 inches and Legal, which is 8.5 x
14 inches. (See Figure 13-3.)

Choose More Paper Sizes fo open the Page Setup dialog box. From there you can
select additional paper sizes.

Make Worksheets Fit Better on a Page

1. Choose Page Layout and then click the Scale to Fit dialog box
launcher (the arrow in the bottom-right corner of the Scale to
Fit group). The Page Setup dialog box opens.

2. From the Scaling area on the Page tab, make a selection from
the options, as shown in Figure 13-4:

e Adjust To: Enlarge or shrink the printed font size by set-
ting a percentage option between 10 and 400.

e Fit To: Force Excel to a specified number of pages wide
and high.

Don't fry to shrink the document too much. Because Excel shrinks the font, trying to
fit too much on a page can make the document typeface foo small to read.

3. Click OK.

Alternatively, instead of opening the Page Setup dialog box, select
Width, Height, and Scale options from the Scale to Fit group on the

Page Layout tab.

rrrrrr

[ re—

Figure 13-3

Figure 13-4
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Chapter 13: Printing Workbooks

Set Page Margins

1. Choose Page Layout=>Margins in the Page Setup group. A list
of margins appears (see Figure 13-5).

2. Choose from the margins options shown or choose Custom
Margins to open the Page Setup dialog box that enables you
to set your own margin options.

From the Page Setup dialog box, dlick the Horizontally option and/or the Vertically
option in the Center on Page section to center the worksheet on the page, regardless
of the margins.

3. Click OK.

Specify Repeating Rows and Columns

1. Choose Page Layout=>Print Titles in the Page Setup group.
The Page Setup dialog box opens.

Figure 13-5

2. On the Sheet tab, type a dollar sign ($) followed by the row
numbers or column letters you want to print as titles in the
Print Titles section. Entering $1:$1, as shown in Figure 13-6,
repeats Tow 1 at the beginning of each page.

S Click the Collapse button on the right to collapse the Page Setup dialog box so you can

select the rows or columns you want to include. Click the Expand button to return fo
the Page Setup dialog box.

3. Click OK.

Figure 13-6
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Preview before Printing

Print Gridlines and Row
and Column Headings

1. Choose Page Layout and in the Sheet Options group, choose
from the following options:

e Gridlines=>Print: Select the Print option to print the grid-
lines surrounding each cell in the worksheet.

; By default, the Gridlines View check box is selected. If you don't want to see the grid-

lines while you're working on the worksheet, deselect this check box.

e Headings=>Print: Select the Print option to print the row
numbers or column letters around the worksheet. Figure 13-7
illustrates a worksheet printed with gridlines as well as row
and column headings.

ing Filec>Options and selecting a different gridline color from the Advanced section.

; By default, gridlines are a lighter shade of gray. You can change the gridline color by choos-

Preview before Printing

1. Click File. From the Backstage View that appears, click Print.
A Print Settings section appears on the left, and a preview of
the worksheet appears on the right.

2. From the preview area (as shown in Figure 13-8), select from
the following options:

e If you have multiple pages, click the Page buttons (in the
bottom center) to view additional pages.

e Click the Zoom icon in the lower-right corner to enlarge
the view. Click it again to reduce the view.

e Select the Show Margins icon to display the page margins;
then drag any margin line to manually set margin sizes.

Then click the Show Margins icon again to turn
off the margin lines.

See the upcoming task, “Print Worksheets and Charts,” in this chapter,
to review the Print Settings options.

3. Click File to return to Normal view.

Figure 13-7

Figure 13-8
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Chapter 13: Printing Workbooks

Add a Standard Header or Footer

132

1.

Choose Viewr>Page Layout in the Workbook Views group.
You see the header area of your worksheet. Headers and foot-
ers are divided into three sections: Left, Center, and Right.
Headers appear at the top of each printed page, and footers
appear at the bottom of each printed page.

Click in the header (or footer area) where you want data.
Additional tabs appear on the Ribbon.

Choose Header & Footer Tools DesigntoHeader (or Footer) in
the Header & Footer group. A list of predefined headers (or
footers) appears, as shown in Figure 13-9.

4. Select the header (or footer) you want to use.

View Other Header and Footer Options

1.

Choose Viewr>Workbook Views=>Page Layout and click any-
where in the header or footer area.

Choose Header & Footer Tools Design and from the Options
group, select any of the options shown in Figure 13-10:

e Different First Page: If you choose this option, Excel
doesn’t print the header or footer on the first page.

e Different Odd & Even Pages: Choose this option if you
want a header or footer for the odd-numbered pages of the
document different from the one that prints on the even-
numbered pages.

e Scale with Document: This option is selected by default
and tells Excel to use the same font size and scaling as the
worksheet. If you want the header and footer font size and
scaling independent of the worksheet scaling, deselect this
check box.

e Align with Page Margins: Choose this option to align the
header and footer with the left and right margins of the
worksheet.

Figure 13-9

=]

Figure 13-10




Create a Custom Header or Footer

Create a Custom Header or Footer

1. Choose Viewr>Page Layout in the Workbook Views group.

Click the Go to Footer button on the Header & Footer Tools Design tab to jump fo the
footer area.

2. In the desired Header or Footer section, type the text you
want for the header (or footer). As shown in Figure 13-11, Figure 13-11
you can format the header and footer text just as you would

any cell data.

3. Click any buttons from the Header & Footer Elements group: e

NAME

2010 Pagroll Log

GROSS PAY FEDERAL AcA MEDICARE

STATE

INSURANCE

1/18/2010

NETPAY

ALLISON WOO0D

e Page Number: Insert a code &[Page] that indicates the s

500150 (114.63) G7212) (87,01
144375 (124.57) (89.53) (204)
212813 (185.17) (131.55) (30.86)

(166.48)
(43.10)
(72.35)

1100.00)
(75.00)
(75.00)

516164
o

84.61
163280

page number. Figure 13-12

e Number of Pages: Insert a code &[Pages] that indicates the
total number of pages.

Add text to the page fext. For example: Page &[Page] of &[Pages] prints Page 3 of 5
or Page 1 of 2.

e Current Date or Current Time: Insert the print date or
time of day. See Figure 13-12.

¢ File Path, File Name, or Sheet Name: Include file
information.

e Picture: Insert a graphic image, such as a company logo.

e Format Picture: Resize, rotate, or crop a header or footer
graphic image.
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Saving Time with
Excel Tools JIT N

Fis chapter is about stuff . . . Excel stuff. In the earlier chapters, I show
how Excel has lots of power to make your computing life a little easier.
This chapter contains a diverse group of Excel tools designed to speed up

data entry and improve spreadsheet quality.

In this chapter, you discover how to Get ready to. . .
= Set and manage Excel options including choosing a default location in = Set Excel General Opfions........................ 136
which to store your files. ’ ]
. . . w= Set the Default File Location................... 137
w=  Customize the Ribbon and Quick Access toolbar.
, . w= Manage AutoCorrect............oveeeeeeeuurnccces 137
== Manage Excel’s AutoCorrect feature to automatically correct many
common misspelling or formatting issues. w= Examine Advanced Editing Options .......... 138
w=  Add special characters such as the copyright symbol, the registered w= Customize the Quick Access Toolbar ......... 139
trademark, foreign characters, or smiley faces. c he Rith 199
= Customize the Ribbon...............ovvereenneecc
»= Check the workbook for spelling errors. Excel includes a built-in
dictionary you can use to check your workbooks for misspellings; = Add Special Characters ........................... 140
however, it can’t read your mind. But combine the spell check with id the Riah it the Th
careful proofreading, and it becomes a very helpful tool. »= Find the Right Word with the Thesaurus ... 140
w= Work with what I call Assistance Tags, those funny little icons that w= Check Your Spelling 141
often appear when you perform certain functions, such as paste data Sl Aeei
or enter a formula that may contain an error. Assistance Tags offer you = Worl vith ASsSIanCe Tags ... 142
options right at the tip of your mouse pointer. w= Split Data info Multiple Columns............... 143
= Split data into multiple columns where you can break up data con- = Merge Columns 144

taining multiple words such as a first name and last name, or city,
state, and zip code, into separate columns.

»=  Merge columns by using the CONCATENATE function to combine data.






Manage AutoCorrect

Set the Default File Location

1. Choose File>Options and click the Save category. You see
the options, as shown in Figure 14-3.

2. In the Default File Location text box, enter the data path to the
place where you want to save most of your files. By default,
Excel saves your files in the Documents folder stored on your
local hard drive, but your company may have another location
where it wants you to keep most of your Excel files. An exam-
ple might be G:\COMPANY DOCUMENTS\DIANE.

To override the default file location, when saving or opening a file, you can click the
Favorites list and choose a location different from the default location.

3. Click OK.

Manage AutoCorrect
1. Choose Files>Options and then from the Proofing category,
choose AutoCorrect Options. The AutoCorrect dialog box opens.

2. Deselect any check box from any option you don’t want Excel
to correct automatically.

In the Replace box, type a common typing mistake.

4. In the With text box, type the correct word, as shown in
Figure 14-4, and then click the Add button.

To remove any unwanted entry, select the entry and click the Delete button.

5. Click the AutoFormat as You Type tab and deselect the
check box from any action you don’t want Excel to perform
automatically.

6. Click OK twice.

Excel Options

=

General
H Customize how workbooks are saved.

Formulas

Froofing Save workbooks

Save Saue files in this format: | Excel Workbaok

Language [¥] Save AutoRecover information every |10 S| minutes

Keep the last Auto Recovered file It cose without saving
advanced

AutoRecaver file location: [AUsers\DianeiAppDiata\RoamingtMicrosoftiExcell
Customize Ribbon Default file location: CaUsersDizneDacuments

Quick Access Toolbar [ Save date and time values using 15O 8801 date format (may limit precision)
Add-Ins AutoRecover exceptionsfor:  |[if] BookL [=]
Trust Center
[F] Disable AutoRecover for this workbook only

Offline editing options for document management server files

Save checked-out files taic:
(©) The senver arafts location on this computer
© The Office Document Cache

Seryer drafts location: | CUsers\Diane\DocumentsiSharePoint Draftsy

Preserve visual appearance of the workbook

Choose what colors will be seen in previous versions of Excel: @ | Colars,

Browse.

Figure 14-3

AutoCorrect: English (U.S.) [ )=

AutoCortect | AutoFarmat As ou Type | Smart Tags | Math AutoCorrect |

Show AutoCorreck Options buttons

Correct Two INitial Capitals
xceptions. ..

Copitalies First Itter of sentences i

Capitalize names of days

Correct accidental use of cAPS LOCK key
Replace text as you type

Replace: wiith:

situatin situstion

simniliar similar -
simpryl simply

sincerly sincerely m
sitl still T
smas same 2

Figure 14-4
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Chapter 14: Saving Time with Excel Tools

Examine Advanced Editing Options =

[ | e .
Ener i:=] advanced options for working with Excel. m
Formulas

1. Choose File>Options and then click Advanced. (See Figure e e et
14-5.) The top section in the Advanced category includes oyecson oo ]
Editing Options. ]| oo
Customize Ribbon Enable fill handle and cell drag-and-drop
2. Here are a few of the more commonly used editing options. cun oo || ] oo g L
Select or deselect the following as desired: - 2 e e e s v o
Enable autoComplete for cell values
e After Pressing Enter, Move Selection: Change the direc- e o et o
tion of the next selected cell after pressing the Enter key. If g e e o s e [
deselected, the selection cell remains the current cell. S
e Automatically Insert a Decimal Point: When selected and
you type a value such as 105, Excel enters it as 1.05 instead o i
of the whole number 105. You can also set the number of S s Opion bttomwher cortert s pted
. . Show Insert Options buttans
decimal places you want displayed. g —
e Enable Fill Handle and Cell Drag-and-Drop: When e =
selected, you can copy and move data by dragging the cells I oo et comprss s n e

Set et torget cutput tor 220 ppi (=]

to a new location. (See Chapter 2.)

e Allow Editing Directly in Cells: This option controls Figure 14-5
whether you can edit a cell by double-clicking the cell.

If deselected, you can edit cell contents only in the 3 = = :
Formula bar.

e Extend Data Range Formats and Formulas: When selected, ':r:"‘;‘i;:a"
Excel automatically formats new items you add to the end Spgnish
of a list to match the format of the rest of the list. Ltalian

e Enable AutoComplete for Cell Values: This controls
whether Excel completes text entries, as shown in Figure
14-6, when in the same column, the first few letters match
an existing entry in the column.

3. Click OK when you're finished. Figure 14-6
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Customize the Ribbon

H : Click the up or down arrow fo reorder the buttons. Rename the new
CuStom’ze the -Q HICk AcceSS TOO(bar custom group (or tab) by clicking the new group and then clicking the
Rename button. Remove a tool, custom group, or custom tab by click-

1. Choose File>Options. The Excel Options dialog box appears. ing it and then dicking the Remove button.

2. Click Quick Access Toolbar. Options for customizing the ) )
Quick Access toolbar appear. 4. Click OK when you're finished.

3. Click the down arrow next to the Choose Commands From
drop-down list and choose All Commands. All Excel com-
mands appear in the list on the left side.

4. Choose the command you want to add to the Quick Access

toolbar and then click the Add button. See Figure 14-7 in
which I add the Quick Print button.
In the right column, click any command and then lick the up or down arrow to .
change the icon arrangement. Click the Reset button to reset the Quick Access toolbar -
to the default toolbar.
5. Click OK when you're finished.
Customize the Ribbon ,
Figure 14-7
1. Choose File>Options and then click Customize Ribbon.

2. From the right side column, click the Ribbon tab name to
which you want to add the tool and then click the New
Group button. A New Group appears at the bottom of the
selected Ribbon tab list. You can’t modify the existing groups,
but you can add new ones.

If you want to create o new custom Ribbon tab, instead of clicking the New Group
button, click the New Tab button.

3. With New Group (Custom) selected, from the left side column,
click the tool you want to add and then click the Add button. )
The tool appears under the new group. See Figure 14-8 in which fl s i T
I add the New, Open, Quick Print and E-Mail buttons to a new = [
group. Figure 14-8 139




Chapter 14: Saving Time with Excel Tools

Add Special Characters T

[ symbols | special Cheracters |
1. Click the location where you want the symbol. Special char- Eont: [ Wnodngs =] )
acters can be in their own cells or amid other text or values. o e|Fe B[ 6 | B DB [Semlaledm
. =B |E (g B2 |&E b w B = ®
2. Choose Insert=>Symbol in the Symbols group. The Symbol MR g <=4 7o Eloloe 2 ;
dialog box appears (see Figure 14-9). = hi - =
Ry | 2| ||| | | | | G| 30| 88V
3. From the Symbols tab, click the symbol you want to use. R
| ™ + = ==
Different fonts display different symbols. If you don't see the symbol you want, | IEIE, |©| - | #=]= | ‘ x | ‘ " ‘ «|P |
choose a different font from the Font drop-down list. For a large variety of unusual ingdnas: 74 Sharacter cods: 74 Fems yml decma) 7]
characters, look at the Wingdings fonts. Addifional special characters are available on
the Special Characters tab. .
Figure 14-9
4. Click the Insert button. Excel inserts the symbol into the cur-
rent cell. Click the Close (X) button. Beserel &
Search For:
specialty =]

Thesaurus: English {1J.5.) El

Find the Right Word with the Thesaurus |> - ©

4 Thesaurus: English {U.5.) »

4 field (n.y
1. Click anywhere in the word you want replaced. fekd
Forke
2. Choose Review=>Thesaurus in the Proofing group. A Research sphere
pane, as shown in Figure 14-10, appears on the right side of e ]
the screen and displays various meanings of the current word wen
and possible replacements. departnert
domain
Alternatively, press Shift+F7 to launch the Thesaurus. e

discipline T
area of expettise (Dicki...

branch of learning (Dic...

N

specialism {n.)
specialism

3. Ifyou don't see the exact word you want, click a similar subject
word, which displays its synonyms. Click the Back button to e i
return to the previous word. R —
Marketplace
4. When you locate the word that best fits your document, click (L, Research cptios..

the arrow next to it and choose Insert. Excel replaces the cur-

. . Figure 14-10
rent word with your selection. o
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Check Your Spelling

Check Your Spelling

1. Choose Review>Spelling in the Proofing group. The Spelling
dialog box opens with the first potential error, as shown in
Figure 14-11.

Spell checker reviews all cell values, comments, embedded charts, text boxes, buttons,
and headers and footers, but it doesn't check protected worksheets, formulas, or text
that results from a formula.

2. Click one of the following buttons:

Change or Change All: Choose one of the suggestions;
then click the Change button to change just this spelling
mistake or click the Change All button if you think you
made the mistake more than once.

AutoCorrect: Have Excel, in future workbooks, automati-
cally correct the mistake with the selected replacement.

Ignore Once: Click this button if you don’t want to
change the spelling of the highlighted instance.

Ignore All: Click this button if you don’t want to change
the spelling of any identical instances.

Add to Dictionary: Add a word, such as a proper name or
medical or legal term, to Excel’s built-in dictionary so that
Excel won't flag it as a potential error in the future.

3. After you click one of these buttons, Excel proceeds to the
next error. When all potential mistakes are identified, the
message box shown in Figure 14-12 appears. Click OK.

Spelling: English (U.S.) ==
Mot in Dictionary:
Ignore All
Add to Dictionary

Suggestions:
Bandannas
Bananas' Change Al

- AutoCorrect
Dictjonary language: | English {L1.5.) [=]

Figure 14-11

Microsoft Excel

The speling check is complete far the entire shest,

=

Figure 14-12
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Work with Assistance Tags

1.

From the worksheet, click an Assistance Tag icon. Each
Assistance Tag type appears with a different icon appearance
and options including:

Paste Options: This icon appears over pasted data (as
shown in Figure 14-13), offering choices for pasting, such
as whether to include formatting, values, or both.

AutoFill Options: This icon appears after you enter data in
a worksheet, offering tips on how to fill in the text or data.

Insert Options: This icon appears next to inserted cells,
rows, or columns, offering a list of formatting options.
(See Figure 14-14.)

Error Checking: This icon appears over potential formula
errors in the same way as the Error-Checking feature.
These errors are indicated by a small green triangle in

the upper-left corner of a worksheet cell.

Choose the option you want.

Figure 14-13

B

o old&
5

D E

Format Sarme As Left
Format Same 4s Right

LClear Formatting

Figure 14-14
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Merge Columns

1. Click in the cell where you want to put the merged data.

2. Choose Formulas=>Text>Concatenate in the Function Library
group. The Function Arguments dialog box appears. (See
Figure 14-17.)

3. Type the first cell address or click the cell you want to add to
the combination. Excel enters the cell address in the Text1 box.

S (Optional) If you want to add specific text that isn't in a cell address, type the fext or

punctuation (including any spaces) on any line. Excel places any spaces, punctuation,
or text in quotation marks.

4. In the Text2 box, click the cell or type the text you want next.
Each element must go on its own text-box line.

5. Repeat Step 4 for each item you want to add. Figure 14-18
shows an example in which I want to add a comma and a
space between the first cell (City) and the second cell (State).
I'm also adding two spaces between the State cell and the Zip
cell. You can see the result in the bottom of the Function
Arguments dialog box.

6. Click OK.

To convert the merged cells into plain text instead of formulas, select the merged
cells, choose Home=>>Copy; next, choose Homec>Paste>Paste Special; and finally,
select Values from the Paste Special dialog box and click OK.

(Optional) Use the ampersand (&) between cell addresses to join text ifems. For
example, =A1&B1 returns the same value as =CONCATENATE(AT,B1). However, the
cells you connect with the ampersand can’t be blank.

You can also use the CONCATENATE command along with a couple other fundtions, fo display
only certain digits — for example, the last four digts of a cell containing a credit card num-
ber. If cell C5 contains the credit card number and you want cell D5 fo display ****-**-
#1234, enter the following formula in cell D5. =CONCATENATE(REPT(“****." 3),

@, @, @,

RIGHT(C5,4)). The REPT function repeats the “****-" text three times and combines that with

the last four digits of the credit card number, which are derived from the RIGHT function.

PCATENATE = | © W o fo| =CONCATENATEQ

OO0 e ke

ke

Formd vk =

it

[

=

22 Va
23 W,
4
25

26
WA bW Customer List (7)o Gl et %) L

Figure 14-17

Figure 14-18




Part |V
Analyzing Data with Excel

The 5th Wave By Rich Tennant

“T started running “what i€’ scenarios on my
spreadsheet, like, “What if T were sick of this
dirtwad job and funneled some of the companyg’s

money into an off—shore account?”






Working with Outlines

w hen you're working with a large worksheet, it's sometimes difficult to
look at the big picture your data presents to you. You can use Excel
to automatically calculate subtotal and grand total values from rows con-
taining related data (sometimes called a database). When you create sub-
totals, Excel outlines the list so that you can display or hide the detail rows
for each subtotal.

A couple other database terms you need to become familiar with are fields
and records. Fields break down your database list into manageable pieces by
using Excel columns. For example, an address database might include fields
such as name, address, and phone number. Records are the rows containing
the individual pieces of information you enter. In an address database, for
example, a single row contains all the information about a specific person.

Before you use the subtotal feature, you must first sort your list so that the
rows you want to subtotal are grouped together. You can then calculate sub-
totals and perform other mathematical calculations for any columns that
contain numbers. You can also count the number of items in a selected

field.

If your data isn't in a database format, you can still group sections to create
a quick way to display or hide them as necessary. Similarly to the way Excel
does subtotals, it displays groups in an outline format. In this chapter, I take
a look at the extensive subtotaling, grouping, and outlining features con-
tained in Excel. I also show you how to create a data entry form screen for
faster data entry. By default, Excel 2010 doesn't include the Form command
you need for this, but you can easily add it to the Quick Access toolbar.

”'%apter

Get ready to. . .

w= Add the Form Butfon...........eevouenn......

w= (reate a Data Entry Screen................

= Manage Records through the Form
Screen

= Generate a Subtotal ........................
= Collapse Subtotal Headings.................
w= Control Individual Subtotdls................
w= (reate Multiple Subtotdls....................

= Copy Subtotals

w= Remove Subtotals

w= Use AutoQutline

w= Form an Outline Group.......................
= Remove Items from a Group ..............

= Consolidate Data by Category.............



Chapter 15: Working with Outlines

Add the Form Button

1. Choose File>Options. The Excel Options dialog box appears.

2. Click the Quick Access Toolbar section and from the Choose
Commands From drop-down list, choose Commands Not in
the Ribbon.

3. Click the Form button and then click the Add button.
Excel places the Form command in the right column. (See
Figure 15-1.)

4. Click OK. Excel places the Form command in the Quick
Access toolbar.

Using a data form for data entry is easier than typing across the columns when you
have more columns than fit on the screen at one time.

Create a Data Entry Screen

1. In row 1 of your worksheet, enter the column headings for
your database. When you create the data entry screen, the col-
umn headings appear as field names. Each database table
should have a specific topic, such as inventory items or ven-
dor addresses, and should have two or more fields. No two
field names can be exactly alike.

For faster data entry, format any numerical columns with the correct number format.
Then when you use the data entry screen, you enter only the raw numbers without
commas or dollar signs.

2. Click in any table heading cell and then click the Form but-
ton from the Quick Access toolbar.

3. Click OK if a message box appears. If you already have
records entered into the database, Excel doesn’t display the
message box. Instead, Excel displays a data form dialog box
with the headings shown as field names. See Figure 15-2.
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Manage Records through the Form Screen

Each label has a field beside it for you to enter the field data.

(See Chapter 6.)

; Widen the data entry fields by widening the columns in the spreadsheet.

4. 1In the data form dialog box, enter the information for the
first record and press the Tab key to move from field to field
(see Figure 15-3).

s Press Shift+Tab to move back to the previous field.

5. Click the New button. Excel adds the record to the database
and displays another blank screen ready for the next record.

6. Click the Close button when you finish entering data.

You can reopen the database form at any fime by clicking the Form button on the
Quick Access toolbar.

Manage Records through the Form Screen

1. Click the Form button from the Quick Access toolbar. The
Form window opens.

The active cell must be somewhere within the database headings or data.

2. Click the Find Next button. The form displays the next record
in your database.

W

Click the Find Prev button. The previous record in your data-
base appears.

4. 1f you want to delete the current displayed record,
click the Delete button. The warning message
shown in Figure 15-4 appears.

5. Click OK if you want to delete the record. Use cau-
tion. This action can’t be undone!

Click the New button to display a blank form where you can enter a

new record.
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Chapter 15: Working with Outlines

Generate a Subtotal

Sort the field to use for generating subtotals. For example, if
you want to know the total sales by state, you sort by the
State field. (See Chapter 11 for sorting instructions.)

The subtotal data must have no blank rows or columns, and each column in the dato-
base must have a label in the first row.

Choose Data=>Subtotal in the Outline group. The Subtotal
dialog box appears.

Select the field you want to subtotal from the At Each Change
In drop-down list.

Select a function from the Use Function drop-down list.
Choices include SUM, which totals the values in a field;
COUNT, which returns the quantity of items in a field,
COUNT NUMBERS, which returns the quantity of numerical
items in a field, AVERAGE, which determines the average
value of a field; MAX and MIN, which display the highest
and lowest value in a field; and PRODUCT, which returns the
value of all the numbers in a field multiplied together. The
options also include four statistical functions: STDDEV,
STDDEVP, VAR, or VARP.

Select the fields you want to subtotal from the Add Subtotal
To list. (See Figure 15-5.) You can select more than one field
to subtotal.

Select the Replace Current Subtotals check box if you already
have previous subtotal calculations. Excel replaces the previ-
ous subtotals with the new ones.

Select the Page Break between Groups check box if you want
Excel to begin each subtotaled group on a new page.

Click OK. Excel performs the subtotal. Figure 15-6 shows
sales subtotaled by state.

Figure 15-5
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Control Individual Subtotals
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2. Hide and show data using the following methods: 5
87
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. . 89
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. e Figure 15-7
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11 CA Total 24,201
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- | 18 Associated Cargo Decatur IL 9/16/2008 5,254
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1. Create subtotals for your data (see the “Generate a Subtotal” = Moo st |

section, earlier in this chapter). Figure 15-8

2. Click the Show Detail (plus sign) button next to any subtotal
row. As shown in Figure 15-8, the selected subtotal detail
expands. You see the detail data for Illinois, but the other
states are still hidden.

3. Click the Hide Detail (minus sign) button next to any sub-
total row. The detail data for the selected row is hidden.

Alternatively, choose Data and then in the Outline group, click the Show Detail or Hide

Detail buttons.
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9. Deselect the Replace Current Subtotals check box and click
OK. Figure 15-10 illustrates the list subtotaled first by state
and then by city.

As you perform additional subotaling, Excel adds additional levels. In Figure 15-10,
four heading levels are displayed. Level 1 displays only the grand totals, level 2 dis-
plays the count by state, level 3 shows the count by city, and level 4 displays the
details.
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Remove Subtotals

1.
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Figure 15-11

Click OK. White lines appear around the selected cells.

Choose Home=>Copy in the Clipboard group. A marquee
appears around the selected cells.

Select the first cell of the group in which you want to place
the copied data.

Choose Homer>Paste in the Clipboard group. Excel duplicates
only the subtotaled values, not the formulas or hidden cells.

The copy subtofal process also works if you have your data in outline format. (See
more about outlining later in this chapter.)

Remove Subtotals

1.

Select any cell is the range that contains the subtotals; then Figure 15-12
choose Datar>Subtotal. The Subtotal dialog box appears. (See
Figure 15-12.)

Click the Remove All button. Excel removes all subtotal infor-
mation from the database, including the Expand and Collapse
icons from the left side of the worksheet. Your data remains
in the order you last sorted it.
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Remove ltems from a Group

Form an Outline Group

1. Highlight the rows that you want to group.

2. Choose Data=>Group in the Outline group. In Figure 15-15,
you see all the North category sales grouped.

Alternatively, to create a group, select the rows or columns and then press
Alt+Shift+right-arrow key.

Use the Hide Detail or Show Detail buttons to hide or display the group detail.

3. Repeat Steps 1 and 2 until you've created all the levels you
want in the outline. A worksheet can have up to eight outline
levels.

Grouped areas can't be immediately adjacent fo other grouped areas. If you create a
group and then create another group directly next to it, Excel doesn’t create two
groups; it creates one larger group.

Remove Items from a Group

1. Select the rows or columns you want to remove from the
group. If you want to remove an entire group, select all the
rows or columns in the group.

2. Choose DatazvUngroup in the Outline group. The Ungroup
dialog box appears.

3. Choose Rows or Columns; then click OK. Excel removes the
rows or columns from the group, and if the rows or columns
you delete are in the middle of a group, Excel breaks the group
into two smaller groups. See Figure 15-16 where rows 7 and 8
are removed from the group and the rest of the North sales are
broken from one group into two smaller groups.

You can also clear a group by selecting the rows or columns and then
pressing Alt+Shift+left-arrow key.

East - Bob
3 East -Mary
A East - Sarah
s East - John

B
Region-Salesperson  January February  March

a7

&

69
a5
57
12

D

56
B0

&1

e
April
84

6 [Morth - Bob

81
83

&1

= 10 South - Bob

11 South - lohn
12 South - Mary
13 South - Sarah
14 West - Bob

15 West - John

16 West - Mary
17 West - Sarah
18

Figure 15-15

Figure 15-16

155















Chapter 16: Filtering Data

Perform a Secondary Filter Selection

1. Make sure the AutoFilter option is on (choose Data=Filter in
the Sort & Filter group) and your database columns contain
filter arrows.

Click the column arrow by which you want to filter data first.

Choose the data you want to filter. In Figure 16-5, you see selec-
tions that display only Indianapolis in the City column. Note,
however, that there is an Indianapolis in GA, OH, IN, and NY.

4. To further isolate specific items, click the filter arrow at the
top of another column.

of data.

S Each additional filter is based on the current filter and further reduces the subset Figure 16-5

5. Select the field by which you want to perform the second fil-
ter. In Figure 16-6, the primary option was to filter by the city
of Indianapolis. I now apply the state of NY as the secondary
filter (because, in Step 3, four states had a city named
Indianapolis). Only two records match that criterion.

6. Repeat Steps 4 and 5 to further filter by as many fields as :
necessary. Figure 16-6

7. When you're finished working with your filtered data, choose
one of these options:

e Return to the first filter: Click the second filter column
arrow and choose a different second filter.

e Return to the first filter only: Click the second filter col-
umn arrow and choose Clear Filter from “field name.”

e Return to viewing all records: Choose Data=>Clear in the
Sort & Filter group.

When working with filters, it's best not o mix text, number, and date formats in the same

column because only one type of filier command is available for each column. If a mix of

formats occurs, the command that's displayed has the format that's used most frequently.
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Use a Comparison Filter for Text

Use a Compatrison Filter for Text

1.

Make sure the AutoFilter option is on (choose Datar>Filter in
the Sort & Filter group) and click the filter arrow for the text
column by which you want to filter data.

Choose Text Filters. A submenu of comparison filters like the
one in Figure 16-7 appears:

Equals or Does Not Equal: Equals locates all records in
which the selected field cells exactly match or Does Not
Equal locates all records in which the selected field cells
don’t match the text you specify. For example, if you look
for records matching Boston only the records with Boston
appear. Records containing New Boston, Boston Hill,
Indianapolis, Bostonia, Atlanta, or Chicago don't appear.
If you choose Does Not Equal, you might see New Boston,
Boston Hill, Indianapolis, Bostonia, Atlanta, and Chicago,
but not Boston.

Begins With or Ends With: Locates all records in which
the selected field cells begin or end with the text you spec-
ify. If you choose Begins With, Boston Hill, Bostonia, and
Boston display, but not New Boston, Indianapolis, Atlanta,
or Chicago. If you choose Ends with, you'd see the records
for Boston and New Boston but not Boston Hill, Bostonia,
Indianapolis, Atlanta, or Chicago.

Contains or Does Not Contain: Locates all records in
which the selected field text contains or doesn’t contain
the text you specify. The text could be at the beginning, the
middle, or the end of the field cell value.

Make a selection. The Custom AutoFilter dialog box, as
shown in Figure 16-8, appears.

In the first list box on the right, type the data you want to
filter.

5. Click OK to display the filtered records.

1 First Nam - Last Nan = Com
: Abboud  Abbo

20 Bl pahien \Curioy

Figure 16-7

Custom AutoFilter ==
Show rows where:
Ciky
begins with |z| Bostan| lz‘
@and O or
Use ? to represent any single character
Use * ko represent any series of characters
Figure 16-8
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Chapter 16: Filtering Data

Choose Additional Comparison Criteria

1. Follow Steps 1-4 from the preceding section, “Use a
Comparison Filter for Text.”

2. Select the And or the Or option. Choosing And means that
both criteria must be met, and choosing Or means that either
criterion can be met.

Figure 16-9

From the drop-down list, choose a second comparison filter.

4. Enter the second comparison filter value. Figure 16-9 shows
an example.

If you need fo locate cells that share some of the characters you entered but not
others, you can use a question mark (?) wildcard character.

5. Click OK to display the filtered records.

Use a Compatrison Filter for Numbers

1. Make sure the AutoFilter option is on (choose Data=>Filter in
the Sort & Filter group) and then click the filter arrow for the
numeric column by which you want to filter data.

2. Choose Number Filters. A submenu of comparison filters, as

shown in Figure 16-10, appears. Some of the choices included
are: Equals, Does Not Equal, Greater Than, Greater Than or
Equal To, Less Than, Less Than or Equal To, and Between.

Figure 16-10

3. Choose a comparison filter to display the Custom AutoFilter
dialog box.

4. Enter your filter criteria and then click OK.
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Filter by Date or Time

1. Make sure the AutoFilter option is on (choose Data=Filter in
the Sort & Filter group) and click the filter arrow for the date
column by which you want to filter data.

By default, dates in the database are grouped by years, months, and days in that
order.

2. Choose Date Filters. You see an extensive list of date filters
like the ones shown in Figure 16-13.

Excel includes two fypes of date filters: common and dynamic. Common filters are based
on a comparison operator, such as Equal To, Greater Than, Less Than, or Between.
Dynamic filters are those for which the criteria can change when you reapply the filter.
They indude Today, Tomorrow, Next Month, Last Year, and Year to Date.

3. Choose a date filter. If you choose a common filter, you see
the Custom AutoFilter dialog box. If you choose a dynamic
filter, Excel immediately applies the filter.

4. If you chose a Common filter, in the box on the right, enter a
date or time or click the Calendar button to select a date.

5. Click OK.

Years and quarters always start in January of the calendar year.

Filter by Color

1. Make sure the AutoFilter option is on (choose Data=Filter in
the Sort & Filter group) and click the filter arrow for the col-
umn by which you want to filter data.

2. Choose Filter by Color. A submenu of color options, as
shown in Figure 16-14, appears. You can filter by cell (back-
ground) color or by font color. The submenu you see
depends on the color choices in your data.
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3. Select an option. Excel displays the database using
the filter you request.

Figure 16-13
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Create a PivotTable

Choose Insert=>PivotTable in the Tables group. The Create
PivotTable dialog box appears.

Make a selection. Excel needs to know where your data will
come from:

e Select a table or range: This choice creates the PivotTable
from organized data in a Microsoft Excel worksheet.

e Use an external data source: This choice creates a
PivotTable from data stored in a non-Excel database.

Verify that Excel correctly identified your data range, includ-
ing the headings. If not, specify the correct area in the Table/
Range box, as shown in Figure 17-3.

If the data is in another worksheet in the same workbook or a different saved work-
book, type the workbook and worksheet name like this: [workbookname]
sheetname!range.

Choose whether to add the PivotTable to a new worksheet in
your workbook or to another existing worksheet. If you
choose to add it to an existing worksheet, you must specify a
cell location.

Click OK. Excel creates a new worksheet with a blank
PivotTable along with the PivotTable Field List, which con-
tains each field from your data range (see Figure 17-4). Excel
also places two new PivotTable Tools tabs on the Ribbon.
PivotTables contain three primary elements:

e Rows: The rows area displays your data vertically, with one
item per row.

e Columns: The columns area displays the data horizon-
tally, with one item per column.

e Values: Data fields summarize numerical data.
To quickly restart a PivotTable, click anywhere in the PivoiTable and choose PivotTable

Tools Options=>Clear=>Clear All in the Actions group. (Optional) You can delete a
PivotTable by deleting the sheet it appears on.

Create PivotTahle
Choose the data that vou want to analyze
@) Select a table or rangs
TablefRange: | Inventory!$A$1:$F§3772
() Use an external data source

zn
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Lacation: =

Figure 17-3
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Figure 17-4
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8. From the PivotTable Field List pane, select the check box next
to the field you want categorized. For example, if you want to
determine how much each salesperson sold, select the Sales
Rep check box. Excel automatically places each unique item
into the PivotTable rows and displays the name in the Row
Labels box in the section located beneath the field name list.
In Figure 17-5, Excel displays the name of each
representative.

If you want the categorized field displayed horizontally instead of vertically, drag the
field to the Column Labels box of the areas section.

9. From the PivotTable Field List pane, select the field, such as
Quantity, you want summarized and perform one of the fol-
lowing actions. Excel instantly takes the data and adds the
totals to create the summary PivotTable (see Figure 17-6).

e Select the check box next to the field.

The PivotTable Field List indicates fields used in the PivotTable with bold lettering. You
don't have to use all the fields in the PivotTable, and you don't have to place fields in
every area of the PivotTable.

e Drag the field to the Values box in the areas section.

If you drag a field fo an incorrect area, deselect the field name check box or drag the
field name out of the section located beneath the field name list onto the Excel work-
sheet or into the correct field box.

the Actions group. Press the Delete key. (Optional) Delete the entire worksheet.

To move a PivotTable to a different location, choose PivotTable Tools Options=>Move
PivotTable. In the resulting dialog box, specify or point to a new location for the cur-
rent PivotTable.

S To delete a PivoiTable, choose PivotTable Tools Options=>Select=>Entire PivotTable in

Figure 17-5
Hﬂ- 3

f %

A

1

2

3 [Row Labals -ISumufquanliN
4 DML 8805
5 DMR 8861
& 10M 8814
7 M 9004
8 SDF 8129
9 M8 9004
10 ThRH 2078
11 TSK 8627
12 VFK a8rn
13 Grand Total 79712
14

15

16

17

18

19

20

7

Figure 17-6



Refresh PivotTable Data

Filter PivotTable Data

On the PivotTable, click the down arrow in the Row Labels
heading section. A list of individual items, such as sales rep
names, appears. The items that appear depend on the values
you used in your data.

From the Row Labels list, remove the check mark next to any
item you don’t want included in the PivotTable. In Figure 17-7,
only data for two specifically selected sales reps appears in the
PivotTable.

To clear the filter, dlick the Row Labels heading arrow and choose Clear Filter or
Select All.

Refresh PivotTable Data

1.

Use any of the following methods to update the PivotTable
with making any changes to the original data:

¢ Choose PivotTable Tools Options=>Refresh in the Data group.

e Right-click anywhere on the PivotTable and choose Refresh
from the shortcut menu.

e Make the PivotTable refresh automatically whenever you
reopen the file by choosing PivotTable Tools Options=
PivotTable>Options. From the Data tab of the PivotTable
Options dialog box, select Refresh Data When Opening
the File, and then click OK.

(Optional) Double-click any data value to display the specific
details that comprise the data. In Figure 17-8, you see the detail
for Sales Rep DML displayed on a separate worksheet. When fin-
ished reviewing the detail data, you can safely delete the sepa-
rate individual worksheet without affecting the PivotTable.

(Optional) Click the down arrow in the Row Labels heading section and choose Label
Filters or Value Filters to further filter your data with a variety of options including
Greater Than, Less Than, or Between. (See Chapter 16.)

A C D
1
3 |Row Label g} of Quantity
4 DML 8805
5 |SDF 8729
6 Grand Total 17534
i
8
9
Figure 17-7
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Figure 17-8
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Sort PivotTable Data

1. In the PivotTable, click anywhere in the field you want to sort.

2. Choose PivotTable Tools Options and in the Sort & Filter
group, click a Sort button. The PivotTable data sorts accord-
ing to your choice. In Figure 17-9, the data is sorted by the
Sum of Quantity, from smallest to largest.

Depending on the data type, the option may say Sort Smallest to Largest or Sort
Ato L

Click the Sort button to display the Sort By dialog box.

Change the Calculation Type

1. In the PivotTable, click anywhere in the subtotaled data field.

2. Choose PivotTable Tools Optionst>Active Fielde>Field
Settings. The Value Field Settings dialog box appears, as
shown in Figure 17-10.

Alternatively, right-dick the subtotaled data field and choose Value Field Settings.

3. From the Summarize Value Field By list, select the function you
want to use. Choices include SUM, COUNT, AVERAGE, MAX,
MIN, PRODUCT, COUNT NUMBERS, STDDEV, STDDEVP,
VAR, and VARP.

4. Click OK. Excel re-summarizes the field based on the func-
tion you selected. The field title also changes to reflect the
selected function.

(Optional) Click the Number Format button and select a format for the
summary field.

If you don't want to display grand tofals at the hottom, choose
PivotTable Tools Design=>Grand Totals=>On for Rows Only in the
Layout group.

1
2
3

6
7
8
9
10
11
12
13
14
15
16
17
18
19
20

Row Labels [.i|Sum of Quantity

| a [Tk
5

SDF
VFK
DML
10M
DMR
TMB
MIB
TMH

Grand Total 79712

A B © D E F G H

8627]
8729
8790
8805
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9004
9004
9078

Figure 17-9
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Format PivotTable Values

Rename a PivotTable Field

1.

In the PivotTable, click anywhere in the field data you want
to rename.

Choose PivotTable Tools Options=>Active Field=>Field
Settings. The Value Field Settings dialog box opens.

Alternatively, dick the field name in the PivotTable and begin typing a new name.
Press Enter when you're finished.

In the Custom Name box, type the new field name. See
Figure 17-11 where I changed the name from Average to
Average Order Amount.

Click OK. Both the PivotTable field and the Field List names
change.

You can't rename a field the same as the original field name. For example, you can’t
change Sum of Quantity to just Quantity. You can, however, add a space at the end of
Quantity, which gives it a unique name.

Format PivotTable Ualues

1.

Highlight the PivotTable cells you want to modify; choose
PivotTable Tools Options=>Active Field=Field Settings.

From the Value Field Settings dialog box, click the Number
Format button.

From the Format Cells dialog box that appears (see
Figure 17-12), select the number format you want.

If applicable, select the number of decimal places you want.
Click OK twice.

To change the format of PivotTable text, select any text cells and format them from
the Home tab. (See Chapters 6 and 7.)

A B ©
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2
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5 DMR 21.14797136
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7 MIB 21.48926014
8 |SDF 20.83293556
9 TMB 21.48926014
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Value Field Settings

(B B3]
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Summarize Values By _Shuw Values As

Summarize value field by
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Sicientific
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Figure 17-12
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Generate Multilevel Totals

1. Create a PivotTable (see the “Create a PivotTable” section,
earlier in this chapter).

2. To create a second summary level, drag the next field you
want to subtotal from the PivotTable Field List onto the
desired PivotTable area, keeping these pointers in mind:

¢ [f you want to create a second category, such as by country and
then by salesperson, drag the field into the Row Labels area
located below the PivotTable Field List. Figure 17-13 shows a
PivotTable with two categories. The field closest to the data is
the inner row (in this example, Document Date). The other
field is an outer row (in this example, Sales Rep). Excel displays
data in the inner row under each of the outer row fields.

¢ If you want to change the order of the inner and outer row
fields, from the appropriate box in the section below the

. . Figure 17-13

Field List, drag the field you want as the outer row to the top g

of the box. gaea e = #
e If you want to total additional fields, drag the field into s 8 @ B B e o

the Values area located below the PivotTable Field List. s T =l '

BT -. .ﬁ... 3333333333 i i i »
You can add even more data fields to your PivotTable. PivotTable data fields are lim- . A i : R P
ited only by the amount of memory in your computer. O WSS W——— e
4 SOML ) 2101 419 - pmsse
5 12/1/2009 26.00 1 P
. . 3 12/3f2009 25.00 3 s Dt
¢ If you want to sum different fields or if you want to create 7| 1 6
. 8 12/5f2009 33.00 1

two different total types (such as Count and Sum, or Max s e 2000 3

and Min), select a field you've used already. Currently e o ]

used fields are listed in bold type. In Figure 17-14, the i Fhpo: : it

order quantities are both averaged and counted by date. IR a2 s :
e Click the minus sign to collapse a row heading, such as a " Wrinyeed i .

particular salesperson’s name. Click the plus sign to . e i .

expand the row again to see all the data. | 1uims i ; .

To change the data source location for the PivotTable, choose PivotTable Tools :

Figure 17-14

Options=>Change Data Source in the Data group. In the dialog box that appears,

enter the new data location.
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Group Data

AutoFormat PivotTables

1.

Choose PivotTable Tools Design and find the PivotTable
Styles group.

PivotTables can also include conditional formatting.

Click the More arrow. A gallery of PivotTable styles appears,
as shown in Figure 17-15.

Select a format. Excel provides 85 predefined PivotTable for-
mats, Or you can create your own format.

To remove the formatting, choose PivotTable Tools Design=>More=>Clear in the
PivotTable Styles group.

To apply a default style for all new PivofTables, choose PivotTable Tools Design, right-
click the style that you want to set as the default, and choose Set as Default.

Group Data

1.

Create a PivotTable (see the “Create a PivotTable” section,
earlier in this chapter).

Click in any cell of the field you want to group. A popular
field to group is a date field.

Choose PivotTable Tools Options=>Group Selection in the
Group group.

From the Grouping dialog box that appears, select the group-
ing option you want to use. The options that appear depend
on the type of data you're grouping.

Click OK. Figure 17-16 illustrates the PivotTable with the
dates per rep grouped by month.

To ungroup categories and redisplay the entire list, choose PivoiTable
Options=>Ungroup in the Group group.

If you need fo change the PivotTable data source, choose PivotTable
Tools Options=>Change Data Source in the Data group and then specify
different cells.
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Calculate a Percent of Totals

1.

Add a second totals field and display the two fields side by
side. (See the earlier section, “Generate Multilevel Totals.”)

Click anywhere in the second totals field and choose
PivotTable Tools Optionsw>Show Values As>% of Column
Total in the Calculations group (see Figure 17-17).

Add Vour Own Calculations

1.

Choose PivotTable Tools Optionst>Fields, Items, & Setst>
Calculated Field in the Calculations group. The Insert Calculated
Field dialog box appears.

In the Name text box, type a name for the formula, such as
CommAmt or ReserveAmt. Calculated field names can't
include spaces and special characters.

In the Formula box, delete the =0 and create your own for-
mula, following these tips:

o Like other Excel formulas, the calculation begins with an
equal sign, but you use field names instead of cell refer-
ences. You can't use cell references in a formula, but you
can use static values.

e Double-click any field name in the Fields box to add it to
the formula.

e Use the standard formula operators, such as plus, minus,
multiply, and divide (+, -, *, and /, respectively).

Click OK. Excel creates a new data column with the calcu-
lated value. Figure 17-18 shows a PivotTable with a calcu-
lated field next to the data field. I've also redisplayed the
Insert Calculated Field dialog box so you can see the formula.

heading out of the Values box located helow the PivoiTable Field List.

S If you no longer want the calculated field on your PivotTable, drag the calculated field
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Rename a PivotTable

Change PivotTable Display Options

1. Click anywhere in the PivotTable and choose PivotTable
Tools Options and find the Show/Hide group.

2. Click any of the following buttons:
e Field List to hide the Field List.

Drag the Field List title bar to undock it and move it anywhere on your screen. While
undocked, you can also resize the Field List by dragging the outer border. Double-click
the Field List title bar fo restore it to a docked position.

e +/- Buttons to hide the summary plus and minus keys that
appear when you have nested rows, such as in the section
“Generate Multilevel Totals,” earlier in this chapter.

o Field Headers to hide the default Row Labels and Column
Labels headers. Figure 17-19 shows both the field headers
and Field List hidden.

Click the options again fo redisplay the tools.

Rename a PivotTable

1. Choose one of the following options:

e Choose PivotTable Tools Options=>PivotTablem>PivotTable
Name and type a name in the text box. (See Figure 17-20.)

e Choose PivotTable Tools Optionst>PivotTable>Options.
The PivotTable Options dialog box appears. In the Name
text box, type a descriptive name for the PivotTable and
click OK.

To move a PivotTable to a new sheet, choose PivotTable Tools Options=>Move
PivotTable in the Actions group. From the Move PivotTable dialog box that appears,
specify where you want fo move the PivotTable.

- I Bockd - Microsoft Excel
Homt kst Pgilapout  Pasmsadsi  Dobi Baiew  Voew | Osbions | Dl

s
K
3

3
g

,
&

elol oo awin- |

16 i 1112%
17, 5 1.18%
18 113%
19 i Lian

20 LEES
0.36% J - i -

21 AT 8 0
WA N Swat? | Sheel? - ety . Shend T b L
R | |t IR e hmrid]

Figure 17-19

Eook3 - Microsoft Excel PirolTable Tools

d9-e-2]-

8 Home Tnsert Page Layout Formulas Data Rewiew  Wiew Qptinns Design

= @y | P Sroup Selection 4] . B Ljﬁ 7 Clear - ® sum
Zv |Z|Aa % e

@ Unaroup Ed Select v * Sho

PiuntTable Active Z| Sort | Insert Refresh Change Data | _,
- Field | B3] Group Field i By~ - source~ | b8 Move PivotTable | [i] Field
I | Group | Sort & Filter | Data | Actions | C
= Bpibien s - = F3 ‘ 43,72
Sales by Rep
B c D E F

FivotTable

Figure 17-20

175



Chapter 17: Creating PivotTables

176

Create a PivotTable Formula List

Click anywhere in the PivotTable.

Choose PivotTable Tools Options=Fields, Items, & Setse>List
Formulas in the Calculations group. Excel adds a new work-

sheet to the workbook, as shown in Figure 17-21, displaying
all the calculated fields.

You'll find this helpful if you've used calculated items and calculated fields in your
PivotTable.

Reorder PivotTable Fields

Make sure the PivotTable Field List pane appears on your
screen (choose PivotTable Tools OptionstField List in the
Show/Hide group).

From the Areas section of the PivotTable Field List pane, locate
the section you want to rearrange and click the field you want
to move. A menu appears, as shown in Figure 17-22.

Choose one of the following:
e Move Up: Moves the selected field left one column.
e Move Down: Moves the selected field right one column.

e Move to Beginning: Moves the selected field to the top of
the list making it the first field on the PivotTable.

e Move to End: Moves the selected field to the bottom of
the list making it the last field on the PivotTable.

A B I D E F
1 |Calculated Field !

2 Solve Order Field Formula

3 1Reserve  =Quantity*® 12%

4 2 Remainder =Quantity-Reserve
5

6 Calculated item

7 Solve Order Item Formula

10 |Note: When a cellis updated by more than one formula,
1 the value is set by the formula with the last solve order.

13 To change the solve order for multiple calculated items or fields,

14 on the Options tab, in the Calculations group, click Fields, Items, & Sets, and then click Solve Order.

Figure 17-21
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Add a PivotTable Slicer

Add a PivotTable Slicer e S,

L on
1. Click anywhere in the PivotTable and choose PivotTable —
Tools Optionse>Insert Slicer in the Sort & Filter group. The

Insert Slicers dialog box appears. g i
2. Choose the field you want to use and click OK. The slicer box :
appears with all available values for the field you selected. ¢
Figure 17-23 shows the slicer for the PivotTable field :
Location Code. This field has only three values; SR1, SR21, 10
and SR34. T
13
You can drag the slicer box anywhere on your screen. i

3. Click a value or hold down the Ctrl key and select multiple rera Sao e S I
values. Excel filters the PivotTable to reflect only the option Figure 17-23
you selected.

¥ -0
Click the filter icon at the top right of the slicer box to clear all filfers. h- o,

4. Click the Slicer Tools Options tab. The tab displays many
options for the slicer box including a name for the slicer and
formatting style and size options.

SR1

5. In the Slicer group, choose Slicer Settings. The Slicer Settings

dialog box appears, as shown in Figure 17-24. 10
11 i
6. Change any desired settings and click OK. S
Figure 17-24

To delete a PivotTable slicer, right-click the PivotTable slicer and choose Remove.
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Create a PivotChart

1. Create a PivotTable (see the earlier section, “Create a
PivotTable,” in this chapter).

2. Click anywhere in the PivotTable. Choose PivotTable Tools
Options=>PivotChart in the Tools group. The Insert Chart dia-
log box appears.

3. Select a chart type and click OK. As shown in Figure 17-25,
Excel automatically creates a chart from your PivotTable. All
PivotTable data, except for the totals and subtotals, appear in
the PivotChart.

Changes to the PivotTable affect the PivotChart, and field changes to the PivotChart
affect the PivotTable.

4. Format the chart (see Chapter 12) with the following
exceptions:

® You can’t move or resize the plot area.

e You can’t add data to the PivotChart from outside the
PivotTable.

e PivotCharts can’t be scatter, bubble, or stock types.

® You can click the Axis Fields drop-down list to filter the
row headings you want to use. See Figure 17-26.

To delete the PivotChart, select the chart boundaries and press the Delete key.

To convert the PivotTable to standard data that you can use to create a standard (non-
PivotChart) chart, select the PivotTable report data that you want to use and choose
Home and in the Clipboard group, choose Copy and then choose Pastec>Paste Values
to duplicate the data to a blank area of the workbook. You can then create a standard
chart of your choosing.
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Building Simple
Macros

ou can often save yourself time by automating tasks you perform fre-

quently. The automation takes the form of an Excel macro, which is a
series of commands and functions grouped as a single command. Macros
are created in a special programming language — Visual Basic — and can be
run whenever you need to perform the task.

Although you can write your own very complex macros in the Visual Basic
programming language, the easiest method for creating many macros is to
use the Excel Macro Recorder. When you record a macro, Excel stores infor-
mation about each step you take as you perform a series of commands. You
then run the macro to repeat, or play back, the commands.

The Macro Recorder is very literal and records every action you complete.
Therefore, planning your macro before you begin the recording process is
very important so you don't record unnecessary steps.

Security is an important issue when working with macros. If you open work-
sheets containing macros from outside sources, these macros can be harmful
to your computer. By default, Excel protects you from running macros, but if
you're creating your own macros, you'll probably change these protective
security settings.

In this chapter, you find out how to record, run, and delete Excel macros as
well as change your security settings.

I“*napter

Get ready to.

w= Record a Macro

= Assign a Macro Keystroke........................
w= Open a Macro-Enabled Workbook............
= Save a Macro-Enabled Workbook.............

w= Run a Macro

= Check Macro Security Level......................
= Add a Macro Button fo the

Quick Access Toolbar

w= Delete a Macro
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Chapter 18: Building Simple Macros

Record a Macro

1. Choose ViewroMacrosvRecord Macro. The Record Macro dia-
log box, as shown in Figure 18-1, appears.

2. Type a name for the macro. The first character of the macro
name must be a letter, and the name can’t contain spaces or
cell references. Macro names aren’t case-sensitive.

3. From the Store Macro In drop-down list, choose where you
want to store the macro:

Figure 18-1
e This Workbook: Save the macro in only the current work-
book file. e o @ o @ ®
e New Workbook: Create macros that you can run in any = =N = F =
new workbooks created during the current Excel session. U Zo0MD | e eze panes e D Unite | B | yrosreace e, , | 2%
. . . oom AN o IE iew Macras
e Personal Macro Workbook: Choose this option if you T
want the macro to be available whenever you use Excel, H ) K L 8| [ Lse Relative References
regardless of which workbook you're using.
4. (Optional) Type a description for the macro in the Figure 18-2

Description text box.
Click OK. The Record Macro option starts recording.

6. Perform the actions you want to record. Excel records your
keystrokes as you type. Actions can include typing into cells,
selecting, inserting, deleting, or even formatting cells. Macro
actions can include almost anything you do in Excel.

Excel records your steps exactly — such as select cell (3 — but you can also record the
steps relative fo any current cell — such as go up one row and insert a blank line. To do so,
choose View=>Macros=>Use Relative References. You can turn the Relative References
function on and off as often as you need to when recording the macro.

7. Choose View>Macros=Stop Recording. (See Figure 18-2.)

Alternatively, dick the Stop Recording button on the left side of the status bar.
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Open a Macro-Enabled Workbook

Assign a Macro Keystroke

1. Choose ViewroMacrosvRecord Macro. The Record Macro dia-
log box appears.

In the Macro Name text box, type a name for the macro.

From the Store Macro In drop-down list, choose where you
want to store the macro.

4. (Optional) In the Description box, type a description of the
macro.

5. Assign a keystroke combination (see Figure 18-3). If you
select a shortcut key used already in Excel, the macro shortcut
key overrides the Excel shortcut key while the workbook that
contains the macro is open. Click OK.

If you enter a lowercase letter, Excel assigns it a Ctrl+lowercase-letfer combination. If
you type an uppercase letter, you must press Cirl+Shift+the letter to run the macro.
The shortcut key can't include a number or a special character.

6. Perform the actions you want to record.

7. Click the Stop Recording button on the status bar or choose
Views>Macros=Stop Recording.

8. To execute the macro, press the shortcut key you assigned or
choose the macro from View=>Macros.

Open a Macro-Enabled Workbook

1. Open a workbook containing a macro. The workbook opens
as usual, but a Security Warning message appears below the
ribbon. See Figure 18-4.

2. Click the Enable Content button. The Security Warning mes-
sage closes.

Record Macro 7 ==
Macro name:
MonthNames
Shorteut key:
CrheShife+ | M
Store macrn jn:
This Workbook E|
Descripkion:
Records names of the months
Figure 18-3
=] =Nk Sales - Microsoft Excel
Home Tnsert Page Layaut Farmulas Data Rewiew | ‘Wiew
j ;HI Page Break Preview uler Formula Bar _“; ] | EE Newwindow [ Spii
T3 Custom Views e = trange 4l 7 Hid)

nMormal| Page
Layout (B Full Sreen

Warkbook Wiews

Zoom  100% Zoomto
Selection
Zoaom

v Fl i
Gridlings Headings B8 Freeze Panes ~ [ Un

Shawy

Al -

1) Security Wamning  Macros have been disabled.

Enable Content

f

A B
January
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7/ Tom
8 Mark
9 Susan
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11 Terri

12 Danny
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Figure 18-4
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Save a Macro-Enabled Workbook

1. Create a workbook with a macro; then choose Filew>Save As.
The Save As dialog box appears.

Enter a name for the workbook and select a location for it.

Click the Save as Type drop-down arrow. A list of file types
appears.

4. Choose Excel Macro-Enabled Workbook. (See Figure 18-5.)
Excel adds the .xIsm extension to the filename.

5. Click the Save button.

S If you neglect to save the workhook as a macro-enabled workbook, you see the warn-

ing message telling you that the macro won't be refained. Figure 18-5

Run a Macro

1. Choose Viewt>Macros. The Macro dialog box, as shown in
Figure 18-6, appears.

It's a good idea to save your file before running a newly created macro. Excel can't
undo the steps taken by the macro.

2. Select the macro you want to run and then click the Run
button. Excel executes the selected macro.

S (Optional) Press the shortcut key combination you assigned fo the macro.

Figure 18-6
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Add a Macro Button to the
Ouick Access Toolbar

1.

Click File and choose Options. The Excel Options dialog box
appears.

Click the Quick Access Toolbar tab and then from the
Choose Commands From drop-down list, choose Macros. A
list of available macros appears.

Select the macro you want displayed on the Quick Access
toolbar and then click the Add button. An icon is added to
the right list.

Click the newly added macro command and then click the
Modify button. The Modify Button dialog box, as shown in
Figure 18-9, appears.

Choose an icon to represent the macro and then click OK twice.
Excel displays a macro button in the Quick Access toolbar.

To run the macro, click the button on the Quick Access toolbar.

Delete a Macro

1.

Open the workbook containing the macro you want to delete.
Choose View>Macros. The Macro dialog box appears.

From the Macro dialog box, select the name of the macro you
want to delete and then click the Delete button. A confirma-
tion box appears (see Figure 18-10).

Click the Yes button.

Deleting a macro doesn't remove the button you placed on the Quick Access toolbar.
To delete a button from the Quick Access toolbar, right-dlick the macro icon and
choose Remove from Quick Access Toolbar.
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Chapter 19: Collaborating in Excel

Add Comments

1. Click the cell on which you want to comment.

2. Choose Reviewr>New Comment in the Comments group. A
yellow comment box with your name and a blinking cursor
appears.

With the comment hox open, you can drag the lower-right corner of the comment box
to make it larger.

3. Type your comment. Comments can be up to 32,767 charac-
ters in length.

4. Click a cell other than the commented cell. Excel accepts the
comment and displays a triangle in the upper-right corner of
the commented cell. See Figure 19-1.

Point at the comment triangle to display the actual comment fext.

Each cell can have a comment, but only one comment per cell is permitted.

Edit Comments

1. Select the cell with the comment you want to edit.

2. Choose Review=>Edit Comment in the Comments group. The
comment box reopens for editing, as shown in Figure 19-2.

To delete a comment, choose Review=>Delete Comment in the Comments group.

188

3. Make any desired changes and then click any other

cell

to close the comment box.

To manage how Excel prints comments, dick the Page Layout tab and then
click the Page Setup dialog box launcher. From the Page Setup dialog hox,
click the Sheet tab and choose an option from the Comments drop-down list.
You can print comments as they're currently displayed on the sheet, or you
can print all comments in a list on a separate page.
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Figure 19-1

Figure 19-2
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Chapter 19: Collaborating in Excel

Tr ac k Ch an q es 5. Make a change in any cell. Modified cells display a

border around the changed cell with a triangle in

1. Choose ReviewsTrack Changese>Highlight Changes in the the upper left corner of the cell.

Changes group. The Highlight Changes dialog box opens, as

S 8IC Each user that opens the workbook must activate revision tracking for
shown in Figure 19-5.

his changes to be marked.

2. Select the Track Changes While Editing check box. This auto-
matically creates a shared workbook file if you haven't
already activated the Share Workbook feature.

3. Select any desired options:

e When: Select the default of All or choose Since I Last
Saved, Not Yet Reviewed, or specify a date.

e Who: Choose from specific users currently using the work-
book, Everyone, or Everyone But Me.

e Where: Specify a range in the workbook to track. If this

option is left blank, Excel tracks the entire workbook. Figure 19-5
e Highlight Changes On Screen: When selected, modified
cells have a triangle in the upper-right cell corner. Hover o = e : T T e
the mouse pointer over the triangle to review the change TR T T T T M TS S
/307" : iahe ell Change Income-Budget ,800. f
and who made it. v oo ot ouw ek o joutt] e
. . . 5 4 1/30/2010 2:40PM Diane  Cell Change Income-Budget B15 13,069.11 1106911
° |_|St Changes on a NeW Sheet When thlS is Selected, EXCQ] 6 5 1/30/2010 2:40PM Diane Cell Change Income-Budget D19 500 0
. . . . 7 6 1/30/2010 2:40PM Diane  Cell Change Income-Budget D13 1,000.00 ]
adds a Speclal hlstory Worksheet ln the Workbook fOI' Vlew- i 7 1/30/2010 2:40PM Diane  Cell Change Income-Budget D8 5,800.00 7,800.00
ing eaCh edlt il’lcludil’lg the detail, authof, date, and tlme 10 | The history ends with the changes saved on 1/30/2010 at 2:40 PM.
. . 11
See an example in Figure 19-6. 2
13
14
When you save the workbook, Excel deletes the history sheet. =
5
19
20
21
22
4. Click OK. You may be prompted to save your workbook. If CRENINESTY o ool o D1
so, click OK again. Excel activates its tracking feature and Figure 19-6

highlights any changes in the worksheet with a colored trian-
gle in the upper-left corner of edited cells along with a col-
ored border around the cell.
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Accept or Reject Changes

e A B C D E F G H
Accept or Reject Changes : A L v
2 Income/Budge cnang:mrm;m to tmsd:mment ]
3 1st Quar| [pne, 1/30/20102:40 P .
1. Save the workbook. If you don’t save the workbook, Excel a peay || H
. 5 Revenues
prompts you to save it when you proceed to Step 2. o i s__mm -
[ 2] sles -y i
Excel notes each user’s revisions with a different color. 10 s Eonien Ta aek mmm e
11 | Sales - Hand Tools 7,05812 24% 8750.00 (1,69188)
12 | Sales - Landscape Services 16,977.53 5.8% 18,500.00 (1,522.47)
10 e Twey VT AR ¥4 S 1t
15 Sales- Pots 13,069.11 45% 8,300.00 476911
16  Sales - Seeds 8,661.39 3.0% 6,800.00 1,861.39
2. Choose ReviewroTrack Changes=>Accept/Reject Changes in 36| Ot it T T I AR5 0000
the Changes group. The Select Changes to Accept or Reject TR — Do (0000 —
dialog bOX appears 21 Total Revenues 291,687.48° 100.0% 291,450.00 237.48
* 22
3. Select which changes you want to review and then click OK. Figure 19-7
The Accept or Reject Changes dialog box, as shown in Figure
19'7, appeal‘s Wlth the ﬁI‘St Change. Accept or Reject Changes -] ==a)
Select a value for cell B7:
4. Click one of the following buttons: o555 (o el 7
52,562,856 (O|IEISI’ Joh{vﬂssourl\izlé:;gp’fg15%)14:53)
9,252,602.86 (Diane 3
e Accept: Keeps the change and removes the revision
marker. Excel then locates the next changed cell.
e Reject: Returns the changed cell to its previous value and ncceptal | [Lrercal | [ i
removes the revision marker. Excel then locates the next -
changed cell. Figure 19-8
e Accept All: Accepts all changes and removes the revision
indicators.

e Reject All: Returns all changed cells to their previous val-
ues and removes the revision indicators.

e Close: Makes no changes and cancels the change review.

5. If a cell has conflicting changes from multiple users, Excel
displays the dialog box shown in Figure 19-8. Excel displays
the original cell value and the value added by each user.
Select the change you want and then click the Accept button.

191



Chapter 19: Collaborating in Excel

Merqe WOrkbooks @Selem Files to Merge Into Current Workbook ==

—
OU ‘L_.!l » Comp.. b Public fABeta\c\sers) ) » hd |ﬁy ‘ | Search Pustic fhBetalclusers) @ £ |

1. From a shared workbook, choose File>Save As. Save a copy 2T e -0 @

for each user. (] Micresoft Bxcel ) Fgures

Ry Wirtual Machines

w Faworites PowerPoints

2. Allow each user to make changes to their own workbook version.

Bl Desktop (}iPublic Dacuments
J8 Downloads | Public Downlaads
Be sure each user saves her changes before you merge workbooks. ] recent Praces = Epubicmusic

Frublic Pictures

Ml Desktop
B Libraries Brublicvideos
3 Documents @ABC Landscaping Income vs Budget 2.,
o Music — Eepn
3. Open one of the workbook copies and make sure Track [ Pictures Eincame vs Budget 15t Qfr 2010 Diane
. . 1 ” . . E Videos @Income ws Budget 15t Qtr 2010 Oliver
Changes is activated. (See the “Track Changes” section, earlier B isne
in this chapter.) 1% Computer ]

File name: Income vs Budget 1st Qtr 2010 Oli [Ex:equrkhuuk ']

4. Add the Compare and Merge Workbooks command to the
Quick Access toolbar. (Choose File=>Options. The Excel roots = |0k I

Options dialog box appears. Click the Quick Access toolbar
section. Locate and choose Compare and Merge Workbooks;
click the Add button; then click OK\)

Figure 19-9

v W s

The Compare and Merge Workbooks command is listed under the category Commands _ Y EEED o G B
Not on the Ribbon. e el 1] " S SR —
1 E;HB(: Landscaﬁing :
5. Click the Compare and Merge Workbooks button from the Quick ' . -cwsien
Access Toolbar. Excel may prompt you to save the workbook. : -

Actual Incame Ratie Budget

6. The Select Files to Merge into Current Workbook dialog box
opens, as shown in Figure 19-9.

7. Navigate to the folder containing the workbooks you want to
merge and click the filenames you want to merge.

To click multiple files, press and hold the Ctrl key while clicking filenames.

16 TOTAL REVENUES

20 | COST OF GOODS SOLD

8. Click OK. Excel merges all the workbooks into one. In
Figure 19-10, Excel incorporates other users’ data into the
workbook and marks changes with revision mark indicators.
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Copy Excel Cells into Word

1. From the Excel worksheet, highlight the cells you want to copy
into a Word document; then copy them. (See Chapter 2.)

2. Open or create the Word document in which you want to
place the Excel cells. Make sure the blinking cursor is at the
location where you want the cells; then paste the informa-
tion. (See Chapter 2.) Excel pastes the cells into a Word table.
Figure 20-1 shows both the Excel worksheet and the new
Word table.

®

The Word table includes any Excel formatting such as column width, font, color, and
border style; however, the Word table and the Excel worksheet aren’t linked. Any
changes made to one don’t appear on the other.

3. Modify the Word table using any of the following:

Replace any cell value: Highlight any existing text in a cell
and type the replacement text.

Delete a column or row: Click in a cell of the column
or row you want to delete and then choose Table Tools
Layout=>Deleter>Delete Columns (or Delete Rows) in the
Rows & Columns group.

Insert rows or columns: Click in a table cell where you
want to insert the new row or column, and then choose
Table Tools Layout and in the Rows & Columns group,
select Insert Above, Insert Below, Insert Left, or Insert Right
button.

Widen a column: Click a cell in the column you want to
widen and then choose Table Tools Layout and in the Cell
Size group, change the width until the column is the width
you want.

Delete the table from the Word document: Click any-
where in the table and choose Table Tools Layout=>
Deleter>Delete Table in the Rows & Columns group.
(See Figure 20-2.)

Figure 20-1

Figure 20-2



Edit an Inserted Worksheet

Insert a Saved Excel Worksheet into Word

1. In a Word document, position the insertion point where you
want the worksheet to appear; then choose Insert=>Object in
the Text group. The Object dialog box opens.

2. From the Create from File tab, click the Browse button; then
locate and click the Excel file you want to include in your
Word document.

3. Click the Insert button. The Object dialog box reappears with
the path and filename you selected in the File Name text box.
(See Figure 20-3.)

4. Click OK. The Excel workbook appears as a Word table. The
cells in the Word table contain the same formatting as the
Excel workbook.

Even if your worksheet contains multiple sheets, only the fop sheet with all the cells con-
taining data appears. You can't specify a particular range of cells. If you want to insert
an Excel chart, save the workbook with the chart sheet on top before inserting into Word.

Edit an Inserted Worksheet

1. Click once in the Word table and perform one of the follow-
ing actions:

e DPress Delete to delete the table.
e Drag one of the handles to resize the table.

e Double-click the table to edit the actual values. The Excel
Ribbon appears, along with column headings, row numbers,
and any formulas you created in Excel. (See Figure 20-4.)

Any changes you make are saved in Word only, not in the original Excel workbook.

2. Click outside the table to deselect it.

Object

File name:

Result

Create from File

==

C:\Users|DianelDocuments 1st gty sales sdsx]

Inserts the contents of the file into your
document so that you can edit it later using the
application which created the source file,

Browse. .

[ Link o File
[ Display a5 icon

Figure 20-3
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Subject: 1% Chuar ter Sales
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) 3 o £
1 Sales by Color
Fiest Quarter 2010
. January February  March Totals
4 Color 3,094 3,269 4,809 1l
F 6173 3,511 4,173 13,857
& Blue 6,704 4,820 5,261 16,785
6,206 3,208 5107 1511
8| Purple 6,039 3,562 3922 13,523
3,294 4,308 4,642 13,244
10 Torals 31,510 22,678 28,514 £2,707 =
oAb N heet) s | et T ¥

o Bl M

Figure 20-4
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Create a Word Mail Merge Form
Letter Using an Excel List

1. Create and save an Excel worksheet with the data you want to
merge in an Excel list. The Excel worksheet doesn’t need to be
open.

The data will be easier for you to identify later if it has column headings. If you're
merging names, you might want to list the first name and the last name in separate
columns.

2. In Word, with a blank document onscreen, choose Mailings=
Start Mail Merge=>Step by Step Mail Merge Wizard. The Mail
Merge task pane appears on the right side of your screen.

3. Select the Letters option (see Figure 20-9) and then click the
Next: Starting Document link.

4. Choose whether to create the mail merge from the current
Word document or from another existing Word document;
then click the Next: Select Recipients link.

5. Select the Use an Existing List option and then click the
Browse button. The Select Data Source dialog box appears.

6. Locate and double-click the Excel file containing your list.
The Select Table dialog box opens, as shown in Figure 20-10.

7. Select the range name, sheet name, or area containing data.

If the first row of your list doesn't contain headers, deselect the First Row of Data
Contains Column Headers check box.

8. Click OK. A Mail Merge Recipients list containing your data
appears.

9. Remove the check mark next to any record that you don't
want to include and then click OK.

198

(Optional) Click the Clear All button to dear all the check marks or click
the Select All button to check all the records. Click the arrow next to
any heading fo sort the data.

il Merge v X

Select document type

‘what bype of document are you
working on?

@) Letters

() E-mail messages
() Enwelopes

() Labels

() Direckary

Letters

Send letters to a group of
people. You can personalize the
letter that each person receives,

Click Mext bo continue,

Step 1 of 6

& [ext: Starting document

Figure 20-9

Select Table e

Mame Description  Modified Created

1/30{2010 4:01:20 P 1/30/2010 4:01:20 PI
Januaryd_xinm#_FilkerDatabase 113002010 4:01:20 PM 1j30/2010 4:01:20 P1
Sheetzd 1/30/2010 4:01:20 PM 14302010 4:01:20 P
Sheet3h 1/30/2010 4:01:20 M 1/302010 +:01:20 P1

4 1} | +

First raw of data contains column headers

Figure 20-10



Create a Word Mail Merge Form Letter Using an Excel List

10.
11.

12,

13.

14.

15.

Click the Next: Write your letter link.

Type the form-letter document, leaving blanks where you
want the variable (such as name, address, phone number, or
product) information to appear. See Figure 20-11.

Click the insertion point at the first location where you want
the variable information (such as the recipient name and
address location).

From the task pane, select the desired option:

e Address Block: Displays the Insert Address Block dialog
box from which you can select an address layout. (See
Figure 20-12.)

e Greeting Line: Displays the Greeting Line dialog box,
which inserts a greeting of your choice along with the
recipient’s first name (if you have such a field in your
database) followed by a comma or colon.

e Electronic Postage: Prints electronic postage on your enve-
lopes if you subscribe to an electronic postage service, such
as Stamps.com

e Postal Bar Code: Prompts you for the zip code field from
your Excel list and then inserts a bar code matching the
zip code field.

e More Items: Displays the Insert Merge Field dialog box,
which displays each field listed in your Excel list. Click the
field you want to insert into Word and then click the
Insert button.

Click the Next: Preview Your Letters link. The document you
created appears with the first data record from your Excel list.

Click the Next: Complete the Merge link. You can now print
your form letters.

To edit a specific letter, click Edit Individual Letters link. To make a change to the mas-
ter document, click the Previous button until you get to Step 4 and then make any
desired changes. Click Next again unfil the merge is completed.

Figure 20-11

Insert Address Block
Specify address elements

Insert recipient's name in this Format:

Josh -

Josh Randall Ir. a
Josh Q. Randall Ir, -
3

Insert comparry name
Insert postal gddress:
NMever include the country/region in the address
Ahways include the country/region in the address
@ only include the country/region if different than:

United States

Format address according to the destination country/region

L =)
Fravisw
Here is a preview From your recipient list:
! PR ]
Ron Abboud
Abboud Chamicals

1000 W, Oak Street
Atlants, GA 30080

Correck Problems

IF items in your address block are missing or out of order, use
Match Fields to identify the correct address elements from your

mailing list.
Match Fislds. ..

Figure 20-12
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Make Mailing Labels with Word and Excel

1.

10.

11.

12,

Create and save an Excel worksheet with the data you want to
merge in an Excel list. The Excel worksheet doesn’t need to be
open.

In Word, with a blank document onscreen, choose
Mailingse>Start Mail Merger>Labels. The Label Options dialog
box appears, as shown in Figure 20-13.

Choose the label manufacturer and size you're using, and
then click OK. You see a blank document onscreen.

Choose Table Tools Layout=>View Gridlines in the Table group.

Choose Mailings=>Select Recipients=>Use Existing List in the
Start Mail Merge group. The Select Data Source dialog box
opens.

Locate and double-click the Excel file containing your list.
The Select Table dialog box opens.

Select the range name, sheet name, or area containing data
and click OK.

On the first label, choose Mailings=>Address Block in the
Write & Insert Fields group. The Insert Address Block dialog
box appears.

(Optional) Choose Insert Merge Field and select the individual field you want to use.

Choose the address block format you want to use and click OK.

Choose Mailings=>Update Labels in the Write & Insert Fields
group. The fields you inserted appear on each label.

Choose Mailings=>Preview Results in the Preview Results
group. You see the labels as they’ll print. See Figure 20-14.

Choose Mailings=>Finish & Merge in the Finish group. You can
then choose to edit the individual labels or to print them.

Lahel Options
Prinker information

() Continuous-Feed printers

Label information

Label vendors: | Awery US Letter

Find updates on Office Online
Product number:

[]

5159 Mailing Labels

5160 Easy Peel Address Labels
5161 Easy Peel Address Labels
5162 Easy Peel Address Labels
5163 Shipping Labels
5164 Shipping Labels

@) Page printers Tray: |Default tray { Automatically Select) EI

Label infarmation

Type: Easy Peel Address Labels
Height: 1"

width: 4"

Page size: 8.5" % 11"

Figure 20-13
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Blending Excel and
PowerPoint

One of the most common ways to make others aware of your work is by
giving a presentation. The Microsoft Office product PowerPoint is one
of the most effective presentation products available in today’s market. And
because PowerPoint is part of the Microsoft Office suite, you can easily inte-
grate information from other Office applications (in this example, Excel)
into a PowerPoint presentation.

My mother always told me to do things right the first time. If you already
spent the time and energy to create information in Excel, why should you
have to recreate it in your PowerPoint presentation?

That's what this chapter is about. You discover how to take the powerful
worksheet data or creative chart that you created in Excel and copy it to a
PowerPoint slide. You can simply copy your data or chart once from Excel
to PowerPoint, or you can create a link so that if the data in Excel changes,
your PowerPoint presentation automatically reflects the changes. That's
doing it right the first time . . .

I“*napter

Get ready to. . .

= Copy Excel Cells into a
PowerPoint Slide

w= Drag an Excel Table info a
PowerPoint Slide

w= [nsert a Saved Excel Worksheet or

Chart onto a PowerPoint Slide.............

w= Link an Excel Worksheet info a

PowerPoint Slide

= Add an Excel Chart to a
PowerPoint Slide

202
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204

205
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Chapter 21: Blending Excel and PowerPoint

Copy Excel Cells into a PowerPoint Slide

1. From the Excel worksheet, highlight the cells you want to
copy into a PowerPoint slide and choose Homer>Copy in the
Clipboard group or press Ctrl+C. A marquee appears around
the highlighted cells. (See Figure 21-1.)

2. Open or create a PowerPoint presentation. Make sure you
display the slide on which you want to paste the cells.

3. Choose Homer>Paste in the Clipboard group or press Ctrl+V.
Excel pastes the cells into a PowerPoint table.

The PowerPoint table and the Excel worksheet aren’t linked. Any changes made to one
aren't reflected in the other.

4. Modify the PowerPoint table using any of the following methods:

e Replace any cell value: Highlight any existing text in a cell
and type the replacement text.

e Delete a row: Click in the row you want to delete, right-
click, and choose Delete Rows.

Alternatively, drag across the row fo highlight it first, right-click, and choose
Delete Rows.

e Delete a column: Highlight the column you want to
delete, right-click, and choose Delete Columns.

e Change a column width: Position the mouse pointer at
the boundary line (as shown in Figure 21-2) to the right of
any column and drag to the left or right.

e Resize the table: Position the mouse pointer over a table
handle and drag to the desired size.

e Move the table: Position the mouse pointer over an edge,
but not a handle, of the table boundary box and drag to

the desired location.
202
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Page Layout
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Drag an Excel Table into a PowerPoint Slide

Drag an Excel Table into
a PowerPoint Slide

1.

Open both the PowerPoint presentation you want to use and
the Excel workbook. Make sure to display the PowerPoint
slide you want.

Resize and arrange the PowerPoint and Excel windows so
that both are visible at the same time. Use either of the fol-
lowing methods:

e Right-click a blank area of the Windows task bar and
choose Show Windows Side by Side.

¢ Click the Restore button in each window so they're no
longer maximized and then drag the window borders to
resize them. Drag the title bars to move them until both
windows are the desired size and in the correct location.

Select the Excel data you want to copy.

Position the mouse pointer around the outside border of the
selected Excel data and drag the data from the Excel window

until it's on the PowerPoint slide. As you drag the mouse, the
pointer changes to a small box, as shown in Figure 21-3.

Release the mouse button. The Excel data appears on the
PowerPoint slide.

Maximize the PowerPoint window to restore it to full screen.
You can then format, resize, or edit the data as desired. See
Figure 21-4.

To delete the table from the slide, click once fo select the table object (the table object
boundary has gray boundary edges) and then press the Delete key.
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Insert a Saved Excel Worksheet o
or C h art onto a ’90 We r Po i nt S { i de @ creste from e | CsersDianeiDocumentsinycar s | el

-ﬁrowse... Link

Display as icon
1. In a PowerPoint presentation, display the slide where you

want the worksheet or chart to appear. Result
~ Iy Inserts the contents of the file as an object into your
. . ot oo ecivate R using the
Before proceeding, if you want to copy a chart onto the slide, make sure to save the " ‘
Excel workbook with the chart sheet as the top sheet. If your workbook contains mul-
tiple worksheets, only the top sheet appears in the PowerPoint slide. Figure 21-5

2. Choose Insert>Object in the Text group. The Insert Object
dialog box opens.

Click to add title

3. Select the Create from File option and then click the Browse
button. The Browse dialog box opens.

4. Locate and double-click the Excel file you want to include in
your PowerPoint presentation. The Insert Object dialog box
reappears and the path and filename you selected appears in
the File text box. See Figure 21-5.

5. Click OK. As shown in Figure 21-6, the Excel workbook or
chart appears on the current PowerPoint slide.

6. Modify the PowerPoint table or chart with any of the steps
from the section, “Copy Excel Cells into a PowerPoint Slide,
earlier in this chapter, or by using any of the following:

”

e Click once on the PowerPoint object. Eight selection han-
dles appear around the table. Drag one of the handles to
resize the object. Figure 21-6

e Double-click the table or chart to edit the actual values.
The Excel Ribbon appears along with column letters and
row numbers. The worksheet includes any formulas you
created in Excel.

7. Click the slide background to return to PowerPoint and
deselect the object.
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Link an Excel Worksheet into a PowerPoint Slide

Link an Excel Worksheet
into a PowerPoint Slide

1.

Open the desired Excel file. When creating a link, the origi-
nating Excel file must be a previously saved file.

Select the portion of the worksheet you want to duplicate in
PowerPoint and then choose Home=>Copy in the Clipboard
group or press Ctrl+C.

Display the PowerPoint slide on which you want to create
the link and then choose Home and in the Clipboard group,
click the Paste arrow and choose Paste Special, which dis-
plays the Paste Special dialog box, as shown in Figure 21-7.

Select the Paste Link option and then select Microsoft Excel
Worksheet Object.

If you select the Display as Icon check box, instead of displaying the linked object as a
table or chart, PowerPoint inserts an Excel icon onto the slide. Double-clicking the icon
opens the workbook in Excel; however, the Excel program must be installed on the
computer trying o open the workbook.

Click OK. The pasted and linked Excel data appears as an
object on the PowerPoint slide.

The PowerPoint table is linked to the original Excel work-
book. You can cause any changes made in the Excel work-
book to be reflected in the PowerPoint presentation by using
any of the following methods:

¢ With the PowerPoint presentation already open, right-click the
PowerPoint table and choose Update Link. (See Figure 21-8.)

e Double-click the PowerPoint table to launch the Excel pro-
gram and open the linked workbook. Make any changes in
Excel, and the PowerPoint table updates automatically.

When you reopen the PowerPoint presentation, a Security
Notice dialog box displays prompting you to update PowerPoint
from the original Excel file. Click the Update Links button to
update PowerPoint.

Paste Special

Source:  Microsoft Excel Worksheet
Sheetl IRICLRISCS

s

Wicrosoft Excel Worksheet Object
i Atkach Hyperlink

Result

3 Inserts a picture of the clipboard contents into yaur
—'@ presentation. Paste Link creates a shorteut to the
source file so that changes to the source file will be
reflected in your presentation,

|

Display as icon

Figure 21-7

Figure 21-8
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Add an Excel Chart to
a PowerPoint Slide

1.

Open the desired Excel file containing a chart; then select the
chart you want to duplicate in PowerPoint.

Choose Homer>Copy in the Clipboard group or press Ctrl+C.

Display the PowerPoint slide on which you want to create
the link and then choose Home. In the Clipboard group,
click the Paste arrow and choose Use Destination Theme &
Link Data. Live Preview displays the chart on the slide. See
Figure 21-9.

The PowerPoint chart object is linked to the original Excel
chart. Update the PowerPoint slide chart by using any of the
following methods:

e With the PowerPoint presentation already open, choose
Chart Tools Designt>Refresh Data in the Data group.

e Double-click the PowerPoint chart to launch the Excel pro-
gram and open the linked workbook. Make any changes in
the Excel data, which updates the Excel chart, and the
PowerPoint chart updates automatically.

When you reopen the PowerPoint presentation, a Security
Notice dialog box displays prompting you to update
PowerPoint from the original Excel file. (See Figure 21-10.)
Click the Update Links button to update PowerPoint.

Figure 21-9

Microsoft PowerPoint Security Notice

(B8 =)
@ Microsoft Office has identified a potential security concern.

This presentation contains links ko other files,

« IF you update the links, PowerPaint will sttempt: to retrieve the latest
information,

 If you don't update the links, PowerPoint will use the previous information,
MNote that file links can be used ko access and share confidential information
withaut your permission and possibly perform other harmful actions. Do not
update the links if wou do not trust the source of this presentation.

More information

Figure 21-10




Using Excel
with Access

you can share data between Access and Excel in many ways. You can
copy data from an open worksheet and paste it into an Access data-
sheet, import a worksheet into an Access database, or simply load an Access
datasheet into Excel by choosing External Datam>Excel in the Export group.

This chapter shows you how you exchange data between Access and Excel
through these processes:

== Importing: Creates a copy of an Excel spreadsheet in Access format.

w= L inking: Connects an Access table to an Excel worksheet so that you
can view and edit the data in both the original program and in the
Access file. Linking is useful when Excel data must be shared between
Excel and Access users.

Entire books are written about using Access, so this chapter assumes you
already know about general database terms, such as records, fields, tables,
queries, and primary keys. I also assume you know the basics of creating
and using an Access database. (If you need help with Access, see Access 2010
For Dummies.)

III*mpter

22

Get ready to. . .

w= [mport Data from Excel to an
Access Table

w= Link an Excel Worksheet fo an
Access Database

= Update an Access-to-Excel Linked
Table
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Chapter 22: Using Excel with Access

Import Data from Excel e
to an Access Table o=, | i

1. Prepare your Excel worksheet data before importing into
Access:

e If you don't want to import the entire worksheet, create a
named range in the Excel workbook that contains the cells
you want to import. (See Chapter 2.)

e Make sure the cells are in a contiguous table format. If the
worksheet contains merged cells, the contents of the cell
are placed in the field that corresponds to the leftmost col-
umn, and the other fields are left blank.

e If the Excel spreadsheet has a cell containing more than
255 characters, Access truncates the data to 255 characters.

2. Ifyou don't already have an Access database created, in Figure 22-1
Access, choose FileroNew. If you already have an Access data-
base, open the database and skip to Step 4.

Get External Data - Excel Spreadsheet (Bl

Select the source and destination of the data

3. Click the Blank Database button and then click the Create
button. (See Figure 22-1.) Specy the sesce o th ot

. . Eile name: |11 Users|Dianet DocumentskCustomer Crders.xlsx __mwsem
4. Choose External Data=>Excel in the Import & Link group. The =
Get External Data — Excel Spreadsheet dlalog box appears. Speciy how and where you want to store the data inthe current database.

@ Import the source datainto a new table in the current database.

5. Click the Browse button to locate and select the Excel file from e o o s e e ke e et A A ek ke
which you want to import data and then click Open. The file- © Boventacopyof the records o the Eabes [a5eT
name appears lﬂ the Flle Name text bOX. (See Figure 22_2) :;ttr;\eesfoi?;fgatf:‘l/e\/lﬁﬁgisée'lrcecfelzitgld”I:dt?‘\;hdea’t:?a’sq:wthEtab‘e‘]F the table does not exist, Access will creste it, Changes made

) Link to the data source by creating a linked table.

6. Specify whether you want the data in an existing table or a new sl st sl it A i koo s i, hares dato o s Sl
o . . . reflected in the linked table. Hawever, the source data cannot be changed from within Access,
table. If you want it in an existing table, select the table name.

If you select an existing fable, Access appends the data to the table. Make the sure
the number of columns in the worksheet or named range matches the number of
fields in the table. The name, data type, and position of each column must also match
those of the corresponding field in the Access table. ,

Figure 22-2

7. Click OK. The Import Spreadsheet Wizard appears.
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Import Data from Excel to an Access Table

8. Select the worksheet you want to import or a specific named
range. If the workbook has no named ranges and only one
worksheet, you don't see this screen.

You can import only one worksheet or named range at a time during an import oper-
ation.

9. Click the Next button and then specify whether the first row
of your worksheet contains column headings. Access creates
field names from the column headings. (See Figure 22-3.)

; If your worksheet has headings, you may not see some of the next several screens.

10. Click the Next button and then if desired, assign alternative field

L . Figure 22-3
names to each column by dlicking the desired column and typ-
ing a name in the Field Name text box. (See Figure 22-4.)
L=l Import Spreadshest Wizard =
If a column name violates the field naming rules in Access, Access assigns a valid e e e S s e S S e T S
name fo the field. RO
Field Name:  [Company| DataType: [Text =]
Indexed:  [No [=] [F]Denotimport field (skip)

11. In the Data Type drop-down list, assign field data types to
each column, if desired.

First Nelast NemeCompan:
[Fon b oud
am mith
teve |inderson
tanley (Chen
pames  [Babcock
Barnett
Lymn ol
boy evers

Ficlds Fields
1000 W, Oak Street tlanta fj

10 Wayne hve Lino Lake
104 U.5. Highway 31 ewark
5092 Woodland Drive orcross
029 Bluff Road [ndianspo
11 West Carlisle Street Indianapo
5100 £ Harcourt Streec [ndianapo
343 Commerce Sguare Dr aristta
10830 indre Drive Indianapo
402 N Hagnolia Ave oreross
F.0.Box 730444 alparais
47 & Indiana Tndianapo
772 Collections Center Drive Muncie
1044 Harrison Street Indianapo| ~
»

13. Click the Next button and then select an option regarding the e
primary index key. You can let Access create one for you, select Figure 22-4
your own primary key, or choose not have a primary key.

14. Click the Next button.

12. In the Indexed drop-down list, choose Yes or No if you want
(or don’t want) the field indexed.

[fonya  [Houser
ke Davis
Lee

[ee[2]=]]a]=[o] ]
T
2
g
3

(Optional) Click a column you don’t want to include and then select the Do Not Import
Field (Skip) check box. You can skip columns during the import, but you can't skip
rows.

H
i
1
2
L

=
"
=
i
a
&

Gaertner
ever
Cabhot

H
o
o
I
o
a

H
-
=
o
a
&
&
n
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Chapter 22: Using Excel with Access

15.
16.

17.

18.

If you are creating a new table, enter a name.

Click the Finish button. Access imports the data and prompts
you to save the import settings for future imports.

If any errors occur during the import, Access creates an error log table in the database
and displays the name of the table in a message. Open the error log table and review
the errors.

Click the Close button. A new table appears in Access, as
shown in Figure 22-5.

To import multiple worksheets or named ranges, repeat the import process for each
worksheet or range.

Double-click the Access table and review the imported data.
(See Figure 22-6.) Keep in mind the following facts about
imported data:

Imported data: Importing a worksheet into Access creates
a duplicate copy of the data and doesn’t make any changes
to the source Excel file.

Graphical elements: Access doesn’t import graphical ele-
ments, such as logos, charts, and pictures.

Data type: Access determines the data type based on the
first 25 rows of data. If any values beyond the 25th row
aren’t compatible with the chosen data type, Access
ignores those values and doesn’t import them.

Calculated values: Access imports only the results of a cal-
culated cell, not the formula itself. For example, if cell D13
contains the formula =B13*C13, which results in a value
of 100, only the value of 100 goes into Access, not the for-
mula =B13*C13. To update the formulas, you can link the
Excel worksheet to Access. See the following section.

Hyperlinks: Access imports cells containing hyperlinks as
text fields.

(&l = Databasel : Database|
Home Create Esternal Data Database Tools
- = »jTextF\Ie =
7, I fE @ ::@ j T e
s [ B @7 A L File LR
Sawed Llinked Table Excel Access ODBEC Sawed Excel  Text bt
Tmports  kanager Datahase %38 More © Exports File  F
Import & Link
All Access Objects @ «
Search. P
Tables 3
T orders
Figure 22-5

Figure 22-6







Chapter 22: Using Excel with Access

9. Double-click the Access table which, as shown in Figure 22-9,
appears as an Excel icon with an arrow next to it, indicating
that the table is an Excel link. Keep the following in mind
when reviewing the data in Access:

e When you create a link, Access creates a new table but the
data is actually stored in the source worksheet, not in the
database table. Any changes you make to the data in the
Excel source workbook updates the Access table. Any
change you make in the Excel file, Access automatically
reflects in the linked Access table.

e Graphics (such as logos, charts, or pictures) stored in the
Excel worksheet aren't visible in Access.

< You can’t change the field data type or size.

e The source cells that contain formulas display only as
results in Access, and you can’t modify the values in
Access.

e Access stores Excel cells longer than 255 characters in a
memo field that displays only the first 255 characters.

If you delete the table from Access, you're delefing only the link, not the actual Excel
worksheet.

Update an Access-to-Excel Linked Table

1. Open the Access database you want to update. The Security
Warning message shown in Figure 22-10 appears.

2. Click the Enable Content button.

212

Figure 22-9

All Acceys Objecs
Search.

st

"% ales Geder:

1] Sromily Waining  Tos

rtile Comtert
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Creating a
Commission
Calculator

Suppose you're a business owner and you pay your salespeople a sliding
commission rate based on their total sales for a specified period, such as
a month. First, you need a sheet of paper to list each salesperson’s sales.
Then, at the end of the period, you have to subtotal each person’s sales.
Finally, you have to figure out which commission percentage to give each
person based on that subtotal.

A Commission Calculator worksheet, designed using basic Excel features,
along with several Excel functions (SUMIF, COUNTIF, and nested IF state-
ments) can do everything for you except enter the individual sales. Excel
saves you precious time and reduces the chance for human error. To set up
this worksheet, perform the following tasks:

w= Enter basic headings.
w= Create a sliding commission rate table.
m= Define the data input area where you track the individual sales.

== Design the calculation area where Excel calculates the totals and
commission.

== Enhance the worksheet appearance so it’s easier to read.

m= Protect and save the worksheet as a template.

I“*napter

Get ready to. . .

w= Enter Headings

w= (reate the Commission Table................
w= Define the Sales Data Input Area.........
w= Total Sales with the SUMIF Function......

w= |Jse the COUNTIF Function fo
Count Sales

w= Calculate Commission with a Nested
IF Statement

w= (reate Totals

w= Make It Look Nicer

w= Protect Your Work

216
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27
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Chapter 23: Creating a Commission Calculator

Enter Headings

1.

In cell A1, type Commission Calculator and in cell A2, type
for the month of.

In cells A3, B3, C3, and D3, type the following column head-
ings: Salesperson, # of Sales, Total Sales Amount, and
Commission Amount, respectively.

Beginning with cell A4 and moving down the column, type
the names of your salespeople.

In column A, in the cell below your last salesperson name,
type Totals.

Move down three more rows and type the following column
headings across into cells A17:B17: Sales Date, Transaction
Number, Salesperson, Sale Amount. Widen the columns

as needed. Your worksheet looks like the one shown in
Figure 23-1.

Create the Commission Table

1.

216

In an unused area of the worksheet, perhaps on another sheet
in the workbook, enter your commission breakdown. Enter
the sales dollar breakdown.

In the cells next to the sales dollar breakdown, enter the com-
mission percentage.

Add any desired headings to further identify the table.

Format the sales dollar values as currency and format the com-
missions as percentages (see Figure 23-2). (See Chapter 6.)

A B ©
Commission Calculator
for the month of
Sales Person #of Sales Total Sales Amount
Steve W
Maria E
Chris K
Katrina B
Daniel
Drew C
10 Alexs
11 Spence D
12 Tim$§

13 Robert)J
14 Totals

15

16

17 Sales Date
18

19

20

(I SR

Transaction Number  Sales Person

D

Commission Amount

Sale Amount

Figure 23-1

Figure 23-2




Total Sales with the SUMIF Function

Define the Sales Data Input Area

1.

At the bottom of the worksheet where you enter the individ-
ual sales, select the cells in the Salesperson column. In Figure
23-3, I selected cells C18:C117, which gives room for 100
sales entries.

Name the selected area with a range name of Sales_Person or
something similar, and then click OK. (See Chapter 2.)

(Optional) Create a validation for the Sales_Person cells so the user chooses from a
lookup list. (See Chapter 4.)

In the same worksheet section, in column D, select the cells
to use for the sale amount. Be sure to include the same num-
ber of cells you included in Step 1. In this example, cells
D18:D117.

Name the selected area with a range name of Sale_Amount or
something similar, and then click OK.

To verify the formulas you create in the next several sections,
enter some sample data in the sales data input area.

Total Sales with the SUMIF Function

1.

In cell C4, enter the following formula and then press Enter:
=SUMIF(Sales_Person,A4,Sale_Amount). If you entered
sample data in the sales data input area, you see the total
sales for the salesperson.

The Excel SUMIF function calculates the totals of numbers that meet specified criteria.
The function first asks for the area you want fo look at, then the cell it should look to
match, and finally the amount you want the function to total. In the sales commission
worksheet example, this equates to =SUMIF(Sales_Person names
from input area, salesrep name in heading
area, total Sales_Amount for the matched
Sales_Person).

2. Copy and paste the formula in C4 to the end of
your salesperson list (see Figure 23-4). (Chapter 3

shows how to copy formulas.)

A
11 SpenceD
12 Tim$S
13 |Robert)
14 Totals
15
16
17 Sales Date

Transaction Number  Sales Person

Sale Amount

Figure 23-3

Figure 23-4
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Chapter 23: Creating a Commission Calculator

Use the COUNTIF Function
to Count Sales

1. In cell B4, enter the formula =COUNTIF(Sales_Person,A4)
and then press Enter. If you entered sample data in the sales
data input area, you see the total number of sales for the
salesperson.

2. Select cell B4 and choose Home=Copy in the Clipboard
group. A marquee appears around cell B4.

Highlight cells B5 through the end of your Sales Person list.

4. Choose Homer>Paste in the Clipboard group. Excel dupli-
cates the formulas to include all the salespeople. (See
Figure 23-5.)

Calculate Commission with a
Nested IF Statement

1. 1In cell D4, enter the beginning function and the first parame-
ter to check the total sales for the salesperson against the
commission table. Type =IF(C4>=$K$6, (include the comma).
The reference to K6 refers to the largest amount in your com-
mission rate table.

Be sure fo place the dollar signs in front of the cell references to make them an abso-
lute reference to a specific cell.

2. Enter the first TRUE result. Type C4*$L$6, (include the
comma).

3. Enter the first FALSE result that begins another IF statement.
Type IF(C4>=$K$5, (include the comma). See Figure 23-6.

218

Figure 23-5
c D E F|]G|H 1 K L

1 Commission Table
2 Total Rate
3 Total Sales Amount G ion Amount WPTO S 999.99 3%
4 s 3,355.00 | =IF(C4>5KS6,C4*SLS6, IF(C4>$KSS, OVER  § 1,000.00 5%
5 s 1.953.00 TFogica s, value T_true] [olue i o] OVER 7%
6 S 10,702.00 OVER
7% 3,715.00
8 s 8,270.00
9 s 5,750.00
10 $ 6,929.00
1 ¢ 1,840.00
12 ¢ 3,191.00
13 ¢ 357.00
14
15
16
17 Sales Person Sale Amount
18 Tim$ $ 2,026.00
19 KatrinaB $ 2,028.00
20 Daniel § $ 1,639.00

Maria F 1.953.00
Figure 23-6




Create Totals

Enter the next TRUE result. Type C4*$L$5, (include the comma).

Enter the next FALSE result that again begins another IF state-
ment. Type IF(C4>=$K$4, (include the comma).

Enter the third TRUE result, if applicable. Type C4*$L$4,
(include the comma).

Enter the third FALSE result, which in my example is the last
level to check. Type C4*$L$3.

Type three closing parentheses (or enough to match the num-
ber of opening parentheses) and press Enter. Figure 23-7
illustrates the final formula and its results. In the example,
the total sales of $3,335.00 falls in the 5 percent commission
bracket, so the answer is $167.75.

Copy the formula to the other rows.

The Excel IF function evaluates a condifion you specify and returns one value if the
statement is TRUE and another value if it evaluates to FALSE. In this example, if the
sales are less than the first commission level, making the first condition TRUE, it calcu-
lates the sales multiplied by the first-level commission percentage. If the statement
isn't TRUE, Excel checks whether the sales are less than a second commission level,
and if so, it multiplies the sales times that commission level percentage. The nesting
continues unfil Excel checks all commission levels, resulting in a commission amount.

Create Totals

1.

In cell B14, or the cell below your last sales rep, create a SUM
function to total the cells above it. In Figure 23-8, the for-
mula =SUM(B4:B13) totals the number of sales orders.

Select the formula in cell B14. Choose Home=>Copy in the
Clipboard group or press Ctrl+C.

Select cells C14 and D14, and then choose Homer>Paste in
the Clipboard group or press Ctrl+V. Excel duplicates the for-
mulas, which total the sales and commissions, respectively.

D4 - S | =IF(CA-$KS6, CA*SLE6, IF(CA-SKSS, CA*SLES, IF(CA>$K$4, CA*SLS4,CA*5L53)))
[ D E F G H 1 1 K L <
1 Commission Table
2 Total Rate
3 TotalSales Amount  Commission Amount UPTO  $  999.99
25 3,355.00 [ 16775 OVER  $ 1,000.00
5 ¢ 1,953.00 OVER $ 5,000.00
6 3 10,702.00 OVER  $ 10,000.00
708 3,715.00
8 3 8,270.00
9 3 5,750.00
Figure 23-7
B14 - Je| =sum(B4B13)
A B c E F

Commission Calculator
for the month of

1

2

3 Sales Person #of Sales Total Sales Amount Commission Amount

4 Steve W 2 3355 167.75

5 MariaE 1 1953 97.65

6 ChrisK 6 10702 1070.2

7 KatrinaB 2 3715 185.75

8 Daniel § 5 8270 578.9

9 DrewC 4 5750 402.5
10 AlexS 5 6929 485.03
11 SpenceD 1 1840 92
12 [Tim § 2 3191 159.55
13 RobertJ 1 357 10.71
14 |Totals I 29! 46062 3250.04
15

16

17 Sales Date Transaction Number  Sales Person Sale Amount

18 3-Apr 17623 Tim § 2026
19 3-Apr 17624 Katrina B 2028
20 3-Apr 17625 Daniel § 1639

4-Apr 17626 MariaE 1953

Figure 23-8
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Make It Look Nicer

1. Apply currency number formatting to cells with currency.
(See Chapter 6.)

2. Widen columns to allow all cell data to appear. (See
Chapter 6.)

Enlarge the font size of the headings. (See Chapter 6.)
Merge and center cells A2, B2. (See Chapter 6.)

Merge and center cells C2 and D2.

S B W

Apply any other desired formatting such as a different font, Figure 23-9

bold, italics, and so forth. See Figure 23-9 for an example. ——

. BT P == S — : hﬁ g 5
g (B u-O- S-Ar el s -w A el b

Protect Your Work T

Commiission Calculator

1. Remove the sample data you entered in cells A18:D117.

2. Select the cells in which you enter the entry month and the b s :
sales data. In my sample spreadsheet, cells A2 and A18:D117 = g & 3
are the only cells in which I want to enter variable data. o : : :

3. Choose Homer>Format=>Lock Cell in the Cells group which n :_::;‘ni.., o : :
unlocks the selected cells. See Figure 23-10. 13 fabeith o s :

14 Totals 0 5 5

4. Choose Homer>Formatt>Protect Sheet in the Cells group. 2

(Optional) Deselect the Select Locked Cells check box and/or assign a password to =
prevent other users from unprotecting the worksheet. e, 3
Figure 23-10

5. Click OK and save the workbook for future use.

Save the worksheet as a template to protect it from changes. (See Chapter 10.)
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Tracking Medical
Expenses

Wth today’s high cost of medical care, few can afford to be without
medical insurance. In fact, many have two insurance companies —
perhaps Medicare and a supplemental insurance, or insurance through your
employer and your spouse’s employer.

Tracking medical costs is very important, especially when filing your annual
tax return. In this project, you create an Excel spreadsheet that efficiently
tracks your expenses, generating totals and even sorting prescriptions from
the rest of the medical-expense totals. See at a glance the total of your medi-
cal expenses, how much is paid by your insurance companies, and — most
important — how much you have to pay out-of-pocket.

To accomplish this task, you use a number of Excel features including data
validation, duplication of worksheets, the creation of totals from other
worksheets, and a few Excel mathematical functions.

I hope your health is good, and you won't need to use this worksheet a lot!
But if you must . . . you'll be glad it’s here.

I“%apter

Get ready to. . .

w= Enter Text Headings ................ovvveeveveeeee 222
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Chapter 24: Tracking Medical Expenses

Total Paid Qut of Pocket
Total Due

Totals
Descriptior Total AmoL Insurance : Insurance Write Off  Paid Out o Check Nun Amount Due

Enter Text Headings [
1. In cell A1, enter a heading for the worksheet, such as 2010 : Fel ey nquence
Medical Bill Tracker. ; BillDate  Provider  Rx?
2. In cells B4 and B5, type Billed and Paid by Insurance, &
respectively, and in cells D4 and D5, type Total Paid Out of s
Pocket and Total Due, respectively. Figure 24-1
In cell D7, type Totals.
4. 1In cells A8:K8, type the following: Bill Date, Provider, Rx?,

Description of Services, Total Amount Billed, Insurance #1
Amount Paid, Insurance #2 Amount Paid, Write Off, Paid
Out of Pocket, Check Number, and Amount Due, respec-
tively. Your worksheet looks similar to the one shown in
Figure 24-1.

Figure 24-2

Create Totaling Formulas

222

1.

In cell E7, enter a formula to calculate the entire Total
Amount Billed column, which begins at cell E9 and runs
through at least row 100. Your formula should read
=SUM(E9:E100). You can make the formula longer or shorter
depending on how many items you might list in a year.

Select cell E7 again, and then grab the AutoFill handle and
drag across to cell K7. This duplicates the formula from F7
through K7. (See Figure 24-2.)

Delete the formula in cell J7.

In cell C4, which references the total amount billed as shown
in cell E7, type =E7 and in cell C5, type =F7+G7, which adds
the insurance payments.

In cell E4, type =17 to reference the total out-of-pocket
expenses and in cell E5, type =K7 to reference the total
still due.




Specify Data Validation

Calculate the Amount Due

1.

Create a formula in cell K9 by typing =E9-SUM(F9:19). This
formula subtracts the total payments made from the total
amount billed.

Notice in Step 1, the compound formula is created with a standard reference and an
Excel funcion.

Copy the formula in cell K9 from cell K10 down through the
end of the calculation area. Use the same number of rows as
you did in Step 1 of the section “Create Totaling Formulas,”
earlier in this chapter. Figure 24-3 shows a value of 0 in each
pasted cell.

Specify Data Validation

1.

In two adjacent worksheet cells, preferably in an unseen
worksheet area, type Yes and No. I'm using cells P1 and P2.

Select cells C9:C100, or whichever row you use as your last
worksheet row.

Choose Datar>Data Validation=>Data Validation in the Data
Tools group. The Data Validation dialog box appears. (See
Chapter 2 for more information on data validation.)

From the Allow drop-down list, choose List and then click
the Collapse button in the Source box. The Data Validation
dialog box temporarily collapses.

Highlight cells P1 and P2 (or whichever cells you used in
Step 1) and then press Enter. The Data Validation dialog
box reappears.

Click OK. When you click cell C9 or lower, notice that a
drop-down arrow appears with Yes or No choices, as shown
in Figure 24-4.

K9 - Fe | =E9-5UM(F3:13)

A B
2010 Medical Bill Tracker
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2

3 =
4 Billed 0 Total Paid | 0

5 Paid by Ing 0 Total Due 0
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7 Totals 0 0 0 0 0 0 0

8 |Bill Date  Provider Rx?
9

10
1"
12

C

D E F G H J K L=

Descriptior Total AmoL Insurance : Insurance <Write Off  Paid Out o' Check Nun Amount Due
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Duplicate the Worksheet for Other Family Members

Add Protection from Accidental Changes

1.

Select cells A1 and A2 and choose Homew>Format>Lock Cell
in the Cells group to unlock the selected cells.

Select cells A9:J100 (the data entry area) and unlock them as
well.

Choose Homer>Formatr>Protect Sheet in the Cells group.

Deselect the Select Locked Cells check box and then click OK.
(See Figure 24-7.) The worksheet is now protected against
accidental changes.

If you need fo unprotect the sheet fo make changes, choose Home=>Formatcs>
Unprotect Sheet in the Cells group.

Duplicate the Worksheet
for Other Family Members

1.

In cell A2, type the patients’ name. For this example, I
entered Eugene Smith. (I also formatted the area to coordinate
with row 1.)

Right-click the Sheet1 tab and choose Rename. Rename the
worksheet with the patient name, in this case, Eugene, and
press Enter.

Right-click the newly renamed tab, choose Move or Copy,
and then select the Create a Copy check box.

Click OK. Excel adds an identical sheet marked as Eugene (2)
or whatever you named the tab in Step 2.

In the duplicated worksheet, click cell A2 and enter the sec-
ond patient’s name. I use Catherine.

Rename the duplicated sheet by following Step 2 with the
second patient’s name. (See Figure 24-8.)

Protect Sheet

Protect worksheet and contents of locked cells

Password ko unpratect sheet:

Allow all users of this worksheet to:

Select locked cells

[T Farmat colurns
|:| Format rows

[ 1nsert columns
[ Insert rows

[T 1nsert hyperlinks
] Delete columns
[ elete raws =
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Figure 24-7
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cells, Excel (continued)
non-blank, filtering for, 159
number of, 5
ranges, 23-25
searching by format, 111-112
selecting, 15, 18
shifting after deletion, 22
shifting after insertion, 21
sorting by format, 109
wrapping text, 64

cells, PowerPoint, 202

cells, Word, 194, 197

charts. See also data visualizations; Sparklines.

creating, 116-126
in PowerPoint slides, 204, 206
printing, 134
circular references, troubleshooting, 34
clearing
cell formats, 71
data groups, 155
data visualizations, 72
outlines, 154
clip art, 79. See also graphics.
closing Excel, 7
collaboration. See sharing.
color
arrow lines, 74
cell background, 63, 109
charts, styles, 123
coding workbook revisions, 191
fill, graphic objects, 75
filtering by, 164
fonts, 62, 109
gridlines, changing, 131
lines (graphic), 74
the Ribbon, 136
scales, cells, 72

schemes, 136
text box borders, 78
transparent, 77
WordArt text, 80
worksheet tabs, changing, 89
columns, Excel. See also worksheets.
###### (pound signs), error display, 58
arrays, 33
database, 147
deleting, 22
freezing titles, 98
headings, printing, 131
hiding/unhiding, 50
importing into Access databases, 209
inserting, 21
locating data in, 43
merging, 144
number of, 5
PivotTables, 166-167
repeat printing, 130
resizing, 16, 58-59, 69, 102
searching, 110
shifting after deletion/insertion, 21
skipping when importing into Access, 209
sorting, 106
columns, PowerPoint, 202
columns, Word, 194
commands, keyboard shortcuts, 8
comments, 110, 136, 187-189. See also
annotating.
commission calculator, 216-220
common date filters, 164
comparisons, 100, 161-162
Compatibility functions, 44
compatibility with older files/workbooks, 10
compound formulas, 29
CONCATENATE function, 144

conditional cell formatting, 71, 109
converting older versions of files/
workbooks, 11
copying
cell data (Ctrl+C), 18. See also copying and
pasting.
Excel cells to Word, 194
formatting, 69
formulas, 31-32
outline subtotals, 153
Sparklines, 114
values, with AutoFill, 20
Word tables to Excel, 197
worksheets, 87-88
copying and pasting, 18
COUNT function, 42, 150
COUNT NUMBERS function, 150
COUNTA function, 42
COUNTBLANK function, 42
COUNTIF function, 218
counting items, 30, 40, 150
cropping pictures, 82
custom headers and footers, 133
cutting cell data (Ctrl+X), 18

o) e

dashed lines versus solid, 74

data bars, 72

data entry, 16-18, 20, 25-26, 52. See also
cell data.

data entry forms, 148-149. See also databases;
outlines.

data range formats, extending, 138

data types, 13, 210. See also specific types.

data visualizations, 72. See also charts;
Sparklines.
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formatting (continued)
PivotTables, 171, 173

text, 40, 64, 171. See also formatting, fonts;

Text functions.
formulas
definition, 13
formats, extending, 138
hiding/unhiding, 54
monitoring, 102
overview, 28-38
results, searching, 110
searching, 110
freezing titles, 98
Function Wizard, 38
functions, 37-38. See also specific categories;
specific functions.
FV function, 45

o (G o

gradients, 75, 80

graphics, 74-84, 210

graphs. See charts; data visualizations.
gridlines, 117, 124, 131

grouping data, 84, 155, 173

o/ o

help, 136, 142

hiding/showing. See also security.
cells, 50, 54
formulas, 54
outline group details, 155
outlines, 154
rows and columns, 50
subtotal details, 150
workbooks, 48
worksheets, 89

highest value, determining, 30
HLOOKUP function, 43

holidays in a date range, calculating, 41
horizontal data alignment, 61
hyperlinks, 92, 210

o] o

icons
data visualization, 72
Excel icon, in Word, 196
sizing, 72
switching worksheets views, 97
IF function, 39, 218
illustrations. See graphics.
images. See graphics.
indenting cell data, 69
inner row fields, 172
insert options, Assistance Tags, 142
italic fonts, 63

° ] °
jumping around, 14, 110
oK o

keyboard shortcuts, 8, 181

o/ o

labels, 13, 16

landscape orientation, 129
LEFT function, 40

LEN function, 40

lines (graphic), 74, 78, 80

linking
Access databases to Excel, 207, 211-212
worksheets to PowerPoint slides, 205
worksheets to Word documents, 196
lists, 25, 107-108
loan payment, calculating, 46
locking/unlocking. See also security.
absolute formula references, 32
cells, 50, 51
data entry in restricted areas, 52
marking workbooks as final, 49
workbooks, 49
worksheets, 51
Lookup & Reference functions, 43
LOWER function, 40
lowest value, determining, 30

oIl o

macro-enabled workbooks, 181
macros, 179-184
magnification percentage, 96
mail merge form letters, 198-199
mailing labels, 200
manual page breaks, 128
marquee (marching ants), 30
Math & Trig functions, 42, 150, 217
MAX function, 150
medical expenses, tracking, 222-226
merging. See also mail merge form letters.
cells, 62
columns, 144
workbooks, 192
messages, data entry validation, 25
MID function, 40
MIN function, 150
mini toolbar, 66, 136
min/max values, displaying, 150
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modal values, determining, 44
MODE function, 44
month, sorting by, 108
mouse pointer, upside-down cross, 78
moving

cell data, 18-19

cell focus, 14

charts, 120

graphic objects, 81, 84

PivotTables, 168, 175

tables, PowerPoint, 202

Watch Windows, 102

Word tables to Excel, 197

worksheets to a different workbook, 88
moving around in Excel, 14, 110
multiplying values, 150

o\l e

#N/A (formula value unavailable), 35
#NAME? (unrecognized name), 34
named ranges, 29, 210
naming

Excel files, 9, 12

fields, PivotTables, 171

macros, 180

PivotTables, 175

worksheets, 87
navigation, 14, 110
NETWORKDAYS function, 41
non-blank cells, 42, 159
nudging graphic objects, 81
#NULL! (non-intersecting ranges), 35
#NUM! (illogical argument), 35
number of pages, in headers and footers, 133
numbers

above or below average, filtering, 163

comparing, 162

filtering, 162-163

formatting, 58, 171

sorting, 104, 105

stored as text, troubleshooting, 34
top or bottom, filtering, 163

o () o

odd/even pages, headers and footers, 132

operators, 28-29. See also specific operators.

options, Excel, 137-138. See also specific
options.

order of precedence, 29

outer row fields, 172

outlines, 150-156. See also data entry forms;
databases.

o pPoe

page breaks, manual, 128
page margins, 130, 132
page numbers, in headers and footers, 133
paper orientation, 129
paper size, 129
passwords, 51-52, 54
paste options, Assistance Tags, 142
Paste Special, copying formulas, 32
pasting cell data (Ctrl+V), 18. See also copying
and pasting.
patterns, 75, 80
pictures. See also graphics.
in chart data series, 126
in headers and footers, 133
replacing, 77
styles, 76
PivotTables, 166-178
PMT function, 46
portrait orientation, 129

PowerPoint, integrating with Excel, 202-206
previewing results, 131, 136

printers, selecting, 134

printing, 128-134, 154

privacy, 51, 53. See also passwords; security.
PRODUCT function, 150

PROPER function, 40

protecting data. See security.

oQo

Quick Access toolbar, 8, 139, 184

o R o

ranges of cells, 23-25
read-only files, 48-49
recently used Excel files, list of, 10
recording macros, 180
records, database, 147
#REF! (invalid cell reference), 35
Reference functions. See Lookup & Reference
functions.
referring to other worksheets, 90-91
reflections, WordArt text, 80
removing. See also deleting.
cells from Watch Window, 102
data entry validation, 26
filters, 159
formatting from PivotTables, 173
renaming. See naming.
repeating rows and columns, 130
Replace command, 112
replacing search results, 112
reports. See printing.
resizing. See also scaling.
charts, 119
columns, Excel, 16, 58-59, 69, 102
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text
effects, 80
filtering, 161
formatting, 40, 64, 171. See also formatting,
fonts; Text functions.
length, data entry validation, 25
outlines, graphic objects, 80
sorting, 104, 105
text boxes, 78. See also WordArt.
Text functions, 40, 44, 144. See also format-
ting, text.
textures, graphic objects, 75
themes, 70. See also styles.
Thesaurus, 140
thickness, graphic lines, 74
tiling worksheet windows, 99
time. See Date & Time functions; date and
time.
Time functions. See Date & Time functions.
titles
charts, 116-117, 121
freezing, 98
in merged cells, 62
tracking
medical expenses, 222-226
workbook changes, 190
transposing cell data, 19
Trig functions. See Math & Trig functions.
TRIM function, 44
trimming unwanted spaces, 44
truncating imported data, 208

olf o

underlined fonts, 63
undoing data entry, 17
unhiding. See hiding/showing.

unlocking. See locking/unlocking.
UPPER function, 40
user interface, 6

o (/o

validating data entry, 25-26
validation type, specifying, 25
#VALUE! (invalid cell address), 34
values, 13, 16, 20, 25, 32

VAR function, 150

variation, calculating, 150

VARP function, 150

vertical data alignment, 61

views, worksheets, 97

VLOOKUP function, 43

o (f/ o

Watch Window, 102
Web addresses, as hyperlinks, 92
weight, graphic lines, 74
whole values, 16
widening. See resizing.
Word, integrating with Excel, 194-200
WordArt text, 80. See also text boxes.
workbooks, 9-12, 48-49, 101, 181, 189-192.
See also comments; documents; Word,
integrating with Excel; worksheets.
workdays in a date range, calculating, 41
worksheets. See also cells; columns; data
entry; documents; rows; Word, integrat-
ing with Excel; workbooks.
copying, 87-88
deleting, 86
emailing, from a hyperlink, 92
hiding/unhiding, 89

hyperlinks, inserting, 92

inserting, 86

linking to Access, 211-212

locking/unlocking, 51

making current, 86

moving to a different workbook, 88

navigating, 14

in new workbooks, default number of, 136

passwords, 51

in PowerPoint slides, 204-205

printing, 134

referring to other worksheets, 90-91

renaming, 87

tab colors, changing, 89

views, 96-101, 136

Web addresses, as hyperlinks, 92
wrapping text, 64, 80

o/ o

zip codes, formatting, 68
zooming in or out, 96
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